[RESPONDED] Microphone not really working

Hello, having the exact same problem.
Out of the box it didn’t work. Then installed the new BIOS and it did work. Put the computer on sleep, and the next day it produced mostly noise impossible for the other person to hear you.

seems like if you put the computer to sleep, the mic never turns back on properly

I can confirm that this is not the case with mine, I used sleep every day and got no problem since the replacement of the webcam/microphone module.

Does it work again if you reinstall last BIOS (3.07)? If so, does it become noisy after reputing to sleep ?

My batch 8 laptop had this problem, I contacted FW support and after a number of tests they sent a new microphone/camera card, took 5 min to fit and now the mic is working :slight_smile:

1 Like

Again batch 8, seems there were a issue with microphone/webcam module in this batch

BIOS 3.07 here. Just received my laptop 2 days ago, so I assume batch 8? Unsure where to find that.

My microphone also doesn’t work, but I noticed the strangest thing when recording a video about it for support:

When I unmute the mic records a POP! (like when a jack is plugged in) at whatever volume the mic unmutes to. Can other folks try this to see if it’s a symptom of the Dead Mic issue?

While recording: set your mic volume max, mute, unmute.

You should have nothing but 1 loud POP when you unmuted in your recording.

I am curious if anybody can reproduce that!

You only have now a batch number for Europe only:

What batch am I? (Is it even relevant anymore?) - #6 by Fraoch

If I understand what a POP is, I would say that I had that :

  • For what ever reason the microphone was picking me jamming on keyboard but not speaking.
  • If you try to pinch your screen bezel, while recording same it was picking that up very clearly.

At some point I was even considering the possibilities that the microphone was mounted upside down on my defective webcam/microphone module…

With the new module, while recording (starting with mic on) there a little pop on the recording but I have this to on my desktop when I plug/unplug microphone when recording.

note: it is early in the morning, sorry if my explanation are not great :laughing:

1 Like

I’m working with Support and while they’re great, this issue has only gotten stranger for me:

After removing and re-seating the webcam module, the mic still would not record audio.

Last night I closed my laptop lid and went to bed disappointed. This morning I opened the lid, it came out of sleep, and I noticed the mic volume picking up noise! I immediately made a recording and the mic worked!

Sadly after rebooting it is broken again. Putting the laptop to sleep and waking it back up does not appear to be sufficient to get it working again. I tried pinching the bezel as @Cleber mentioned above with no luck.

Have you tried reset the RTC too?

Was it a good sound or very noisy (like speaking with hair dryer running)?

Your case seems to be indeed stranger than mine :thinking:

Have you tried booting for example an other Linux distro USB ? (Just saw your post on the fedora Thread)

What seems weird to me is it appear you have either good sound or no sound at all…

I don’t even know what this means, much less how to do it. :sweat_smile:

With the mic input volume set at 50% (in Fedora 35), it sounded good. Higher than that caused distortion (clipping? limiting? I’m not very knowledgeable about audio terms), but it did not have overwhelming background noise that I remember.

I tried Ubuntu 20.04 and the mic did not work. I even tried to install Windows, but neither Windows 10 nor 11 would detect the trackpad so I gave up trying to install it.

I don’t know if it is truly useful but support advise me to do it after I completely removed the mic module…

If you do it, be gentle on the battery connector there are few people who bend the pins and damage the motherboard’s side of the connector. Just take your time, and pull/push straight the connector.

If you don’t feel comfortable doing it, then don’t.

A friend just received their Framework laptop and installed Fedora 35 as well. They have had 0 mic or other issues. Everything just worked, so I don’t think this is Linux or distro related.

I am having the same problem I think. Microphone not picking up voice really. If I tap on the bezel near the microphone it picks that up very clearly. Going to contact support as recommended.

1 Like

I had the same issue, I contacted support and they sent me a new webcam module and now it works great. I ordered my laptop around the time this topic was created so maybe it was an issue with one specific batch of webcam modules.

1 Like

I’m in Batch 6 and have the same issue, the mic is only picking up white noise. Tried re-seating the webcam module and recording without the bezel but it made no difference. I’ll try getting a replacement module but I’m in one of the countries where Framework doesn’t ship so I might just be SOL for now.

I am from the September 2022 batch, not sure what batch # that was.
Same problem as several people above, any bump on the bezel, keypad, even on the desk next to the computer is picked up. But in order to hear even the faintest hint of my voice I have to amplify the sound until the white noise sounds like a leaf blower.

The mics are, however, reproducing those contact sounds at the level that I would expect (very loud), which I assume means that the MEMS membranes are working properly. Something must be preventing the air from hitting the membranes.

I tried the microphones without the bezel and there was no change, so it isn’t a problem with module/bezel misalignment.

From visual inspection of the microphones, I can see inside the sound inlet what looks like a webbed or spotted surface. Are the Framework microphones bottom port or top port MEMS? I’m guessing that is the backplate, as I would expect the membrane to be smooth. It’s too small for me to see whether there are problems with the backplate: maybe it’s not perforated correctly?

Just follow the guide, just to see in the first place if everything is connected. It is mostly taking off the magnetic bezel :+1:.

I would contact support before taking step forward. They will ask you I think to try different OS and/or USB live key.

Good luck :slight_smile:

1 Like

Thanks Cleber,

I will contact support eventually, but I’m playing around a bit first :smile:

If several people have had problems with these modules, it would be good to know what the problem actually is.

In my case it won’t be either a connection problem or an OS problem, otherwise my mics wouldn’t be picking up the contact sounds (bumps, taps, etc.) as clear as day.

1 Like

Just thinking out loud, but is it possible that these modules are somehow working inverted?

As in: Instead of removing the background noise, they remove the speech?

Because your experiences truly sound like that.

If you open your alsa or pulseaudio mixers (whatever you use), do you actually see a decent amount of noise when talking in a normal level with a 50cm distance?

Also, anything suspicious on dmesg?

I think there is a problem with the kill switch on my microphone?

Here is a recording with the microphone enabled (no red bar visible): link (HEADPHONE WARNING)

Here is a recording with the microphone disabled (red bad visible): link

image of my setup

So it appears as though turning it “on” is doing something terrible to the compression/bitrate/idk, while turning it “off” makes it work perfectly fine? This is a serious problem for both usability and security. I have been running around with my microphone off (red bar) for privacy, but apparently, sound is still accessible - just garbage.

In that case, contact support I am sure they’ll issue a replacement of microphone / webcam module or bezel.

1 Like