[RESPONDED] NVMe is lost after resuming from sleep FW13 AMD

I cannot get suspend to work properly, or rather waking it back up:
After awakening, the nvme device is lost and thus the system freezes, crashes and panics.

It can be replicated on a live distro as well, where the nvme just disappears and remains unreachable.

I have tried to following boot commands to mitigate the issue, but none of them worked:

  • nvme.noacpi=1
  • rtc_cmos.use_acpi_alarm=1
  • mem_sleep_default=deep
  • pcie_aspm=disabled
  • acpiphp.disabled=1
  • nvme_core.default_ps_max_latency_us=10000

The arch wiki recommends s3 sleep instead of s2idle when running into this issue, but when checking /sys/power/mem_sleep, only s2idle is available. Is s3 sleep unavailable on AMD frameworks?

The NVMe in question is an (old and crappy) 1TB ADATA SX6000. Suspension worked fine with the same drive in my older AMD laptop (featuring an 3500U)

P.S. hibernate works fine

Hi @Ceremony, we see a number of posts here about issues with Arch with AMD Ryzen 7040 series.

And while we don’t officially support Arch:

s2idle is it for suspend, so that is correct. Going through the parameters:

YES: Prevents waking after five minutes:

NO: This will cause major problems for suspend on 7040 Series.

The rest of them are not needed.

My guess is you had nvme.noacpi=1 set, and were trying to address issues caused by it with the other parameters.

I have tested just the rtc_cmos.use_acpi_alarm=1 param without any of the other options, but the nvme still disappeared after sleep, so nothing really helped unfortuantely.
I’ll try a Ubuntu 22.04 live distro on a usb stick tomorrow, whether that makes any difference to rule out an arch compatiblity issue.

Also, I ordered a new pcie drive for my framework, so maybe the issue disappears with the new drive (a Kingston KC3000 2TB), so we might be able to nail it down to an incompatible drive. as for how we go from there, we’ll see!

Here is the update:
Ubuntu 22.04 live distro also loses my ADATA SX6000 after sleeping.

In the meantime, my new SSD, a Kingston KC3000, arrived and it was able to sleep just fine within Ubuntu. I am installing an arch distro now and see how that goes…

So the issue is definitely with the SX6000. How do you want to proceed with this?

To me, this is no longer an issue, as I won’t be using the problematic drive with my Framework, but others might stumble into this issue with similar drives… So do you wanna continue to troubleshoot it and fix the issue? or just pray that nobody else uses this kind of nvme? :sweat:

I think going with the new drive is the path forward. I suspect there is a conflict with the older drive somewhere that ventures into firmware territory. Sticking with the Kingston KC3000 is my recommendation.

That was the plan :+1:

1 Like