[RESPONDED] One expansion port not charging

Moving this to support for visibility.

If I plug my charger into the either of the left expansion ports, or into the right-front expansion port, the laptop charges as expected. I get the following:

❯ cat /sys/class/power_supply/ACAD/online 

❯ cat /sys/class/power_supply/BAT1/status

and when the charger is not plugged in, I get:

❯ cat /sys/class/power_supply/ACAD/online 

❯ cat /sys/class/power_supply/BAT1/status

However, when the charger is plugged into the right-rear expansion port, I get the following:

❯ cat /sys/class/power_supply/ACAD/online 

❯ cat /sys/class/power_supply/BAT1/status

Why is that? Why can’t I charge from the right-rear expansion port?

I have two USB-C expansion cards, and have tried them both in each expansion port and consistently get the above results.

Do you get the same result, when you plug the charger directly into the Framework without expansion card?

Yes .

Just moved this out of general into the section where others will see it (support).

Can you replicate this with a live USB of Ubuntu 22.04 or Fedora 38? I suspect this is likely a bad port, but getting out of an installed environment helps us to confirm.

Also, which distro, release and board generation?

Additional info:

When I am using the framework charger, the port works fine. However, when I am using a 35W charger, that’s when that one port is not working properly.

OS: NixOS 23.11.20230906.0bffda1 (Tapir) x86_64
CPU: 11th Gen Intel i5-1135G7 (8) @ 2.400GHz

This sounds like the issue, the charger itself.

That doesn’t make sense, though. The charger works on the three other ports.

The charger I am using is the new 35W charger Apple chips with their Macbook Air. It outputs 20V at 1.75A.

I understand. However if the FW charger is working, but, the other non-FW charger is failing, it’s something with that charger the laptop is not compatible with. I seen this with Apple chargers in the past. For whatever reason (firmware, etc), it creates challenges. I do not know why as I don’t own or use Apple chargers, but it’s not the first time I’ve seen this with our laptops and with others as well.

Some folks have had success, while others have had issues with Apple chargers.

I wish I had a solution, but I am unable to troubleshoot an Apple product that I don’t have access to.

May be worth opening a support ticket in case someone on the support team can see if they can replicate this.

You are looking at this from a particular viewpoint and are drawing a conclusion that doesn’t seem likely – that the charger and the laptop are not compatible with one another. The problem I see with this conclusion is that this particular charger works just fine on the other 3 expansion ports. The only way this might be the correct conclusion is if this one particular expansion port has different charging circuitry than the other ports. Do you know this to be the case?

Sorry if I wasn’t clear. Since we do not test with Apple chargers, we can only look at common themes based on this being a reoccurring thing I see crop up with certain Apple chargers.

That said, I would recommend opening a ticket to see if we can reproduce this with someone with a similar charger. No conclusion drawn - only pointed out past patterns. The best suggestion would be to get this in front of support to see if we can replicate.