[RESPONDED] Ryzen Ubuntu Install Guide Issues with fingerprint reader


After installing ubuntu and fedora, and fwupd not working for the fingerprint reader. I ended up installing windows without a product key.

Afterwards, I downloaded the FW windows 11 driver bundle, after installing that, and then reinstalling ubuntu, everything is working a lot better, and I can use the fingerprint reader in ubuntu. Hope this helps others

Original post

I followed the step 9 instructions (https://github.com/FrameworkComputer/linux-docs/blob/main/ubuntu-22.04-amd-fw13.md) and enabled the correct kernel on my framework. A few things are not working and I didn’t see anything in the docs about it:

I have secure boot enabled, is this a problem? no mention of this in the guides that i could see

Would be nice if there was just a procedural list on 1 page for the amd ryzen setup instructions post ubuntu install, instead of having to open multiple things from many steps too

Edit: I was able to fix the right click problem by installing gnome tweak tool and enabling two finger mouse click emulation. Not sure if this is the correct solution though.

Edit 2 I was able to reboot a few more times and retry the finger print stuff, and now after a really long boot, it shows the sensor, but each time i try to install the new cab file, it just says Loading… and never finishes.

Would be curious how others got their fingerprint sensor working and if the reboots stall out for minutes at a time between trying the upgrade steps


I even decided to switch to fedora.

fwupdmgr has the same problems there. to list the fingerprint device it says “failed to claim interface” usb error, and starts timing out on any other commands.

You might want to review [TRACKING] Fingerprint reader failing to register on 13th gen - #49 by Richard_Tango-Lowy. The reference to 13th gen in the title is irrelevant–the issue is with the fingerprint reader firmware.

1 Like

thanks, i had reviewed that one fully and no matter what, the fwupdmgr commands would just hang and never work, one user on there mentioned installing windows, turns out that was the only solution for me. Just glad it all works now :slight_smile:

FWIW, manually reinstalling the firmware worked for me.

It looks like Goodix (the manufacturer of the fingerprint module) have yet to upload their firmware to LVFS. However, reinstalling the firmware from the cab file that Framework have provided is enough:

wget https://github.com/FrameworkComputer/linux-docs/raw/main/goodix-moc-609c-v01000330.cab
sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab

I’m curious if anyone on the amd framework is able to run that command.

It freezes and then fwupd hangs for 5 minutes or more before crashing. Tried it in Ubuntu and fedora before doing it with the windows bundle.

Going to assume Fedora 39 pre-release and Ubuntu 22.04.3 using OEM C as it sounds like that is what was done thus far above.

  • First step, reboot to a fresh state.
  • Before trying anything with fwupdmgr, stop, go to Users, attempt to setup the fingerprint reader from there - using fprint from the command line will usually not work.
  • If this gives you an error, please take a screenshot and reply back here.
  • If Users is giving you the standard hardware error for the reader, then and only then follow the complete guide for using the fwupdmgr.

I can confirm your suspicion that it has to do with Secure boot being enabled. After a full fresh install of Ubuntu with Secure Boot disabled, the troubleshooting steps in the guides started to work and I was able to update the fingerprint reader firmware.

I had at first installed Ubuntu 22.04 with Secure boot enabled, did the whole MOK enrollment as normal with that, and I had the same issues: nearly everything involving fwupd would hang the process with a nasty error about version being too low. After some research, I found a reference to the version on Ubuntu being stuck because the later ones had issues with Secure Boot… After a lot of searching and troubleshooting, I turned off Secure boot. It didn’t work right away, but then I re-installed the whole OS (22.04) from scratch without Secure Boot and now fwupd seems to work. I was able to flash the firmware and get the reader working by following the guides after that.

The guide needs to be updated: in U22.04 at least, Secure Boot has to be off in order to flash the fingerprint reader.

1 Like

FWIW, all of this worked for me on Kubuntu 23.10 with secure boot enabled. Not exactly a relief to anyone trying to install it on 22.04 right now, but it’s probably a good sign that:

  1. Maybe you can use a live USB?
  2. It should (hopefully) be solved with the 24.04 LTS in April
1 Like

Okay, this is good news!

Edited the KB article linked within Section 8, bottom of the KB article now reflects this.

1 Like

We’ll continue to recommend supported/tested distros with secure boot off. :slight_smile: