[RESPONDED] Ubuntu 22.04 on the Framework Laptop 13

@lightrush thanks, it was an issue with the SSD. I had to put it back in again properly.

Just want to add a note about my experience with ubuntu on gen 12, 1240p laptop with the AX210 non-vpro wifi card.

The AX210 is not picked up out of the box by network manager, so had to install backport-iwlwifi-dkms and reboot. Fortunately I had a usb-to-ethernet adapter, otherwise it’d have been a bigger hassle to download the package out of band and transfer it on usb stick. The wifi worked after installing and rebooting.

Other than that, the other tweaks are quality-of-life things.

  • Since I am a mac refugee, I needed mac keyboard mappings. I found this project kinto (https://github.com/Kinto/kinto) which basically handles most of the messy details. So far I feel at home.
  • Touchpad scroll direction inverting.
  • Setting up fingerprints.

Besides the wifi thing, the distro more or less works out of the box. I lowered my expectation for battery life vs mac laptops, but other than that so far so good.

1 Like

I am on ubintu mate 22 . I just installed the ssd from my thinkpas e590 and everything worked without changing anything. Except the bluetooth… Ut after some re oots to kenel 5.15 and back 5.18 it now works like a charm!

1 Like

That’s great news :sunglasses::blush:

I am curious, could you please run
apt list --installed | grep iwlwifi

Maybe the package that Wilson mentioned was already around on your “migrated” system.

Thank you for sharing this! I setup my framework today and found myself in the exact same situation. I’m glad I ordered a USB-A module and had an ethernet adapter too.

1 Like

Has anyone else had trouble getting PSR to work on Intel 12th Gen? I just received my 1240p DIY yesterday and started going through the steps. I added i915.enable_psr=1 to the grub boot parameters and can confirm it is listed in /proc/cmdline. However, I also see

$ sudo cat /sys/kernel/debug/dri/0/i915_edp_psr_status
Sink support: yes [0x03]
PSR mode: disabled
PSR sink not reliable: yes

I’m trying to get this set up because I noticed that I am not reaching C9/C10 states in powertop with power-profiles-daemon.

My Framework laptop (DIY 12th gen.) has been working brilliantly with the default Ubuntu-MATE 22.04 LTS 5.15.x kernel. It has been rock-solid and stable until I tried installing “linux-oem-22.04” after reading the suggestion in the Framework guide. I got intermittent USB problems running the 5.17.x kernel, so I’ve uninstalled it and everything is working fine again now. I’ve got one USB-C-HDMI and an Ethernet adapter on an external USB-C-PD hub and two DP monitors on USB-C-adapter cables. This all works fine under the 5.15.x kernel.

1 Like

Does the fn lock work on 22.04? I prefer F1-F12 to be active all the time, and the media/control keys to be fn+FX, but it seems like I can’t toggle the fn lock.

I’m on a 12th Gen chipset, with the linux-oem-22.04 kernel.

Yes, the key combination to toggle the “fn lock” on/off is “Fn + esc”. I am on ubuntu 22.04 here and like yourself prefer to have F1-F12 always active (Edit: without having to use the Fn key to use them).

I am also on a 12th gen board and have that kernel package installed here but after installing it I then added the 6.0.0-1007-oem kernel as well.

$   uname -r
6.0.0-1007-oem

I do have the xubuntu-desktop package installed and use an xubuntu session and the lightdm login screen so am on a more highly modified Ubuntu 22.04 installation than yourself. Even with such modifications the fn-lock functionality still works fine here.

That didn’t work for me.

I’m still on 5.17.X. I’ll give >=6 a shot and see how it goes.

Just so you are clear with what I posted; I will note that here even on the 5.17 kernel and the original 5.15 kernel I could use the fn-lock. So I would suspect from my install that your issue is unlikely to be kernel related. If you have a problem with it, it may very well carry over to a newer kernel version as well. Good luck though, hope you find a fix.

Edit:

Just a quick check; are you using a USB keyboard or the standard framework keyboard? I have noted here that USB keyboards will often use a different combination for the fn-lock; my current logitech USB keyboard is using “Fn + caps-lock” for instance. The key combination I gave in my first reply to you is specific to the framework keyboard.

Interesting. I’m going to give it a shot anyway and try a couple other distro’s if necessary. If this follows to other distro’s it may actually be the hardware.

This is with the built-in keyboard.

1 Like

That is interesting, I was expecting different :slight_smile: .

One last check I can think of before you try other distos etc is to check your UEFI (bios) settings. On the “Advanced” tab towards the bottom is a setting “cntrl - Fn” (or named something like that); I have that set here to “Normal”, if yours is set to “swap” I’d try changing it first and see if it changes your situation before testing other distros etc.

I had noticed that setting because I’ve had a laptop in the past that had a BIOS setting for whether the Fn keys act as Fn or media keys by default, so I thought to check for a similar setting here. That cntrl - Fn setting just switches the fn button with the ctrl button that’s next to it to simulate the layout of other keyboards. Has no effect in this case.

2 Likes

Don’t know how this happened, but after trying a few other distros with the same results and coming back to Ubuntu, fn lock works now?

1 Like

I can’t get my fingerprint reader to work. Does anyone have the same issue?

systemctl status fprintd:

● fprintd.service - Fingerprint Authentication Daemon
     Loaded: loaded (/lib/systemd/system/fprintd.service; static)
     Active: active (running) since Wed 2022-12-07 10:52:58 CET; 10s ago
       Docs: man:fprintd(1)
   Main PID: 54020 (fprintd)
      Tasks: 6 (limit: 38089)
     Memory: 1.7M
        CPU: 75ms
     CGroup: /system.slice/fprintd.service
             └─54020 /usr/libexec/fprintd

Dez 07 10:52:57 vanguard systemd[1]: Starting Fingerprint Authentication Daemon...
Dez 07 10:52:58 vanguard systemd[1]: Started Fingerprint Authentication Daemon.
Dez 07 10:52:58 vanguard fprintd[54020]: libusb: error [udev_hotplug_event] ignoring udev action change
Dez 07 10:52:58 vanguard fprintd[54020]: libusb: error [udev_hotplug_event] ignoring udev action change

And the syslog says:

Nov 14 10:39:58 vanguard systemd[1]: Starting Fingerprint Authentication Daemon...
Nov 14 10:39:58 vanguard kernel: [  663.357249] usb 3-9: reset full-speed USB device number 4 using xhci_hcd
Nov 14 10:39:58 vanguard dbus-daemon[952]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 14 10:39:58 vanguard systemd[1]: Started Fingerprint Authentication Daemon.
Nov 14 10:39:58 vanguard fprintd[7236]: libusb: error [udev_hotplug_event] ignoring udev action change
Nov 14 10:39:58 vanguard kernel: [  663.649311] usb 3-9: reset full-speed USB device number 4 using xhci_hcd
Nov 14 10:39:58 vanguard fprintd[7236]: message repeated 3 times: [ libusb: error [udev_hotplug_event] ignoring udev action change]
Nov 14 10:40:04 vanguard gnome-shell[7251]: polkit-agent-helper-1: pam_authenticate failed: Authentication failure
Nov 14 10:40:15 vanguard fprintd[7236]: parse fingerlist error
Nov 14 10:40:15 vanguard kernel: [  680.889743] traps: fprintd[7236] trap int3 ip:7f26d9448ccf sp:7ffd49bc6400 error:0 in libglib-2.0.so.0.7200.1[7f26d9409000+8f000]
Nov 14 10:40:16 vanguard systemd[1]: fprintd.service: Main process exited, code=dumped, status=5/TRAP
Nov 14 10:40:16 vanguard systemd[1]: fprintd.service: Failed with result 'core-dump'.

@Oliver_Guhr please try:

sudo apt --purge remove fprintd libpam-fprintd

reboot

then

sudo apt install fprintd libpam-fprintd

I just got my laptop and installed Kubuntu 22.04. I ran sudo apt update and sudo apt upgrade with Ethernet but I don’t appear to have any Wi-Fi connections available. lshw -C network shows Wi-Fi though:

  *-network                 
       description: Network controller
       product: Wi-Fi 6 AX210/AX211/AX411 160MHz
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:a6:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:16 memory:7a200000-7a203fff

Any ideas what’s going on?

You should check out this thread: [SOLVED] Getting wifi working on Ubuntu 22.04

I had something similar where I had to delete and maybe install some Intel WiFi FW files because the first one that the driver was loading was crashing the card. When things are good they look something like this:

$ sudo dmesg | grep iwlwifi
[    5.399950] iwlwifi 0000:a6:00.0: enabling device (0000 -> 0002)
[    5.405479] iwlwifi 0000:a6:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-72.ucode failed with error -2
[    5.406543] iwlwifi 0000:a6:00.0: api flags index 2 larger than supported by driver
[    5.406560] iwlwifi 0000:a6:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.0.2.36
[    5.406957] iwlwifi 0000:a6:00.0: loaded firmware version 71.058653f6.0 ty-a0-gf-a0-71.ucode op_mode iwlmvm
[    5.537555] iwlwifi 0000:a6:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    5.693982] iwlwifi 0000:a6:00.0: loaded PNVM version 05a8dfca
[    5.706141] iwlwifi 0000:a6:00.0: Detected RF GF, rfid=0x10d000
[    5.782111] iwlwifi 0000:a6:00.0: base HW address: 04:XX:XX:XX:XX:XX
[    5.802301] iwlwifi 0000:a6:00.0 wlp166s0: renamed from wlan0

Note: failing to load a FW is fine, the driver will just try the next one. But if the WiFi core crashes because of bad FW then it just dies.

Overhaul of the 22.04 guide.

1 Like