[RESPONDED] Using elementary OS on the Framework Laptop

My biggest complaint is the single-click feature which is pretty annoying and there is no way to adjust that, change single click folder navigation to be double click instead. The OS is slick though.

Thanks @mgoggin For the suggestion on the firmware fix. My Wi-fi is working now (although Bluetooth is not) :-/

Elementary OS is quite a delight. I believe BT and fingerprint are the only other hardware I need to get working and this machine should satisfy most of my use cases as a primary driver.

1 Like

Does anybody have a way to automate the xrandr fix? I’ve found that it works for Pop! as well, but it reverts immediately after suspend. Ideally there’d be somewhere that you could place: xrandr --output eDP-1 --mode 3000x2000_60.00 so that it would be run every time you wake from sleep, in addition to running on first login.

I installed Elementary on my Framework laptop and everything worked surprisingly well after manually grabbing the wifi drivers and putting them on a flash drive since there is no ethernet port by default. Used the screen size recommendations from above and the resolution indeed is much better but can also confirm viewing black flashes sporadically. Hopefully we can track that down.

One big issue I found so far is that the touchpad occasionally drops out completely. I was able to get movement again with modprobe -r psmouse but it didn’t bring back the gestures and I don’t think this is the correct approach. Open to doing more debugging but I’m not even sure where to start in finding those logs/pinpointing gesture issues.

1 Like

Thanks @mgoggin for the wifi fix. I did use USB tethering to get a connection to the laptop, which worked via USB-C to get the firmware to install for the wifi. After that I haven’t any issues that other have mentioned. trackpad works great and bluetooth works. Only thing I have noticed, very minor though, is that the workspace switching animation are kind of jagged, not as smooth as I would have hoped for.

@cassidyjames Thank you for the screen scaling tip! 2x bothered me so much! Could you please explain what those other numbers mean and how did you come up with them?

xrandr --newmode “3000x2000_60.00” 513.44 3000 3240 3568 4136 2000 2001 2004 2069 -HSync +Vsync

It would be super handy in case I wanted to try 175% or ran into a similar issue on another laptop in the future.

1 Like

@Dmitrii_Turygin I had the same question, and found the following resources in my searching:

The manpage for xrandr gives some insight into the --newmode command:

--newmode name mode
              New  modelines  can  be  added to the server and then associated
              with outputs.  This option does the former. The mode  is  speci‐
              fied using the ModeLine syntax for xorg.conf: clock hdisp hsync‐
              start hsyncend htotal vdisp vsyncstart  vsyncend  vtotal  flags.
              flags can be zero or more of +HSync, -HSync, +VSync, -VSync, In‐
              terlace, DoubleScan, CSync, +CSync, -CSync. Several tools permit
              to  compute the usual modeline from a height, width, and refresh
              rate, for instance you can use cvt.

I can’t say that that’s particularly useful, so I also consulted the Arch-wiki:
Specifically the “Adding undetected resolutions section”

It seems like a desired resolution can be found by using the gtf or cvt commands.

Running gtf 3000 2000 60 (where the syntax is gtf x y refresh) gives the following output on my desktop:

  # 3000x2000 @ 60.00 Hz (GTF) hsync: 124.14 kHz; pclk: 513.44 MHz
  Modeline "3000x2000_60.00"  513.44  3000 3240 3568 4136  2000 2001 2004 2069  -HSync +Vsync

So I presume that’s the procedure that @cassidyjames followed.


How is the battery life for everyone running elementary? Standby battery is terrible for me. Dropped from 45% to 3% in 10 hours.

Wow, this is really great! I have been using Linux Mint 20.2. It does have experimental scaling feature and I could set scaling to 150%, but I would get horrible diagonal tearing when scrolling in Firefox or scrolling PDFs. Thank you for providing the solution! I am surprised this does not just work out of the box…

1 Like

Wait… What? That’s terrible?

1 Like

Umm yes? Why should suspend use that much battery?

1 Like

Oh suspended!!! My bad I missed that. Yeah that sounds a bit off.

Have you tried with another distro?

Not yet, I started out with Fedora but messed up the installation. I might try Ubuntu 21.04 and see how that works out.

For those who are still dealing with the huge battery drain, using TLP seems to have cut down the overnight drain on suspend by about half. Around 20% in 7.5 hours.

Thanks so much for this installation guide! First time using Elementary and loving it.

For Wi-Fi, rather than upgrade the Linux kernel, these intel driver install worked for me. See [Guide] Install Intel Wireless Drivers on Linux - #15 by NoneenoN

AX210 non-vPro
Elementary 6.1

Been using Elementary on my Framework for several months now and have been really enjoying it. Few little issues here and there (mostly solved through this forum) but pretty solid for the most part. That is, until about 2 weeks ago. Now every time the laptop goes into suspend the login screen fails when starting back up. I type in the password and it just sits there and will eventually error out. Requires a reboot to recover.

Anyone else having this issue and/or have a way to fix it?

I installed the AX210 card with ElementaryOS 6.1 for my dad and all I had to do to get it working was move the file /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm to ~/

The article I read said remove it but I wanted to make sure it wasn’t needed later. Everything else worked out of the box with Elementary OS 6.1. He’s really enjoying the laptop!

1 Like

I’m trying to install ElementaryOS I keep getting errors. I’ve tried using two different applications to build the boot stick (Rufus and Etcher) and I’ve tried using two different flash drives as the boot stick. I have the latest DIY edition model of the Framework. Does anyone know how to fix this?

1 Like

@Tuesday Same here. I just got my laptop. I think the kernel on the elementary OS install disk is too old.

@cassidyjames can you confirm that the current iso is incompatible with the newest framework laptops and, if so, update the post to note this?