[RESPONDED] Zorin OS on the Framework Laptop

Hi! My FW16 arrived and I am having some challenges - dGPU on Zorin 17.1 (22.04 LTS based)

happy to help support any investigation/troubleshooting efforts you’d like to check out. Definitely want to help Zorin and Framework succeed!

I haven’t tried libre office too much yet, but for firefox I did have some strange stalling/hanging issues before making some changes including uninstalling the flatpak and installing the snap version (required to support firefoxPWA extension, a lesson I learned with my other Zorin machines) and updating the kernel per the FW16 22.04 setup guide and since then it’s been much more stable. Are you using the FW or the Zorin kernel?

The other issue I’ve had is the fingerprint reader failing and then becoming disabled. have you tried that yet?

Per zorin support I am running 22.04d. It has seemed to help a lot but still not perfect. I’ll have to try the snap version of Firefox because I always have that running in the background .

I have had zero issues with the fingerprint reader. It just worked out of the box for me