[SOLVED] 12th Gen Laptop not charging

My 12th Gen Framework laptop running Windows 11 stopped charging today and I’m hoping for some advice. I’m using the Framework AC adapter. Here are the details:

  1. The laptop was plugged in and charged overnight. It was at 100% battery when I turned it on.
  2. When plugged in, the LED light next to the USB-C port is lit up.
  3. The battery icon always indicates that the battery is charging, whether it is plugged in or not

Here are the things I’ve tried:

  1. I plugged the charging cable into different ports (no difference)
  2. I tested the AC adapter and it works fine on other devices
  3. I’ve turned the laptop on and off again

Any advice would be very much appreciated, thanks!

I’d recommend sending a message to support while you’re waiting to see any responses here. There may be other users with advice, but support will be able to help you if its a hardware issue, and they will likely be able to give you other troubleshooting tips.

Is “Fast Start-up” enabled on your system? My guess is that the system just need a true restart.

Just started having this issue as well.
Additional details: OS is Windows 11

Windows shows as charging regardless of cable status; Tried 2 different power systems (wall power adapter of up to 100W and USBc dock of up to 90W). Both create an orange lite on the USBC card but power keeps decreasing.

Other oddity; although the windows icon shows charging, and status lists as charging, in the power and battery graph, it only shows charging when it was actually plugged in, and changes after reboots

Any update on this?
@Second_Coming I did not see anything like “Fast Startup”, unless you mean in windows? Only thing in bios is Quick boot which disables memory tests or not.
I did do the shift-shutdown in windows but no dice

Hopefully last update. I seemed to have solved my part.
I decided to try a batter unplug/replug. When I opened the laptop the LEDs started flashing red, possibly due to the OS being in hybernate at the time, or for some other reason.
I disconnected the battery, gave it a minute or two and reconnected it. Initially the lights continued to flash but then stopped.
On reboot the OS no longer showed the phantom charging icon, and replugging the charger showed the battery is now charging.

Hope this helps anyone who experiences something like this in the future :slight_smile:

1 Like

Correct. In Windows.