[SOLVED] AMD 13 7840 SSD link speed limited with PSPP disabled

Today, I’ve been running SSD benchmarks and realized something is not quite right with my Framework regarding the SSD PCIe link speed:

With “PCIe Dynamic Link Power Management” / AMD PSPP enabled and with a charger plugged in, the performance is as expected (Gen3 (~3500MB/s) without charger, Gen4 (~6000MB/s) with charger).

However, when PSPP is disabled, link speeds seem to always be limited to PCIe Gen 3 speeds (~3500MB/s), regardless of whether a charger is plugged in or not, which is disappointing as I’d love to trade some battery life for better performance.
For someone else who was disappointed with their SSD performance on battery, disabling PSPP worked, for me that is not the case: AMD 13 7840 - Samsung 980 pro underwhelming performance - #5 by Pramod

Framework 13 AMD 7840, Firmware 3.03, 2TB WD Black SN850X

Benchmarks (I only ran the sequential test):

PSPP on, no charger:

PSPP on, with charger:

PSPP off, no charger:

PSPP off, with charger:


Hey, I did some tests on my Framework 13 AMD Ryzen 7 7840U, and with the option disabled, I don’t have this issue at all. The speed is around 7000 MB/s even on battery… I’m using Windows 11, the latest BIOS version 3.05, and a Crucial P5 Plus. I hope your problem has been resolved in the meantime!

Yup, seems to have been fixed with BIOS 3.04 or 3.05, works fine now.