[SOLVED] BIOS - No boot entry + enter = Madness

  • Which OS (Operating System)? Doesn’t matter, it’s on boot. I installed Void Linux.
  • Which release of your OS (Operating System)? Rolling release, latest. (04.01.2023)
  • Framework laptop (11th or 12th generation Framework laptop) are you asking for support with? 12th.
  • If this is a Linux issue, please use the Linux tag or at least put Linux in the title. It’s not

So it looks like on the current stable BIOS having nothing to boot (boot partition broken and no external drive connected) will get you into an empty menu. If you press ENTER, the laptop will heat up very quickly and the fans will go crazy.

Does this cause some kind of loop? This forced me to force-shutdown the laptop.

I am on the 03.05 BIOS, btw.

Hi @Anachron, please open a support ticket and they’ll be happy to help. This is going to be a support ticket for sure.


I’ve tried reproducing the issue with 03.06 and removed my nvme, booted, got the no bootable device found message, pressed “ENTER” a few times. All is well, fans didn’t go crazy. Temperature stayed normal. I did this twice.

I reseated the nvme drive, but it doesn’t detect it anymore, always claiming no bootable device found.

Booted my void linux live ISO, mounted my nvme and realized:

  • efibootmgr has no Void entry anymore. Does the firmware delete invalid entries?
  • after running efibootmgr -c and efibootmgr -w I got my EFI-entries back.

However, the boot still complained about not finding any bootable devices. It told me to insert bootable media and continue with enter, which I did. However, the whole process got stuck and I had to force-shutdown.

Booting into the live ISO again, rechecking my /etc/fstab UUIDs and they are still equal!
However, my efibootmgr again is missing the Void entry. I then realized that efibootmgr -c created an entry with path \EFI\void\grubx64.efi, but the correct path is \EFI\Void\grubx64.efi.

Since it seems to have issues with upper/lower-case, I deleted /boot/EFI/Void and reran grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="void", so that it creates the files were it would expect them when the EFI-entry was created automatically by the efibootmgr.

I can now boot from my nvme again! Hooray.

This was quite a ride. Do you want me to open an support ticket for this new issue?

By the way, can I call this bug “The disappearing salesman”?

Okay first of all:

That is awesome and I will likely borrow the term in the future, giving you credit of course. :slight_smile:

Ah ha!

No need, we’re good here. And, for anyone else experiencing something similar, we have a cause/solution.

I appreciate the outstanding detective work and the update. Marking solved.

Does this mean you already figured out what is deleting those efi boot entries?
And that a fix is in the works?

Because in my mind detaching an nvme should not require me to recreate the boot entries, and it should probably also generate the correct paths itself.

No problem, I always like to tinker around and figure out whats going on.

1 Like

I agree, this is odd. If you can recreate this issue, I will remove the solved status. But as it’s working in the here and now and we have a solution to correct what happened, I marked it solved.

I mark it solved when we have a working solution to a problem. If it’s a problem that is recreated, I then remove said status and send up the chain.

Fair enough, I will try to recreate it once I have time for this again. I run a lot of different tests and the original issue was solved, which was much worse than the current one.

Like you said, it’s currently working and we have a solution to fix this, so this isn’t a high priority anymore. I’ll ping you once I have new results.

@Matt_Hartley it looks like the disappearing EFI entries is a known issue, at least on BIOS upgrades.
I could imagine this could get triggered in other scenarios possibly too?

Yes, this can happened with BIOS upgrades. This can happen. I didn’t put it together initially, but this is what happened.