[SOLVED] BIOS update help - 11th Gen Intel to 3.17

while waiting for my ryzen framework 13. I bought an 11th gen intel and a cooler master case to build a slim desktop. I got everything running, and have windows 11 installed. The mainboard came with 3.10, and i followed the instructions at Getting started guide with a bare motherboard - Creators & Developers - Framework Community to get the fw to 3.17. However, i am in a wierd loop…

  1. i don’t have a battery that can supply 65W, so i couldn’t take the advice from the link about to put a battery between the wall outlet and the fw mainboard…
  2. i initially got my left and right mixed up - and had the power on the right side of the board when i did the update, then switched it to the left… however firmware install failed on the 2nd boot
  3. now when i start with power on the left, reran the firmware updater in windows, updated till shutdown, then switched to right, and restart - firmware update failed again…

so i’m now confused if i have a PD port that hasn’t been updated. How do i check? am i in a weird state? everytime the fw update says failed, it recovers and boots into windows.

As you have tried it multiple times, its highly likely everything has been updated by now. You can see the installed firmware versions in the BIOS and can check that both PD controllers are running the same version. I have not yet flashed from Windows and would recommend going the USB/UEFI route, after applying the platform.ini hacks provided in the article.

@nmaas87 thanks, how do I check if both PDs are updated? Firmware does say 3.17 in system information, as well as when I run the bios update app again. However not sure both PDs updated

You need to enter the BIOS/UEFI on boot. I think its F2 or F12. And within the BIOS you find an exact listing of all components and their versions.

1 Like

thanks @nmaas87 again! I was able to get into UEFI using Windows 11 “advance startup options” and choosing UEFI. In there, i see

  1. InsydeH20 version = GFW30.03.17
  2. PD Controller 1 Ver & PD Controller 2 Ver =
  3. EC Ver = hx20_v0.0.1-c1d06ea

does this mean that i’m fully updated? anything else to check?

1 Like

Yes, thats correct. It worked out. Finally have access to mine again, here is a screenshot of the system updated to 3.17, as you can see it matches. So - you’re ready to rumble, have fun!

Thanks @nmaas87 for helping me confirm this! So the update worked! Weird that the update app continued to say bios update failed…


Marking solved.

1 Like