[SOLVED] Can't reply to specific reply in topic

Hi, it appears there is no meta category, so I’ll put it under General Topics.

Usually in Discourse you can reply to a specific reply in a topic, but it seems that on this instance, that reply option isn’t there. Why is this? Is there a specific reason?

This feature is useful because it allows you to reply to someone without quoting their entire reply. It also allows you to expand a reply and see all the replies to it, and also expand up to see the original reply it was a reply to.

Do you mean like this?

To accomplish this you would highlight the portion of the response you would like to reply to. After highlighting it, a popup option will come up called Quote. You would click on this to what I did just above.

However, if these options are not being shown to you, it most likely has to do with your accounts trust settings. This is an onboarding technique that Discourse uses to help stem the tide of spam accounts and after you have spent some time here it should naturally increase permitting you to do more here. (Edit: I don’t think this applies to your account, but I am including it here, for other who may search this thread out later, as it is good information for them.)

Yes that option isn’t available here but this highlighting and quote option is.

This was done by highlighting some text and then clicking on the [red] reply button. It has the same effect using the floating [quote] option, that you may not have noticed or not have access too ??

@2disbetter I meant like this

This was taken from the Discourse Meta forum. Every reply has its own ‘Reply’ button.

Yes that option doesn’t exist here but as mentioned, the other options work fine.

Is there a specific reason this isn’t an option here?

No idea as I don’t administer the forum.

I noted it when I arrived and being used to to it elsewhere thought it a bit inconvenient. However I can cope with it and have forgotten about it, even though I spend more time on the Fairphone forum which has it.

I can’t say specifically as I did not configure this discourse instance. However, one ground I have seen used elsewhere is that it helps people to think more about what they are responding to. Studies have shown that taking more time to respond helps the response to be more productive, etc.

YMMW, but since the quote option does essentially the same thing, I don’t have a problem with it either way.


That sounds like a valid reason in some cases, however when you just want to answer a simple question with a simple answer, for example, which is often the case, I find it more tedious. Not every reply is a long one with several points brought up which require specific replies. People will naturally use the quote feature when it makes sense, like to reply to the type of reply I just described. I see this in all other forums, people will use the ‘Reply’ button when using quotes isn’t necessary, but will still use quotes when it makes sense to do so.

Yes In can’t see any possible other benefit, so I wonder if that was a setup choice or an argument to support a missed option :slight_smile:


I am facing the same problem. I posted a new topic, and many people responded. Now I can’t reply back to them. The “Reply” button that should appear next to the heart and flag and link icons is missing. (I did try on a different browser.)

I can click the arrow just below the timeline in the right sidebar. In this way, I can post a comment that will appear all the way at the end of the conversation. I can highlight someone’s text and a “Reply” button appears, but if I reply that way, it doesn’t appear under that specific comment. Again, it appears all the way at the end, so my quote/reply is likely to get lost.

I have found three forum posts asking about this. Responses speculate that this has to do with a customized trust level setting on Framework’s instance of Discourse (forum platform). On the help pages hosted by Discourse, replying is actually described as a required step to qualify for the next trust level. Every forum (Discourse instance) help link on Framework’s site goes to the Discourse website, so I don’t know what I need to do specifically in the Framework instance of Discourse to get to the trust level to be allowed to reply. I don’t know if there is a customized trust setting or if something entirely different is happening.

A reply that is not located at the end of the thread just does not seem to be an option here.

It doesn’t seem to be trust level related. I’m at the highest non-mod level and it’s still not an option.

But there is a round-about way to reply without quoting any text. By quoting then deleting the quote, your post will remain linked as a “reply”.

Note “Graf_Theory” above the text entry box to show that it’s a reply. And the arrow to the left can be clicked to let you clear the reply function if you wish.

Same as with a quote, this notifies the person that they have a reply, and provides an expandable “Reply” button under their post if the replied-to post isn’t directly above yours.
fw reply 2b

Okay, I’m trying the quote deletion method for replying.

Trying the quote deletion method a second time.

Hey folks! We’ve added a dedicated reply button to each comment to make it more obvious how you reply to a post.

For the sake of clarity, we still recommend and encourage you to quote the part of a message that you’re replying to in most cases. This makes it easier to follow long threads and prevents context from being lost in edits or post deletions.

With that, I’m going to mark this post as [SOLVED].