[SOLVED] Debian 12 display lockups

  • Which OS (Operating System)? Debian
  • Which release of your OS (Operating System)? Debian 12 (Bookworm)
  • What desktop manager are you using? task-xfce-desktop
  • Framework laptop (11th or 12th generation Framework laptop) are you asking for support with? Framework Intel 13th Gen

So I have been having this issue that has been driving me nuts for a couple of days since getting my Framework laptop (thou mind you I love my framework laptop :smile: ).

What’s happening?
When using the computer or not, I am getting what is best described as a “display freeze”. Everything will working fine and then the panel just stops updating.

System is still responsive, I can actually work around the issue by Ctrl + Alt + Fn + F1 (virtual tty 1) then Ctrl + Alt + Fn + F7 (graphical “tty”).

A likely related issue is that sometimes the display will freeze for a moment, the display will jump around like I am getting desync and then will come back fine a second or so later.

Steps taken thus far:

  • I’ve turned off power management for PCIE while on AC power as well as disabling USB power management (thinking this was causing it when i was on eGPU)
  • I’ve tried with and without the eGPU, happens randomly so at one stage it felt like it was happening more frequently on eGPU but today it has been a real pig which rules out the eGPU. I am not charging of the eGPU either (to rule out some weird “half working over too long lead” issue)
  • I’ve done the fix to enable brightness keys ([SOLVED] Ubuntu 22 brightness keys not working) because I had a hunch it was happening when it was trying to dim the display.
  • I’ve checked the logs to the best of my ability (I am not use to journalctl so I might have missed something, but sudo journalctl and journalctl seem to not be showing anything)
  • I do have Nvidia drivers installed for the eGPU
  • I did find at one stage scrolling would cause lockups but that is not consistent.

Other notes:

  • I do have redshift enabled but it’s not been active when the issues were happening.
  • Intel package versions
dpkg -l | grep intel
ii  intel-gpu-tools                          1.27.1-1                            amd64        tools for debugging the Intel graphics driver
ii  intel-media-va-driver:amd64              23.1.1+dfsg1-1                      amd64        VAAPI driver for the Intel GEN8+ Graphics family
ii  intel-media-va-driver:i386               23.1.1+dfsg1-1                      i386         VAAPI driver for the Intel GEN8+ Graphics family
ii  intel-microcode                          3.20230512.1                        amd64        Processor microcode firmware for Intel CPUs
ii  libdrm-intel1:amd64                      2.4.114-1+b1                        amd64        Userspace interface to intel-specific kernel DRM services -- runtime
ii  libdrm-intel1:i386                       2.4.114-1+b1                        i386         Userspace interface to intel-specific kernel DRM services -- runtime
ii  xserver-xorg-video-intel                 2:2.99.917+git20210115-1            amd64        X.Org X server -- Intel i8xx, i9xx display driver

Had problems posting and seems like it nuked my note about kernel version
Linux max-framework 6.1.0-10-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.38-1 (2023-07-14) x86_64 GNU/Linux

1 Like

Is this on X11 or Wayland? Can you kill-and-restart whichever when it happens?

I am on X11

So to kill X11 when it happens it would mean I’d need to switch to one of the ptys which would unfreeze the screen.

Should I try wayland? redshift does whinge and complain about not having wayland and having to “fall back” to an older method

Like if I go to pty1 then back to pty7 with the Ctrl + Alt keys it unfreezes the screen.

This is a community support distro (which just means Matt (me) and Loell have not vetted/tested it. That said, we do have an active Debian community of users here. [GUIDE] Debian unstable (sid) on the Framework Laptop - #48 by Peter_Ralph

All of this said, I’d try disabling Redshift and using Wayland. This strikes me as a pretty sound place to start.


I was referring more to killing X from within X, e. g. by using ctrl+alt+backspace.
You might have to enable that feature first.

Honestly not a bad idea, Wayland is in good shape these days and it just might fix your problem.

1 Like

For most things, it works fine for me on Fedora 38. OBS, video calls, stuff that used to be problematic has been fine for me.

Same happened to me today, had Debian 12 installed for a week, running great until tonight just started freezing. conky on my desktop shows a load of 100+, I thought on a 8 thread machine 8 was the maxium. But im a bit of a linux noob. sorry. CPU and mem usage is fine.

Have an AMD ryzen 3700u with vega gfx. Will try the suggestion to change display driver. BTW im using gnome.

Here is a screenshot of my conky with a load graph at the bottom.

Yup no worries, I knew I was entering into less supported waters when I chose to stick to Debian :smile: I did find that post when I was doing initial setup, found it very helpful for avoiding a lot of the traps :heart: I’ve been trying to keep track of all the changes I’ve made so I can cook up an ansible playbook to make the Debian journey for others less fought, at least until Debian gets better support for 13th gen (they do already have decent-ish looking support for 11th and 12th gen)

That sounds like a fantastic idea, I didn’t think to check whether Redshift was active so I will start with that as thinking on it more it did feel like I had more problems in evenings rather than during the day. Whether that is proportional to amount of usage vs time of day I don’t know. (usage during the days is pretty much just having music playing while using a different device, where is in evenings when I finish work I of course then start using the laptop more)

Doing some reading unfortunately it seems that I can’t move over to Wayland as neither desktop manager that I like (XFCE or KDE) support Wayland yet. I am not that big of a fan of Gnome’s UI and still somewhat scarred from the whole Gnome 3 ordeal all those years back.

I haven’t noticed high CPU (fan profile is set to aggressive so laptop makes a racket at the slightest of provocation) during the issue except for when I had an unrelated zombie process.

But yeah the other’s suggestion of using Wayland in lieu of X11 maybe a winner, at least as a Gnome user you have the option to use it. However those load averages suggest your lighting up all of your cores. Most I have ever seen which was when I had the zombie was it pegging only 1 of the like 12 cores.

tl;dr for others who find this thread later on:

  • I am going to disable Redshift once troubles return (as of writing this reply it’s behaving itself without me changing anything) to see if it improves the situation. I will provide a progress update once new information comes to hand :smile:

edit 1: finished off a train of thought (the bit about time of day == anything or just proportional to how much I use the device)

I am using KDE+Wayland on Arch Linux ARM on my tablet.
I don’t know exactly what you need to get this working… maybe the Debian version is too far behind?

Interesting, thanks for that. I will be honest I didn’t read into KDE too much, I just quickly googled it, saw that they have a “list of problems” similar to that of XFCE, albeit a bit shorter and assumed it was a similar situation to XFCE.

Yep im Gnome+wayland here. I have a felling that the load ramped when gnome was set to turn on my nightlight setting. So will monitor it tonight to see if the same thing happens at the exact same time.

Hi @jonoiv , were you able to able to identify the services that’s taking up cpu resource?

1 Like

@Matt_Hartley have the same problem on Ubuntu 22.04. AFAIK both on X11 and Wayland. But it happens only when on battery.

1 Like

Hmm, only battery makes me question what is currently attached when you experience this? For troubleshooting.

  • Peripherals, displays?
  • If anything is connected, does it occur when everything is detached?
  • If nothing is attached, does it occur with all expansion cards (all of them) removed on battery?


This I have to test.

So I haven’t had it happen to me since :melting_face: been waiting for it to come back for further troubleshooting.

What changed? there was a kernel update! I went from


Linux max-framework 6.1.0-10-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.38-2 (2023-07-27) x86_64 GNU/Linux

(i.e. ‘6.1.38-1 (2023-07-14)’ to ‘6.1.38-2 (2023-07-27)’)

So yeah in my case the freezing was likely resolved with a kernel update.

I have had the odd graphics glitch however but I am not sure if it’s to do with the original issue or whether it’s something else.

@Matt_Hartley I don’t seem to be able to edit my original post anymore to add an update, can you please update it to have something like?

8th Aug '23 - Kernel update seems to have fixed the freezing ([SOLVED] Debian 12 display lockups - #16 by mbainrot)



thanks for the update @mbainrot , changing this to resolved.

1 Like