[SOLVED] Ubuntu 22 brightness keys not working

I just received my 12th gen intel laptop and installed Ubuntu 22. It seems that the brightness keys aren’t working out of the box. The media and volume keys work, and I’m able to change the brightness from the system menu. Does anyone have an idea of how to fix this?

Thanks

1 Like
3 Likes

Thanks!

1 Like

I’m totally new to linux and I’m having the same problem - can someone walk me through how to actually do these steps for the fix? I assume I have to put something in the command terminal but I really don’t know what specifically to type or look for, so I’d really appreciate some help

Hi @Alex_Meyer, I’d be happy to help!

Which Linux distro are you on and which specific version?

I’m having this same issue running Ubuntu 22.04.1 LTS

Hi @alexander_bardelmeie

Booted into my Ubuntu 22.04.1 Framework laptop.

Open a terminal window, then using your mouse paste in:

sudo gedit /etc/modprobe.d/framework-als-blacklist.conf

This will open up a blank text file. Copy and paste the following into it, then press the save button.

blacklist hid_sensor_hub

Now still in the terminal, copy/paste this and press enter.

sudo update-initramfs -u

Now you can reboot your computer. This was tested on a fresh install of Ubuntu 22.04.1 on 12th gen Framework.

6 Likes

that fixed it, thanks!!

1 Like

One of my favorite phrases! Yay!

3 Likes

@Matt_Hartley You are a legend! I was having the same issue, thanks heaps!

1 Like

Thank you that helped a lot!

Works also on 22.10, but you first have to install the text editor gedit with “sudo apt install gedit”, than everything will work out fine (don´t worry if its hard to read, if you are on dark mode)

1 Like