[SOLVED] Dual Boot (Windows 10 and Ubuntu 22.04) and can't enroll Fingerprints

I setup a Dual Boot system that I can successfully swap between Ubutnu and Windows, but I have now run into a problem with the fingerprint sensor. I originally had a Ubuntu only system and the fingerprint worked fine there.

I then added the Windows system (which required a Ubuntu reinstall to make things easier) and added my fingerprint data in Windows. When I then went to setup my fingerprints in the new Ubuntu install its fails to enroll.

The GUI shows a message “Failed to enroll new fingerprint” after I touch the sensor. Never before I touch it so I assume it it still correctly detecting a finger. Also when I try to enroll a fingerprint from the terminal with fprintd-enroll it returns

Using device /net/reactivated/Fprint/Device/0
failed to claim device: GDBus.Error:net.reactivated.Fprint.Error.AlreadyInUse: Device was already claimed

I found a forum about disabling a Pre-Authentication Setting in the BIOS, but Framework doesn’t have a setting similar to that in their BIOS. I would make the assumption that this is caused by something happening with Windows, but I dont understand how it could hold hardware without being active.

You can use the fingerprint scanner in Windows or Linux, not both. When you add fingerprints in Windows or even update the driver, it renders the fingerprint scanner inaccessible in Linux.

In Ubuntu, you can delete the stored fingerprints from Windows and start over:

Not sure if my configuration is similar to yours but my Batch 1 1185 system dual boots Windows 10, and Ubuntu 22.04 LTS.

Windows 10 is on the NVME drive.
Ubuntu is on a 250 GB expansion card.
I have fingerprint login on both.

The system is set to boot the Expansion card by default.
I can choose Windows if desired from the GRUB menu, or via F12 at Boot.


Thanks for the help. I would much rather have the fingerprint sensor for my Linux setup so I went ahead and following the steps in the thread you posted. Everything worked fine and I was able to add fingerprints in Ubuntu.

1 Like


Now as @Edward_Gray reports, it should be possible to use the fingerprint reader both in Ubuntu and in Windows somehow, but I could not find a procedure here. Personally I could never get this to work.

So it now lets me add fingerprints in Windows, but not on the same fingers that I am using for Ubuntu. I believe there are some ways to get around this in the thread you posted above. I’ll look around and post something if I find it.

I believe that since my setup uses different hard drive mounts to du a l boot, I have no issues using the same fingerprints for both

1 Like

Using Ubuntu 23.04 and Fedora 38 (both clean install). Fingerprint sensor works on both operating system till I shutdown and restart the other operating system, then I need to re-register my fingerprint in the other operating system. If I don’t re-register in other operating system it still continues to work in the previous operating system.

is it possible to store the fingerprint for Linux Distributions in dual boot (not windows)?

hi @Lamy ,

can you try and check /var/lib/fprintd/ or in /var/lib/gdm/ directories and see if various files are stored there when you try to enroll your fingerprint?

I only have Fedora 37 on my FW13, so no dual boot here. I also have just one fingerprint registered, left correction, right index finger.

I see only one file, at /var/lib/fprint/<user name>/goodixmoc/<some UUID>/7.

I’m guessing that fprint (or the goodixmoc driver) is counting fingers left to right starting with 1 for the left pinky.

I managed to move the fingerprint registration between Fedora installs on different SSDs back in the F35 days, when I believe libfprint wasn’t able to delete fingerprint slots from the reader, by copying the files.

That’s worth trying between fedora and Ubuntu here. Another thing to try is to maybe register a different finger on each Linux install?

1 Like