[SOLVED] EFI USB Device has been blocked by the current security policy

Hello, I am attempting to install Arch Linux on my Framework 13, so I made a USB from the Arch ISO using pv archlinux-2023.06.01-x86_64.iso > /dev/sdb. When booting from the USB, I get this error message.

How do I proceed? I don’t see anything in the BIOS about a security policy.

1 Like

You’ll need to disable secure boot. Manjaro 22.1 Installation on the Framework Laptop 13 - Framework Guides

1 Like

Hi, thanks. However, I don’t see a Secure Boot setting in the Security tab, as the instructions say. Here’s the complete list of settings.

1 Like

Is it under the Boot section?

@Second_Coming I don’t see anything relevant in the Boot section.

I tried disabling Quick Boot, setting a Timeout, Disabling/Enabling “Automatic Failover”, and setting “New Boot Device Priority” to other values, and rebooting still gives the same error.

In case the instructions use a different BIOS version, I’m using InsydeH2O version IFR30.03.03.

I figured it out! In my BIOS version, the Secure Boot setting is not in the BIOS Setup. Instead, press F2 when booting and you’ll see an option called Administer Secure Boot.

Then disable Enforce Secure Boot, save, and restart.


Nice to hear it gets resolved @Vortico welcome to the forums. :slight_smile: