[SOLVED] Ethernet module crashing in mid-use?

Hi folks! First time using the Framework Ethernet module. I’ve got a TP-Link TL-WR802N v4 and was trying to put it into client mode (for devices with no Wi-Fi support, this neat little device will function as an ethernet-to-wifi bridge).

The Problem
While setting the wireless network using the device’s onboard web UI, whenever I hit save on the wireless settings, the ethernet module would stop working. When running dmesg, I got this:

The ethernet module would stop functioning until I removed and reinserted it into the laptop. Then it would work fine again, until I got to that same point. Ended up using a different computer to get the job done, but if everyone is totally baffled, I’ll test it with other USB ethernet adapters on my Framework, and perhaps also just using wireless to reconfigure it. I also updated the firmware on the TP-Link, so it would be interesting to see if this still happens with the new firmware.

I’m running Fedora 35 on an 11th gen (original DIY model) Framework laptop.

Linux fedora 6.0.12-100.fc35.x86_64 #1 SMP PREEMPT_DYNAMIC

I’ve spent a tremendous amount of time with these Realtek based cards. Card started out fine, then graduates to this exact error. Swapped it with another card, flawless - was the Realtek chipset crashing. I had the same issue, so I had to have a solution and cause.

It’s a hardware issue, I was able to replicate it with both the Framework Ethernet Expansion card and a third party one, same Realtek chipet. 100% duplicatable across multiple distros, kernels, etc. It’s legitimately a bad card.

Spent two days diagnosing this. I can replicate this up and down the kernel spectrum. Realtek had some bad chips.

Devices tested:

Two Framework Ethernet expansion cards, one Pluggable brand dongle – same chipset and same driver module. One Framework Ethernet expansion card was failing.

I can create the act errors you’re seeing easily by simply using the bad card.


In hindsight, let’s just get this taken care once and for all. Please contact support and we’ll get this remedied for you.

Marking solved, but because of escalating this to support for a resolution as we do have a fix. We’re not forgetting about you, but we do have a resolution for you at support.

Man, that’s crazy! Glad to hear you were already aware of the issue and knew what to do. I just created a support request.

I assume the only fix is to replace the hardware? Not even a firmware update would solve the problem?