SOLVED: Fingerprint Reader no longer working on Fedora after "Windows to go" boot

Hello, I have a strange problem that I haven’t been able to find anywhere here or elsewhere. I’m on Fedora 35 Silver Blue Gnome 41, and so far it’s a flawless.

I had the fingerprint reader working just fine, then decided to create a VM of Windows 11 in my Virtual Machine Manger. After getting that working, I used that instance to create a “Windows to go” image on a usb, restarted and booted up W11, updated the drivers using Frameworks own driver package. It works great!

But ever since I did that, I’ve broken the finger print scanner in Fedora. The error message I get using the GUI:

“framework” failed to claim device: GDBus.Error:net.reactivated.Fprint.Error.Already In Use: Device was already claimed

When I run:

systemctl stop

I’m able to start again, but this time it says “Device is disconnected”. Running it from the command line produces a similar result:

fprintd-enroll -f right-index-finger userme
Enroll result: enroll disconnected

Whats frustrating, is lsusb lists it as a device, and fprint-list userme shows I don’t have any fingerprints enrolled, so it’s clearly detecting it.

Not sure what I did wrong. I tried going back to a few versions prior at boot, and same result. What I’d like to do is completely disable it for all windows, clear the fprint data and start again. I disabled it in W11 as well, and same result. Apologies for the sloppy post; formatting is tough in this forum since there’s no preview.

This has been happening to several people who are dual booting.

Check this out -

1 Like

I believe this has to do with the WIndow’s driver for the fingerprint reader. (Witch is Goodix’s responsibility and not Microsoft’s) It is specifically locking the dreader to work with Windows. I say this because I don’t think if you are dual booting different Linux distros the same thing is happening. If it then it is a hardware limitation (and a good one as it prevents some exploits).

AS mentioned in a post above, you can reset the reader, and blank its fingerprint memory to use with Linux, if you set it up in Windows.

1 Like

For anyone curious, just follow the suggestion from @snee and you should be good to go. If you scroll a bit further on that thread, @Devyn_Cairns posted a link to an appimage that ultimately did the trick.