[SOLVED] Fn lock broken

Yup, I tried multiple time and even switched kernel (5.15 up to 6.2)

Ok… maybe try a mainboard reset, and if that still doesn’t work you should contact Support.


Hi @jean , Can you try and check if it’s KDE specific behavior? try to check the global shortcut keys it’s most like on system settings, perhaps something has changed? let us know what it looks like at the moment.


Guys… I swear I rebooted multiple time and even removed the motherboard cell without any success
But booting on a fresh Ubuntu from USB stick apparently solved the issue for me
fn lock worked fine there, and now it works fine on my KDE install as well :man_shrugging:


I believe you lol… In other threads too some people are reporting transient problems with Fn keys.
Usually they don’t happen often (they are really rare, for me, but they do happen), and almost always go away with a reboot, but maybe your problem was a bit different.
The issue seems to be seriously looked into, so it’s possible that a future iteration of the BIOS will fix it.

1 Like

Have the same issue: fn + action, or action buttons stopped working recently
My setup: KDE neon 5.27
fn + escape to change also does not work.

As of now f1-f12 buttons only work in f1-f12 mode - no actions (e.g. brightness increase) are available (no matter if I press fn or not):

  • tried pressing fn + f1-f12
  • tried pressing just f1-f12
  • tried switching by fn + escape
    in all cases no actions are available

will try to boot from usb and see if that fixes the problem

Update: the issue is solved after reboot

hi @Ievgen , let us know if it happens frequently, or just a one off event.


1 Like

Yes the problem repeats after reboot after couple days running without reboot - not sure about the root cause.

E.g. not right after the reboot but couple days after. My best guess is that its somehow connected with sleep mode.

I installed evtest, but it does show nothing when I press Fn button (both when Fn is not working, and when Fn is working after reboot) So it might not be the best tool for testing Fn stopping registering in the system.

F1+Fn and F1 has not difference when this issue happens. Below, copied output from evtest just turn on-turn off for F1+Fn as for F1 only its identical:

Event: time 1682197753.418585, type 4 (EV_MSC), code 4 (MSC_SCAN), value 38
Event: time 1682197753.418585, type 1 (EV_KEY), code 56 (KEY_LEFTALT), value 0
Event: time 1682197753.418585, -------------- SYN_REPORT ------------
Event: time 1682197753.430739, type 4 (EV_MSC), code 4 (MSC_SCAN), value 0f
Event: time 1682197753.430739, type 1 (EV_KEY), code 15 (KEY_TAB), value 0
Event: time 1682197753.430739, -------------- SYN_REPORT ------------

after reboot, Fn+F1 and F1 only - working correctly now:

Event: time 1682197870.238866, -------------- SYN_REPORT ------------
Event: time 1682197870.650673, type 4 (EV_MSC), code 4 (MSC_SCAN), value a0
Event: time 1682197870.650673, type 1 (EV_KEY), code 113 (KEY_MUTE), value 1
Event: time 1682197870.650673, -------------- SYN_REPORT ------------
Event: time 1682197870.799744, type 4 (EV_MSC), code 4 (MSC_SCAN), value a0
Event: time 1682197870.799744, type 1 (EV_KEY), code 113 (KEY_MUTE), value 0
Event: time 1682197870.799744, -------------- SYN_REPORT ------------
Event: time 1682197872.444981, type 4 (EV_MSC), code 4 (MSC_SCAN), value 3b
Event: time 1682197872.444981, type 1 (EV_KEY), code 59 (KEY_F1), value 1
Event: time 1682197872.444981, -------------- SYN_REPORT ------------
^[OPEvent: time 1682197872.562701, type 4 (EV_MSC), code 4 (MSC_SCAN), value 3b
Event: time 1682197872.562701, type 1 (EV_KEY), code 59 (KEY_F1), value 0

Please share more details how I can help you debugging / testing this problem.

Hi @Ievgen

have you tried restarting just the desktop environment? see if fn keys functions recovers?

I think, just pressing Ctrl + Alt + Backspace does it,

let us know if it makes any difference.

1 Like

I tried to follow both methods, desktop restarts but fn button / multimedia buttons still do not work:

killall plasmashell  
kstart5 plasmashell


kquitapp5 plasmashell
kstart5 plasmashell

from here

Also, restarting DE every time fn / multimedia stops working does not sound like a long-term solution :slight_smile:

Thx for support and ping me here if you need more debugging / more details about my system.

I spotted that in 100% cases this problem occurs is after the laptop sleep mode, but it might be not the first sleep after reboot…

Tried this solution: [SOLVED] Ubuntu 22 brightness keys not working - #7 by Matt_Hartley - seems this fix is working in my case


thanks for updating this thread @Ievgen , glad matt’s suggested solution worked for you :slight_smile:

1 Like

Sorry, after few days after fix that stopped working again. Please notify me if you have solution for this or need additional debug info.

On a hunch, please try this in the terminal and reboot.

echo "blacklist cros_ec_lpcs" | sudo tee -a /etc/modprobe.d/no_cros_ec.conf

I don’t believe it’s related, but I’d like to rule it out as there are some issues that have affected function keys on 11th gen systems.

1 Like

ok, executed:

new@new-laptop:~$ echo "blacklist cros_ec_lpcs" | sudo tee -a /etc/modprobe.d/no_cros_ec.conf
[sudo] password for new: 
blacklist cros_ec_lpcs
new@new-laptop:~$ cd /etc/modprobe.d/
new@new-laptop:/etc/modprobe.d$ cat no_cros_ec.conf 
blacklist cros_ec_lpcs
new@new-laptop:/etc/modprobe.d$ ls -al
total 64
drwxr-xr-x   2 root root  4096 May  5 10:02 .
drwxr-xr-x 140 root root 12288 May  5 09:56 ..
-rw-r--r--   1 root root  2507 Feb 22  2021 alsa-base.conf
-rw-r--r--   1 root root   154 Oct  7  2021 amd64-microcode-blacklist.conf
-rw-r--r--   1 root root   325 Aug 17  2021 blacklist-ath_pci.conf
-rw-r--r--   1 root root  1518 Aug 17  2021 blacklist.conf
-rw-r--r--   1 root root   210 Aug 17  2021 blacklist-firewire.conf
-rw-r--r--   1 root root   677 Aug 17  2021 blacklist-framebuffer.conf
-rw-r--r--   1 root root   156 Feb 22  2021 blacklist-modem.conf
lrwxrwxrwx   1 root root    41 Feb 14 03:51 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r--r--   1 root root   583 Aug 17  2021 blacklist-rare-network.conf
-rw-r--r--   1 root root    27 Apr 28 22:31 framework-als-blacklist.conf
-rw-r--r--   1 root root   154 Aug 10  2022 intel-microcode-blacklist.conf
-rw-r--r--   1 root root   347 Aug 17  2021 iwlwifi.conf
-rw-r--r--   1 root root    23 May  5 10:02 no_cros_ec.conf

will report later if the issue persists (and, yes, you are right, I have 11th gen i5 model)

Thanks, do keep us posted.

I have the same issue with a i5-1135G7, latest bios (3.17 I think). I can’t Fn-Esc to lock Fn in Fedora even after trying the above. I dual boot back to Win 10 and it works fine there.

Please give this a try and report back. [TRACKING] Fn key stops working on PopOS after a while - #32 by Matt_Hartley

Thanks. I had tried this prior to posting and have used Win11 lately instead of Fedora. I updated everything on the system today to latest and is working now so perhaps something fixed it in interim.

1 Like

Same here!