[SOLVED] Linux Mint 20.3 Cinnamon Recurring Problems

Hello, this might be better suited for a Linux Mint specific forum but I already have this account, so I figured I’d ask for help here first.
For the past couple of weeks my laptop running Linux Mint 20.3 Cinnamon 64-bit has been having recurring issues. I fix them (aside from the random Firefox crashes, those never stopped), and then they come back a few days or a week later.

It started with Firefox crashes and Synaptic being unable to load updates because of the APT configuration being corrupt (encountered a section with no Package: header, problem with MergeList, and package lists or status files that couldn’t be parsed)

The MergeList error part caught my eye, and I found this guide and followed it How To Fix Ubuntu Update Error: Problem With MergeList
then Synaptic worked so I thought it was all fixed. And then the next day after a reboot due to a lack of response to inputs, it booted to BusyBox.

I looked into what to do next, and fsck worked. It was good for a few days after that (aside from Firefox) and then I got the error in Synaptic again.
That time, I looked up the APT corruption part, and found out about changing my mirror. I did that, and it was ok for a few more days.

Today it booted to BusyBox again, and it let me in after doing fsck.
Although it’s not as bad as it was that second day, I’m afraid that it will get worse. These issues came out of nowhere, I’ve had the laptop for less than a year.

I’d really like to know how to diagnose the issue, I’m not sure where to look. System Reports says that there’s no issues, and I don’t know how to parse syslogs.
One more thing that might be relevant is that I had never heard that holding down the power button to shut down the computer is bad until I was doing research on these problems- I’ve probably done it a couple dozen times over the past 11 months.

tldr: Recurring APT configuration corruption error, sometimes boots to BusyBox. Something fixes it, but it is temporary. And somehow it is making Firefox crash.

Thank you for reading, and please excuse my lack of experience with this stuff. Please let me know what specific information I can supply, and it is ok if I don’t get responses here.

Oh and about Firefox, when it crashes there’s no crash report (though, some information does appear in the syslog, and the terminal when I try to launch from there). It is really strange. No other applications have done that, but when Firefox was repeatedly crashing on launch I checked on Discord to see if it would crash too. It didn’t, so I closed it, but when I looked in System Reports there was a crash report for it with a bunch of text.


I suggest to post kernel logs (dmesg) and application logs (2>&1 > error.log) about the crashes so we can help you further.

1 Like

Ok! dmesg doesn’t seem to have time stamps, but my laptop is going through it right now so I will grab a recent chunk of it when I am able to get Firefox open- maybe I’ll get another browser temporarily.
Do I copy paste it in, make a text file, or should I send the whole log?

I’m having trouble finding error.log, I don’t see anything with the name 2 in var>log.

You can just put the last relevant lines (15-20) in here using three backticks (`), newline, the text and another three backticks.

You would have to run the program with the additional arguments of 2>&1 > error.log.
So for example, if firefox is crashing, run it as firefox 2>&1 > error.log.

You can then check error.log for clues and paste these here.


Ok, thank you! The most recent stuff in dsmg is about bluetooth and hardware, nothing really looks like it is about errors, so here is something about 50 lines up from the bottom that mentions the name of the drive my laptop boots from that I used when using fsck

[    4.141683] systemd[1]: Finished Load Kernel Module ramoops.
[    4.144894] kernel: bpfilter: Loaded bpfilter_umh pid 410
[    4.145042] unknown: Started bpfilter
[    4.146609] kernel: EXT4-fs (nvme0n1p2): re-mounted. Opts: errors=remount-ro. Quota mode: none.
[    4.147750] systemd[1]: Finished Remount Root and Kernel File Systems.
[    4.148519] systemd[1]: Activating swap /swapfile...
[    4.148794] systemd[1]: Condition check resulted in Rebuild Hardware Database being skipped.
[    4.149467] systemd[1]: Starting Load/Save Random Seed...
[    4.150087] systemd[1]: Starting Create System Users...
[    4.151461] kernel: Adding 2097148k swap on /swapfile.  Priority:-2 extents:6 across:2260988k SSFS
[    4.151503] systemd[1]: Activated swap /swapfile.
[    4.151553] systemd[1]: Reached target Swap.
[    4.151949] kernel: lp: driver loaded but no devices found
[    4.154440] kernel: ppdev: user-space parallel port driver
[    4.157366] systemd[1]: Finished Load/Save Random Seed.
[    4.160844] systemd[1]: Finished Create System Users.
[    4.161528] systemd[1]: Starting Create Static Device Nodes in /dev...
[    4.163209] systemd[1]: Finished Load Kernel Modules. 

And here is all that was in error.log

[GFX1-]: glxtest: VA-API test failed: process crashed. Please check your VA-API drivers. 

FYI, the real number at the beginning of each dmesg log line is a relative timestamp, in seconds, since the linux boot started.

You can often use journalctl (on systemd distros of which Mint is one) to achieve the same thing but with the times translated to wall-clock time. Journalctl segments logs into “boots” which are all the messages in a single boot-up-to-shut-down period.

The old-school /var/log/kern.log* files also contain these log entries with relative times converted to local date-times.



Thank you! Here is some of what I got from using journalcltl

Feb 12 00:31:16 LOHAC systemd[1]: systemd-coredump@11-12925-0.service: Succeeded.
Feb 12 00:31:16 LOHAC systemd-coredump[12970]: Process 12968 (firefox-bin) of user 1000 dumped core.
                                               Stack trace of thread 13:
                                               #0  0x00007f8b839db50d n/a (/usr/lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 + 0x1050d)
                                               #1  0x00007f8b839d8dd2 n/a (/usr/lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 + 0xddd2)
                                               #2  0x00007f8b835c5ebc n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x160ebc)
                                               #3  0x00007f8b839d8360 n/a (/usr/lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 + 0xd360)
                                               #4  0x00007f8b835c5ebc n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x160ebc)
                                               #5  0x00007f8b839d8764 n/a (/usr/lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 + 0xd764)
                                               #6  0x00007f8b834f0094 n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x8b094)
                                               #7  0x00007f8b835c5ebc n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x160ebc)
                                               #8  0x00007f8b835c5f88 n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x160f88)
                                               #9  0x00007f8b834efb63 n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x8ab63)
                                               #10 0x00007f8b834f014f n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x8b14f)
                                               #11 0x00007f8b76bf92cf n/a (/usr/lib/x86_64-linux-gnu/libva.so.2.1500.0 + 0x42cf)
                                               #12 0x00007f8b76bff4fa n/a (/usr/lib/x86_64-linux-gnu/libva.so.2.1500.0 + 0xa4fa)
                                               #13 0x00007f8b7a8ede39 n/a (/app/lib/firefox/libxul.so + 0x3b68e39)
Feb 12 00:31:16 LOHAC systemd[1]: systemd-coredump@12-12969-0.service: Succeeded.
Feb 12 00:31:16 LOHAC systemd[1150]: app-flatpak-org.mozilla.firefox-12946.scope: Succeeded.
Feb 12 00:31:17 LOHAC kernel: Web Content[13069]: segfault at 7ffc038edbc0 ip 00007fc78de8b27f sp 00007ffc038df6d0 error 6 in libxul.so[7fc78902f000+5c38000]
Feb 12 00:31:17 LOHAC kernel: Code: 41 55 41 54 53 48 81 ec 00 10 00 00 48 c7 04 24 00 00 00 00 48 81 ec f8 03 00 00 49 89 f7 49 89 fc 64 48 8b 04 25 28 00 00 00 <48> 89 84 24 f0 e4 00 00 48 8b 46 >
Feb 12 00:31:17 LOHAC systemd[1]: Started Process Core Dump (PID 13082/UID 0).
Feb 12 00:31:17 LOHAC systemd-coredump[13083]: Process 13069 (Web Content) of user 1000 dumped core.
                                               Stack trace of thread 123:
                                               #0  0x00007fc78de8b27f n/a (/app/lib/firefox/libxul.so + 0x5f6627f)
Feb 12 00:31:17 LOHAC systemd[1]: systemd-coredump@13-13082-0.service: Succeeded.
Feb 12 00:31:18 LOHAC systemd[1150]: app-flatpak-org.mozilla.firefox-12898.scope: Succeeded.

That journal fragment confirms what you already know: ffx is crashing. You seem to be running a containerised Firefox (ffx) so it’s also possible that the container or its sub-system (flatpak) is crashing.

The crash is caused by a “segfault” which is an attempt to access memory outside an authorised range. Your system has successfully captured a “coredump” which is a diagnostic snapshot of the state of ffx when it crashed. However these dumps are not much use unless you are a ffx developer or are asked to provide the dump file to a ffx developer.

You can use coredumpctl to list the dumps on your system and examine aspects of them.

I wonder if you have a specific reason for running a containerised ffx. While they’re convenient for the application provider, they add additional layers of diagnostic complexity in circumstances like this. You could try to run the packaged (native) ffx and see if the problem continues.

I guess it’s also possible that the container (flatpak) is damaged. I know almost nothing about flatpaks. It seems like they should have integrity checking built in and refuse to launch from damaged containers but maybe that’s not the case. Unless someone more knowledgeable declares it a waste of time, you could try uninstalling and reinstalling the flatpak.

If it was me, I’d uninstall the ffx flatpak and install the native ffx package. Other than the few minutes that you’ll lose doing it, I doubt you’ll be worse off.

Make a backup of important bookmarks and passwords before you uninstall.



If I am understanding what native package refers to, I may have had that version of Firefox first (which I neglected to mention, since the post was already long). I believe I installed it from the Mozilla website. I had issues with it when my laptop started acting up, and when that persisted after making the MergeList error go away the first time I found the Flatpak version in the software manager and installed that instead, in case it would be more stable or something. It ended up being the same.

Now, I’ve opened up my original version of Firefox, and it’s working ok. When it runs into trouble, I will use the things above to get some info.

Thank you for breaking all of that down!


Community got this one resolved. Yay!

1 Like

Sorry, it isn’t resolved. It is just very inconsistent- it was fine yesterday. The other version of Firefox is acting up now, I’m going to get an error log.
No new MergeList error yet though, but I also haven’t really done anything different.

Update: it generates a blank error log.

The way that it is almost exclusively impacting Firefox is what is stopping me from trying something drastic yet, like reinstalling Mint. To be honest, I haven’t looked into how difficult that is to do yet, maybe it isn’t that bad.

I did ctrl+PRT SCR R E I S U B to reset, and it was in fallback mode when it booted back up.
After getting out of fallback mode, doing journalctl gave me logs dated to October?

edit: did another reboot, Firefox opened, but now my screen is frozen aside from my mouse.

After a reboot, Firefox and Chromium aren’t working, Zoom works, and journactl output a log dated to Oct 31 instead of 16 like last time.

Another reboot, and the update manager is displaying the MergeList error

Update: Switching mirrors worked, but now it’s very slow (new), so I’m going to reboot.

Update 2: Firefox doesn’t work, Chromium opens but doesn’t load, and journalctl displayed Nov 4.

Update 3: APT/MergeList error is back. Gonna go for an earlier method of fixing it. Once I can open a browser I think I’ll try reinstalling Mint. Still don’t know how to find the cause of this issue.

None of the methods are working now- Fix MergeList error from Software sources (fails to update cache), sudo rm -fv /var/lib/apt/lists/*
sudo apt-get update (MergeList error gets in the way of updating), and changing mirrors (MergeList error gets in the way)

My guess is that you have a hardware issue–probably a failing storage system–that is corrupting data that apt/aptitude, flatpak and ffx depend on. That corrupt data is what is causing them to crash. Storage system failures will be logged to the kernel ring buffer which you should be able to monitor in real time using dmesg.

Either open a desktop terminal session or log in on one of the tty consoles and run the command:

dmesg -kW

The dmesg command does not depend on logs being written to storage (unlike journalctl and syslogd). In theory then they should be immune to storage system failures (but perhaps not memory failures).

On a stable, correctly functioning system you might see a handful of messages each day. I have a noisy BT mouse which I have set to sleep aggressively so maybe I get 20 mouse wakeup messages a day.

In your situation I’d expect 100s of messages each minute when you notice apt or ffx malfunctioning.



Thank you! I will try that. I used something built into Mint to check the status of my hard drive a week ago and it said it was fine, but I forget what.

It didn’t recognize the W

Sorry, -W (uppercase) is a new-ish option. The older option is -w (lowercase) which almost does the same thing. When you enter dmesg -kw it will dump the whole buffer immediately and then wait for and display new messages as they’re logged.

By contrast, -W displays nothing until a message is logged.