[SOLVED] Missing drivers for windows 11 installation

*[SOLVED] by downloading the OEM Drivers for the Mediatek mt7921 (RZ616) from this website:

I can’t be the only one that had this problem, so I’m updating ppl to let you guys know and hopefully FW can include this in their windows guide.*

I know the driver bundle exists, but an exe doesn’t help during the installation.

I tried in virt-manager and on hardware, and I seem to be missing hardware drivers to ever start the installation.

I added a bunch of ssd drivers, but those didn’t seem to be the reason for that, anybody had the same issue if you ordered a ryzen 5 DIY edition without it being preinstalled?

Is the problem that you can’t get onto the wireless network? If so, this guide provides a way around it.

If it’s something else, please provide more detail and I’ll try again. :slight_smile:

1 Like

Thx, I was only able to find the other guide and the windows drivers guide which confused me

This is exactly what I was looking for and will try it tomorrow or so👍

Please report back on whether that solves it. Inquiring minds will want to know. :wink:

1 Like

Yep, there is a driver bundle available for download. It’s an .exe that you can transfer onto a flash drive and install post windows installation.

Here’s what I did:

  • Didn’t have internet in the Windows installer, but just created a local account and didn’t have any issues with the installation process
  • Didn’t have wifi/bluetooth after booting into Windows
  • Downloaded the drivers on a different computer and transfered to USB drive
  • Installed the drivers. Internet and bluetooth works after

Did Windows give you any grief over the local account? I was under the impression that the more recent Windows 11 installers try to pretend there’s no such thing, to get you to use a Microsoft account so M$ can monetize your information. (As you can probably tell, I’m not a fan of Microsoft.)

From my experience, if you have internet access, Microsoft will try to push you to using an online account. It will hide the option to create a local account through dark patterns. But without internet it will default to local account setup.

After installing, I’ve noticed that every now and then the OS will try to pursuade you into creating a microsoft account. Every now and then when windows updates without your consent (like if the OS crashes and reboots into an update UI) it will prompt you to log into a microsoft account and hide the “No thanks, continue using local account” option through dark patterns.

Yep, also not a fan of M$. Sad because I do like the windows desktop experience and I use windows for gaming (a lot of games i play have anticheat measures that won’t let you run in a VM)

Huh. Haven’t tried it in quite a while myself… I have a Windows/Ubuntu dual-boot setup on both of my current machines, but I haven’t booted either of them into Windows in a very long time (I’m debating not even installing it onto my Framework 16 when it finally gets here). I did see a YouTube video a while back suggesting that the latest installers would flatly refuse to accept I-don’t-have-Internet, maybe MS realized that was a step too far and backed off from that.

This is another annoying microsoft thing, but the installation is different depending on whether you are installing Home or Pro.

Home is on the left, Pro is on the right.

For Home, dark patterns are employed. You have to close the window using Alt+F4 before it gives you the option to install a local account.

M$ correctly assumes people installing Pro would be less tolerant of this kind of BS, so it gives the option to chooes “I don’t have internet” and continue with local setup

1 Like

Ah, that explains the difference. Thanks for pointing it out.

This typically happens when you boot a Windows ISO with Ventoy. Something about the block device emulation that Ventoy does causes the installer to be unable to see the SSD.

1 Like

I seem to be having a pretty funny set of problems, can’t compile rufus from source as gcc from linux can’t run windows apps and wine runs on win7, so it can only run an older version of rufus, which wont have the options I need…

so I need to install windows 8/10, to run the rufus that I need to create for win11

how is there no alternative for linux to this? I feel like there should be an easier way…

The assumption seems to be that you have another Windows system to do the initial prep work on. If you don’t, there are several Linux options for creating the bootable USB.

So far as I know, none of them include the Windows-specific option that you need to get around the Internet-access requirement if you’re installing Windows Home (as described above, Windows Pro doesn’t have that issue). Fortunately there’s another way around that, described here. You’ll need to skip a bunch of useless comments to get to the answers, but the one from “Hania Lian” (should be the first, using the default “most helpful” sort) describes it well. [EDIT: more detailed description of the process is here.]

If it still demands that you log into a Microsoft account after that, you can get past it using @Desmond’s work-around described above.

As for why there isn’t an easier way, there’s a simple answer: Microsoft wants to extract the maximum profit from its users, so they do everything in their power to make it hard to do anything that stands in the way of that. They’d make it impossible if they felt that they could get away with it.

1 Like

I should’ve included this in the beginning, but I left it out as it was in German, but my issue comes way before the “activate online” btw

I just checked the guide you edited in and its around step5 where it asks for the product key, I don’t even get to this window, right after I hit install, it asks me for drivers…

I can include a pic if you want, but it will be in German

Yeah, if the message isn’t “bratwurst,” “lager,” or “gesundheit,” I almost certainly wouldn’t understand it. :laughing:

Okay, it sounds like Windows is detecting that you have a wifi card, and demanding drivers for it before it will let you go any further.

From what I can find, you might be able to do the Shift+F10 (or Function+Shift+F10, depending on your keyboard settings) and use the OOBE\BYPASSNRO thing on that screen too.

If that fails, I have to go out on a limb. If you’re comfortable messing with the hardware, you can try removing the wifi card long enough to install Windows. Then reinstall it (using the instructions on the same page) before running the downloaded driver package. Be careful with the antenna wires!

If that doesn’t work either, then I’m out of ideas. :frowning: All I can think of is asking a friend with a Windows computer to create the Rufus image for you.


1 Like

Edit: nvm, this doesn’t answer OP’s question since it they couldn’t even get past the “Install Now” button

I tried installing Pro on a VM and the “I don’t have internet” option was missing… I found a guide online that described trying to sign into a disabled account before continuing:

This needs to be done after running that OOBE\BYPASSNRO command

Several things to try:

  • Ventoy works on Linux and is what I used to create the bootable usb. You first format the usb drive, and then drag and drop the windows iso into the directory it created. Ventoy

  • If you’re installing windows on a VM, you need to emulate the TPM. If you don’t, you’ll get an error message saying the hardware doesn’t support windows. That might be the error message that you’re getting. This is what I had to do to get TPM working in QEMU: QEMU - ArchWiki

1 Like

Not being able to find your SSD during installation is a common problem caused by Ventoy and other virtual ISO boot solutions.

Just to update you, I found the drivers for it and it allowed me to install it now… I kept searching for RZ616, but I found them after I searched for the Mediatek mt7921

It allowed me to at least get further than before

*the dark-patterns deployed have indeed been more advanced than even shift-f4 or f10, I had to hit ctr+shift+fn and f3 to enter windows as admin and I am being shown this page:

Something something in German about OOBE !!

Just tried installing the FW exe file with drivers, but it said I don’t have a Ryzen amd, eventhough I do have it…

Anyways, now I will just install rufus on it and create another win11 iso the correct way using this incomplete installation

Somewhat genius really😄

1 Like