[SOLVED] Missing textures on UE5 games with AMD Phoenix APU

Hey there !
I’ve just bought Ark Survival Ascended (running on Unreal Engine 5) after finding that it can run on Steam Deck at 30 fps with low settings so I told myself that it should be much better with my Ryzen 7840U if I lower the resolution. Well … it turns out that the game can be playable but there are many glitches on the textures. A lot of them are transparent.
I run on Fedora 39 updated, with the memory on bios set to GAME OPTIMIZATION, and have Mesa 23.3, and the last available kernel 6.6.7.
I also tried the very last version of GE-Proton 8-25 and the graphics are still the same.
Any idea about what’s going on there and how to solve ?

EDIT: I’ve tested against mesa 24.0 git using this copr and the issue is still there :

Maybe @Mario_Limonciello you would have an idea of what’s going on here ?

Maybe a mesa bug? I’d raise it with mesa Gitlab.

I’d be happy to create a report but I don’t know how to retrieve usefull logs for it.
Ive seen so many tools for doing trace on vulkan, on opengl and such but I’m not even sure which one to use, or what’s the tech behind the game’s UE5 …

Can someone point me to the right direction please ?

Few schools of thought here.

  • In the past, granted it’s been awhile, ARK: Survival Evolved was super buggy when it came out when ran on Linux. Now, it’s been a bit and it looks like it’s fine now. Point being, I’d test this against other similar game titles, see if this is affecting other titles as well.

  • Running this through the Proton DB, filtering to AMD GPU, it does look to be iffy for compatibility.

Thank you @Matt_Hartley
I definitely remember the Ark debut until proton arrived. I was there too.

Yeah, that’s the problem here and also the reason I posted on the forums : I’m mostly a casual gamer playing only few games. ASA is the most recent game I got and don’t have any other UE5 game to try against.

I’m not sure to understand what you mean by “to be iffy for compatibility” but anyway, I already looked at this page you mentioned. The fact is, the game does not seem to have any problems with other AMD product. There are also some people uploading some recorded gaming session on their Steam Deck and there’s no glitches. Can’t find any report in comments either.
For example, this video :

So it might be specific to our model or driver stack ? This is where my technical knowledge reaches the limit…
Any help in order to further test or debug would be appreciated !

Running my game with VKD3D_DISABLE_EXTENSIONS=VK_EXT_mesh_shader launch parameter on Steam ‘solved’ the problem here. I get now all the textures of the game. Since I only have Ark Survival Ascended using UE5 among my games, I can’t really tell if it will do the trick on other games or not… You’ll have to test but it seems to be a global issue on UE5 games and Phoenix APU.

There’s a lot of reports of this kind on mesa so let’s hope it will be fixed anytime soon. :crossed_fingers:

EDIT: I’ve changed the topic title to better help visibility on this for all the gamers on FW out there :wink:

Fantastic! Glad to hear that you got this sorted.

Basically, you’re disabling the mesh shader extension as a launch parameter. This is useful when you have a game that needs to this to be disabled to work on Proton. Seems this game matches this need based on MESA in this case.

This kind of issue has been fixed upstream as mentionned on Phoronix:

:rocket: :tada: :partying_face:
Now Ark SA is working great on FW13 AMD with a few tricks at around 20~30 fps. I know it’s pretty low but hey it’s better than nothing (and it’s beautiful !).
I can’t wait to get my hands on my next to be FW16" :blush:

Just to give my two cents, I’ve been playing Palworld, No Man’s Sky and Risk of Rain Returns perfectly fine on my FW14 7840U without seeing any missing textures or graphical irregularities.
Distro I’m running is Fedora 39.