[SOLVED] PopOS MST doesn't work

Hopefully this is an alright place to try for help. If not I’ll go to PopOS forums I guess.

I have 12th gen round 1 FrameWork and I’m using a USBC for charging and display out for a monitor that has MST. I’ve confirmed the setup works via my work laptop, and I can identify the second monitor, but it doesn’t display on my FrameWork. Anyone have any ideas where I can look to resolve this?
I’m also using an HDMI for a second monitor, but I’d really prefer to use the MST if I can so the second monitor can be used for a different computer.

@Matt_Hartley I apologize if it’s forbidden to tag you. Do you know if there’s some issue with Display Port daisy chaining with PopOS or the Framework DP over USBC?

Sorry I think the reason no one has offered up any suggestions is quite simply because your setup is unclear. For it to work properly the laptop should be connected to the IN usbc port on the MST capable display and any chained monitors should be hooked up to a DP MST Hub (in this case the monitor) on the OUT port.

So questions I have are 1) what is charging your laptop? 2) your monitor? 3)what is the max PD on the charger or chargers involved? 4) Is the displayport to HDMI adapter/cable passive or active? 5) Have you double checked Thunderbolt Authorization in case that is blocking it?

At my time at System76, I can tell you that yes, anytime a user is Daily Chaining, there is a possibility of it working then not working. Each link in the chain is a potential point of failure.

That said, @nadb has an excellent point and path forward:

I understand. I didn’t know what all was relevant. Forgive me if this is too much info in the other direction. I promise I’m not trying to be sarcastic

  1. USBc over the same cable for the DP.
  2. Yeah; it’s a Dell model P2422HE.
  3. 65W
  4. Forgive me for being unclear here. I have three monitors: FW lappy goes HDMI to center monitor (Dell S3422DWG). USBc for DP to the right monitor (P2422HE as listed before) and then the DP out from that monitor goes around the back to the left monitor (Dell P2421DC).
  5. I’m not sure what Thunderbolt Authorization is or where to check; I’ll Google that after I finish typing this.

Resolutions for left and right monitors are 1920x1080 and 60Hz. Middle monitor is 3440x1440 and 100Hz. I can detect the all three monitors in my display settings, but no picture shows on the left monitor. I’ve verified everything works without any changes other than the laptop. I’ve seen in my searches that Linux distros have issues with multiple monitors, so I’m thinking that’s the right tree to bark up, but thought maybe someone here would have an idea for me to chase first.

So your laptop is getting power from the monitor? and this is the P2422HE? Then you have an HDMI connection from the laptop to the S3422DWG? Then from the S3422DWG DP to the P2421DC?

Thunderbolt Authorization would be found under settings in the Thunderbolt section. This is more to verify that nothing is requiring authorization and that the lack of it is breaking the connectivity.

Another things to check is in settings under displays when all of them are showing please verify that the boxes representing the displays are actually touching.

Regardless please let me know the answers to the questions I just posed. I have some suspicions and well the exact setup matters.

1 Like

Correct that the laptop is powered by P2422HE. HDMI > S3422DWG is also correct. Third part is incorrect. It’s Display Port from right monitor to far left (P2422HE to P2421DC). Goes from DP via USBC to DP out then to the left monitor. I’m also using the USBC for ethernet.

Only setting I find for Thunderbolt is under privacy to allow access for docks and GPUs. This setting is/was enabled.

Yeah I’ve tried moving them around a bunch to make sure they’re happy and all can be found. It does show all three, but, if they’re not touching, it’ll have an error saying “not allowed due to hardware limitations.” When I try turning on the left monitor it’ll say scanning for signal, then “no DP signal from device” before going to sleep.

This would suggest to me a potential issue with the cable.

Okay so a couple of concerns is your laptop actually getting enough power under all conditions? Most 65w rated chargers don’t actually hit the full 65w, the 12th gen does need the full 65w or it will start discharging the battery to make up the difference.

Ensure that the DP out on P2422HE is going to DP in on P2421DC. Also try switching out the cable. You may also want to use a DP port to connect the laptop to the monitor instead of the usb-c. Why? DP alt-mode is in my experience finicky and dependent on a number of items, the cable, the port, the graphics card. In this instanc ew eknow the graphics card definitely supports it and I am fairly sure the port would support it as well. The cable I don’t know where you got it or if it is still good. Just because it works on windows does not mean it will work on linux.

If it begins to behave properly with this DP connection, I would seriously consider getting a Thunderbolt hub or dock with the right adapters to maximize stability. Once you have it set right you really want to restrict this to a single connection solution.

I’ve verified that it all works with a separate computer. Plug in work laptop (using Win 10) and everything is happy. Plug in Framework and all is sad.

I don’t know how I’d test that. It’s coming direct from the monitor. :-/

DP Alt being finicky could be an issue. I’m considering using the DP adapter to go to the second monitor instead of from the DP out of the right monitor, but I don’t want to plug and unplug three plugs every time I leave lol. I’d also need a longer DP cable for it to work.

This does not matter. You have PopOS on the Framework not Win10. Never assume something that works on Windows is evidence it should work on Linux, it almost never does.

You would need a usb-c power reading adapter so nix that. We know that the screen delivers 65w or says it does. If you are charging off of it and the battery kicks in…well you know you ain’t getting 65w out of it.

Switching to all DP would give you one dp to plug in on the computer and the usb-c for PD so two connections. The only way to get it down to one is with a dock that plays nice. The only potential limiter here is how many screens at what resolution the MST hub in the display can handle.

Was just saying that I know everything physically works as laid out.

I’ve never seen/noticed the battery kick in while connected. I could disable the battery in BIOS and find out for real lol

Thank you for your assistance with troubleshooting this.

1 Like

Understood :slight_smile:

Not sure if it’s worth updating, but, in case someone comes here in the future with a similar problem, the issue was not the OS or the Framework. There were a couple of minor issues which gathered together to make this very frustrating and take months to solve.
If the receiving MST monitor was not already selected for the DP In input it wouldn’t detect that an input came to that. Also the DP cable was loose, so, if I bumped the monitor while moving things around, it may or may not be connected. And finally, once everything was connected tightly and turned on, I’d still have to manually wake the monitor by pressing one of the buttons on it. Now everything works and I’m rocking the triple monitor setup like I wanted.

Edit: i don’t know how to mark this solved, but it is. Maybe the mods can assist with that?


@ravenssettle I can take care of it. Good to hear it was solved!