[SOLVED] PXE booting netboot.xyz mysteriously failing

Framework 13 mainboard, connected to a thunderbolt dock, set up an EdgeRouter for netboot.xyz.

It looks IPv4 PXE is going to work–it gets an IP address, is able to download the image–but then it just drops to the choose device boot menu. Ostensibly failing to boot the image. But no errors.

This screen is just before the boot menu. The “NBP file downloaded successfully” flashes for like 0.1s.

I have absolutely nothing to go on. I can’t tell if the efi file is wrong somehow or if there’s a network weirdness or if the phase of the moon is wrong.

I would appreciate any advice.

On this screen, once you see the “NBP file downloaded successfully” message, what happens when you press F12 a few times now?

For example, there seems to be a few ways to ‘progress’ forward in the boot process:

UI message issue:

You misunderstand. You can see the download success message for 0.1s (not even enough time to read it) before dropping into the Framework mainboard firmware boot option selection menu.

I can also google an error message. As I said, I’m not trying to PXE boot Microsoft enterprise stuff, I’m booting netboot.xyz. Nothing Microsoft or Windows is involved–neither the PXE images nor the empty disks have it.

Oh, and the only options in the boot menu are the PXE IPv4/6 options, and they just do the same thing again.

Just tried one of my desktops, came right up into the netboot menu, so it’s not immediately a router problem.

What do your UEFI settings look like? There’s some weirdness with how the bios handles PXE in settings iirc.

I don’t remember seeing settings other than “enable net boot”? Secure boot is turned off.

I was going to update the firmware today, but this is a brand new board.

Definitely update your firmware (depending on the board rev your uefi settings may reset), and ensure that Network Stack is enabled as well.

Omfg. Secure boot was turned on, and I feel like an idiot.

Turn it off, and it boots the image happily.

Hopefully someone else finds this thread and it saves them the days of hair pulling.


It definitely doesn’t help that the RTC battery on this one seems to be dead, and the 11th gen still ships with 3.07.

Yes! You did save me a lot of time. I knew I had to disable secure boot, but forgot. Your picture showed exactly the same message as the picture I took from my screen.

After failing to netboot from a VM (don’t know why yet) and an older laptop (old NIC with bug, adds “ÿ” to the boot file to load), I tried with a newer laptop and hit the secure boot issue.

We’re expecting a new Framework to arrive in a few weeks.