[RESPONDED] Ubuntu 22 brightness keys not working

I just received my 12th gen intel laptop and installed Ubuntu 22. It seems that the brightness keys aren’t working out of the box. The media and volume keys work, and I’m able to change the brightness from the system menu. Does anyone have an idea of how to fix this?


1 Like


1 Like

I’m totally new to linux and I’m having the same problem - can someone walk me through how to actually do these steps for the fix? I assume I have to put something in the command terminal but I really don’t know what specifically to type or look for, so I’d really appreciate some help

Hi @Alex_Meyer, I’d be happy to help!

Which Linux distro are you on and which specific version?

I’m having this same issue running Ubuntu 22.04.1 LTS

Hi @alexander_bardelmeie

Booted into my Ubuntu 22.04.1 Framework laptop.

Open a terminal window, then using your mouse paste in:

sudo gedit /etc/modprobe.d/framework-als-blacklist.conf

This will open up a blank text file. Copy and paste the following into it, then press the save button.

blacklist hid_sensor_hub

Now still in the terminal, copy/paste this and press enter.

sudo update-initramfs -u

Now you can reboot your computer. This was tested on a fresh install of Ubuntu 22.04.1 on 12th gen Framework.


that fixed it, thanks!!


One of my favorite phrases! Yay!


@Matt_Hartley You are a legend! I was having the same issue, thanks heaps!


Thank you that helped a lot!

Works also on 22.10, but you first have to install the text editor gedit with “sudo apt install gedit”, than everything will work out fine (don´t worry if its hard to read, if you are on dark mode)

1 Like

I had this problem too and this fixed it!

Nevertheless, I have a (un)related problem. For some reason I can’t change my brightness with above or below a 8% since a few days. I have no idea what triggered that. If I use the keys or even the adjustment with the mouse, it directly jumps back to 8% after I let go the slider. Anybody has an idea what could be the reason for that odd behavior?

Delighted to hear this!

Something must have changed, we just have to figure out what.

  • Distro and desktop environment?
  • Kernel?
  • Did this happen after running updates?
  • Mint 21.1 Cinnamon

  • Kernel 5.15.0-60-generic

  • No it did not happen after an update. I think it happened after I started using an external screen via HDMI a few weeks ago. Otherwise I did not do/change anything. I tried to find a solution but all the threads I found where related to backlight not workin in ubuntu.

Hi all

Unfortunately I’m still seeing the problem even with the blacklist. :frowning:

paul@Cog:~$ cat /etc/modprobe.d/framework-als-blacklist.conf 
blacklist hid_sensor_hub
blacklist hid-sensor-hub

(I’ve got both formats in there as this thread has both styles in it.)

I can’t see any particular sign of hid sensor hub stuff in the dmesg output:

paul@Cog:~$ sudo dmesg | grep hid
[    1.939943] hid: raw HID events driver (C) Jiri Kosina
[    2.217160] hid-generic 0018:32AC:0006.0001: input,hidraw0: I2C HID v1.00 Device [FRMW0001:00 32AC:0006] on i2c-FRMW0001:00
[    2.218027] hid-generic 0018:093A:0274.0002: input,hidraw1: I2C HID v1.00 Mouse [PIXA3854:00 093A:0274] on i2c-PIXA3854:00
[    6.392998] hid-multitouch 0018:093A:0274.0002: input,hidraw0: I2C HID v1.00 Mouse [PIXA3854:00 093A:0274] on i2c-PIXA3854:00

xev just doesn’t show any key output for the brightness keys (or the airplane mode key for that matter).

Keyboard layout is pc105 - is there a better one I should be using?

geometry: pc(pc105)


@LEEH Since it’s working at some level, let’s set aside the brightness keys and take this approach instead.

Scroll down for the Ubuntu package install, then follow the directions to try different brightness settings in the terminal.

@Paul_Walker Didn’t catch the distro you were using. Regardless, if this is a 12th gen Framework, please try removing the modprobe blacklisting, then add it directly to grub instead. If Ubuntu or related, follow the Ubuntu guide.


Thank for the suggestion! The “light” package and adjusting the brightness in the terminal works. It is odd that it doesn’t work with the keyboard keys or in the GUI settings. Nevertheless, it works in the terminal, good enough for me.

I am a student who is new to linux. I successfully installed ubuntu 22.04 on windows 11 a few days ago. I want to adjust the brightness of the screen, but the “Display” in the “Settings” does not have a brightness slider. I checked the information on the Internet but it didn’t work.
Can anyone help me? Thanks

Happy to help. You installed Ubuntu onto which Framework version 11th or 12th?

Are you dual booting?

Sorry it’s taken a while to reply - thanks @Matt_Hartley, the Ubuntu guide helped and it’s all working now. (I’m using LinuxMint, which is Ubuntu-based.)