[SOLVED] Ubuntu sleep issue fix

I’ve had a long standing issue with my Framework laptop running Ubuntu where occasionally it will not wake from sleep - the power light just slow blinks and I have to hard reset the laptop to get it to respond to anything.

It was especially annoying because whenever I tried to track it down I couldn’t repro the issue - it just seemed to happen consistently when I got home from work.

I’ve finally figured out that it’s the HDMI expansion port - specifically the steps that cause the bug for me are:

  • Plug in a monitor to the HDMI expansion
  • Unplug the monitor WITHOUT unplugging the expansion
  • Put the laptop to sleep

After this it will consistently not wake up from sleep. Just having the HDMI expansion in doesn’t affect it, or putting it to sleep while a monitor is plugged in or removing the expansion after unplugging the monitor is fine too.

So my fix is to use an extra USB C expansion and treat the HDMI expansion like a dongle

I will try looking further into this and find a software solution but I was curious if anyone else had the same issue - there were some threads where people got the blinking light but the only advice I could see was to upgrade firmware which has not helped me - I’m currently on 3.10 with Ubuntu 22.04 and the issue has been there for several updates.

Hope this helps someone!


I’ve been having the same issue as described above, but the cause has proven slightly different.

In my case, just having the HDMI expansion plugged in DOES cause the issue. I am using a usb-c hub which connects to a monitor, so the HDMI expansion card isn’t being used, but it still is causing the issue.

When I disconnected the HDMI expansion and rebooted (thanks to the OP’s suggestion), the issue has not occurred again. So it is definitely an issue related to the HDMI expansion being plugged in.

I’m wondering if this issue is related to the power draw issue that the HDMI expansion has, and if so, will the new 2nd generation HDMI expansion resolve this issue?

I’m also on Ubuntu 22.

Hi @Josh2 ,

welcome to the framework community :blush:, interesting sleep behavior you have there, I wonder if you’re using kernel 6.x? or just 5.15.

maybe we could check with lshw for your list on connected hardware
also try to capture PowerTop’s Device stats.

Hi @Loell_Framework,

Thanks for reaching out. I am on kernel 5.15.
PowerTOP shows the framework hdmi at 100%.
I’m not sure what I am looking for in the lshw output, it is super long. Could you let me know specifically what I am looking for? Thanks.

btw, have you tried kernel version 6, see if your mileage varies?

nothing really specific on lshw, but perhpas will see something, you can just zip and upload it somewhere then link it here.

lshw | tee lshw_output.txt | zip lsh_output.zip lshw_output.txt 
1 Like

For whatever reason, I’m not experiencing the issue anymore. I’m still on the same kernel. It may have been an OS update. I’ll post back if it comes up again.

It may be related that I was also noticing an issue with a memory leak, where the system would slow down over time. That issue seems to have gone away as well. Very strange.

Thanks for the help.

1 Like

hey @Josh2 ,

thanks for updating this thread, yeah that is quite strange, I’m leaning to perhaps an active process in the background preventing OS to sleep. do let us know if the issue pops again.