[SOLVED] UHD Graphics instead of Iris Xe on 1260P?

Just got my new laptop (i7-1260P) and installed Win11 on it. The device manager shows “Intel(R) UHD Graphics” but I thought it had a dedicated GPU called “Iris Xe Graphics”.

I ask because I’m trying to use 3D cad software on it and I can’t select “OpenGL” mode since, evidently, the UHD graphics doesn’t work for it. Am I screwed? Am I missing a driver? Can I activate the dedicated GPU somehow? I can’t find any documentation on this.


1 Like


As far as driver are concerned, you should be good to go if you got the bundle from the official framework website in case you did not get it already.

EDIT: My bad, Removed wrong link.

As per the comment below, make sure you are getting the drivers for the 12th.

1 Like

For the 12Gen you have, please see the following


Thank you. I did already install the driver bundle for the 12th gen system. What should I see in the device manager if everything is installed correctly?

1 Like

These machines do not have a dedicated GPU. They have an integrated GPU (iGPU) that is part of the processor.

I don’t think this is a driver issue. My guess is you are only running with one stick of memory which means the iGPU will be running in a degraded state and show “Intel(R) UHD Graphics”. To have it running at full performance which is when you would see “Iris Xe Graphics”, you need to have dual channel memory.

Here is the summary from the Intel site:

…in single-channel memory configurations will default to less than 80 EUs, in alignment with Intel® UHD Graphics branding.

Could that be it? Or are you in fact running in dual channel mode?


You’re right in that I only have one stick. Had no idea that would be an issue. Great excuse to get another!


I agree. I need an excuse to buy more stuffs too. :slight_smile:


Wow, that’s worth mentioning in the webshop while folks are selecting memory in the webshop. I luckily already went for dual channel but didn’t know this.


That’s a good idea a note about it in the webshop would be nice. This was the same behavior for the 11th gen. chips as well.

1 Like

@gizmosmith55 I’m going to go ahead and rename the thread and mark it as solved as the title is a bit vague and your issue was resolved. Thanks to @nomb85 for teaching me something new tho!

1 Like

You can if you want. I’d suggest waiting until I get my second stick of ram and then seeing if the graphics card automatically activates.


I bought some extra RAM the other day to fill both slots. (without reading this thread).

I wanted to use this laptop for some light gaming but found the iGPU couldn’t handle it, so I have just ordered an eGPU to supplement it. However, I booted up the game (Final Fantasy 14) just now on reading this thread, now that the extra stick of RAM is in place, and it has gone from ~15FPS to ~50FPS, which has made it playable! (kinda regret ordering the Core X now)

Wish I knew this before, would have been good to know when purchasing the laptop.


I can also confirm that adding in the second memory card made the Iris XE show up instead of the generic UHD graphics and graphics are a lot faster now.


I’m glad everything is working for you!

I ended up buying a Core X Chroma and putting a 3090 in it and it’s great! I think you will still be happy to have an eGPU as well.

If you are running Manjaro I made a thread about my journey here: [GUIDE] Manjaro, Kernel 5.18+, eGPU, Nvidia

1 Like