[SOLVED] Upgraded from 11th gen I5 to AMD mobo and Im having issues

First off, I run Debian, so I know Im not going to get official support. Thats fine.
However, as I was (and now am again until my AMD file system gets fixed), running a perfectly happy Debian installation of my gen 11…My problems “must” be affiliated with the bios or amd drivers…right? Im just hoping someone can help me pin down what the problem is, or where to look.

My problem is entirely to do with my external monitor behavior in XFCE.
I have the LG 34WN80C-B connected via usb-c through a Dell Thunderbolt Dock- WD19TBS.

This setup works fine with my intel hardware and debian 12. Sleep/wake. laptop lid closed and in its cradle.

On the amd, I have several behaviors that I was trying to fix, and in the process, crashed my file system and cant boot into it anymore.

If your interested in trying to help on that front:

So, my external monitor…It mostly works…gets recognized fine, but I cant close my laptop lid without it shutting off…and by shutting off, I mean I cant get it back without unplugging/replugging the usb-c cable. xrandr shows it available. I can set it to primary. It just sits blank in power savings mode. If I then disable the lid screen, I get 2 blank screens.
but Im not in sleep mode. I can retype in the blind to get my laptop screen back. I tried various xset commands to force it awake, but no luck. Eventually I tried edditing my /etc/systemd/logind.conf file to set all the lid switch settings to ignore. This is what I believe crashed my system. I rebooted fine, then crashed within a couple minutes of being up…several times until it couldnt find the file system…
Prior to this, it had been running for weeks just fine…except for the lack of sleep mode.

I had run the amd s2idle.py script and eventually got a clean bill of health after a little fiddling.
I ran a xfce4-power-something in debug mode and got a warning about laptop lid was inhibiting sleep…hence my trying to ignore the lid…So a side note, setting the screen to off in the power manager settings (exactly like it is on my intel setup), shuts down the external screen same as above.

I installed the 3.03 BIOS
I had downloaded and copied the github amdgpu drivers into /lib/firmware/amdgpu
I had also self compiled the 6.6.8 kernel from kernel.org.

Any ideas? I may be re-installing from scratch…so anyting to avoid next time? other than dont touch /etc/systemd/logind.conf?

1 Like

Everyone’s mileage is going to be different when it comes to docks and multiple external displays. It may just be one of those things where it takes a bit for your particular device to hit the upstream on Linux or AMD updating the hardware drivers. Unfortunately it’s a waiting game and nothing Framework can really do except use their connections to maybe escalate the issues.

I’ve also had issues with the sleep/wake on this system…many others have as well and I’m sure it’s being looked into for a future update.

Overall…it’s going to be growing pains for a little while. It was when the 11th gen board first released. Before I upgraded to my AMD board, it finally felt that the 11th gen board aside from the coin battery issue, was finally running solid and baked in.

To give you an idea of my setup, I’m running a dual boot, Windows/Fedora and I’m running my external monitors through an OWC Thunderbolt dock. I have no issues with the displays running other than when I unplug from my USB port and replug, it takes one of my two extra monitors a bit longer to recognize and the computer kinda lags behind for a minute until the second one turns on. It’s a odd behavior but not a killer. As far as the closing lid issue, my laptop usually hangs up if I leave for a few hours closed and starts running really hot as if the CPU is stuck on an infinite loop, minus the fans though, they don’t even kick in. And when it comes to system files, be careful. Better to start over honestly at this point.

Thanks for the input. I appear to be up and running…undid my changes in the .conf file and I seem to be stable again. fingers crossed.

I did stumble across a “hidden” setting in xfce4-power-manager that seems to be working for now. Lid is closed and external screen is working…

1 Like

Thanks for updating this thread @Ryan_Horst , marking this as solved. :blush: