[SOLVED] Using the AX210 with Linux on the Framework Laptop

Also if you need to use an older distro version for various reasons, you can usually install upstream kernel packages which are not officially supported to get the latest features needed.


Time to brush up on my linux! Looking forward to the framework teams guides (and community guides) on getting a few of these common distros up and running!

1 Like

It’s also worth noting that if you plan to run an Ubuntu long-term support (LTS) release or an OS built on the Ubuntu LTS repos like elementary OS, the point-releases also get updated hardware enablement (HWE) kernels—albeit a bit later. Ubuntu 20.04.3 LTS (due soon, I think?) will have the same updated 5.11 HWE kernel that comes to newer non-LTS releases.


@nrp should this be on the DIY order page — seems like a crucial thing to be aware of when ordering.


Note that AX210 Wifi card requires Linux Kernel 5.10 or above.

Current Kernel for Ubuntu 20.04 is 5.8.

Any Framework DIY setups should use Ubuntu 21.04 which has Kernel 5.11.

Otherwise, WiFi and Bluetooth will not work.


I’ve changed the first post to be a wiki post, and will pin this as soon as we fix our database issues.

Per Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues by @mbernhard there are regressions on newer kernels too.

1 Like

I have just installed Linux Mint 20.2 from USB - which installs kernel 5.4 only. Alternatively, this link describes a way to modify the USB live ISO for other kernels:
Modify Live Iso to use any kernel version. - Linux Mint Forums”.
I choose to not go that route because it’s rather complicated.

I did however use my Raspberry Pi WI-FI USB dongle to gain network access for updates. And then was able to install-activate the kernel to 5.11 (.0-25-generic~). Kernel 5.12 was not presented as an option within the LM Update Manager app. Post re-boot everything seems to be working including BT and left-right click, 2 finger scroll & tap entry pad mousing without changing other settings. BTW - I have the no-vPro Wi-Fi module working on 2.4 and 5G WI-FI bands.


I’m on 5.13.7 (fedora respin) and the WiFi is giving me throughput of about 5mbps when other devices on the same network are in the 100mpbs range.

Starting to dig into it, but wondering if others are hitting similar issues?

1 Like

@Anil_Kulkarni could you double check that your WiFi antennas are connected fully, with the WiFi bracket on top of the card: WiFi Replacement Guide - Framework Guides

@Anil_Kulkarni I do … 5.13.8-arch1-1 is a little bit better but then you loose your bluetooth. There is a new firmware + driver patch on linux next I am trying now. If this doesn’t work I’ll try windows to be sure.

I checked my antenna connection too (that was my first suspicion).

I ended up working around this for now by disabling AX modes for the wifi:

cat /etc/modprobe.d/iwlwifi.conf

options iwlwifi disable_11ax=Y

Hopefully the driver support improves soon :frowning:


Update: Disabling 20/40mhz coexistance on my router seems to have solved the issue without disabling wifi6 on the card. See [SOLVED] AX201 Slow Wi-Fi / Newbie Corner / Arch Linux Forums


I didn’t look at this compatibility thread before ordering my DIY edition, and ordered the vPro version of the AX210. It’s working fine, but I do get a fair bit of standby battery drain (about 2-3% per hour) even after enabling deep sleep and even when turning off the wifi in Ubuntu desktop. Is this likely to be a vPro issue, and if so, is there likely to be a software fix in the future or should I just order a non-vPro replacement card?


It likely depends on Intel’s kernel driver plans, which we don’t have visibility into.

I’m having a very weird issue with my WiFi. I ordered the AX210 from Framework for my Linux build. However, I found that my download speeds were very slow compared to my other laptop running Linux. (4 to 8 times slower) Both laptops have the same upload speed. I spent a lot of time trying various kernels, distros, and parameters for iwlwifi.conf and default-wifi-powersave-on.conf, to no avail. I finally decided that it would be easier to spend $20 on a new wifi module, so I ordered one with the AX200ngw chipset. Same exact speeds. In frustration I switched the AX210 WiFi module with the one working fine in my other laptop, and NOTHING changed! The AX210 had fast downloads in the old laptop, and the formerly fast WiFi module had the exact same slow download speeds in the Framework laptop. Both machines have the same configurations. It seems to me that there’s something going on specific to the Framework laptop. Any ideas?

@FsOver2 Could you post results from a wifi performance tool like wavemon including the detailed Info section (F1), if you want to AB compare between your two systems we might be able to narrow down the differences:
If you want to share your router and approximate distance it could also help.

Also please remove your mac/ssid/router bssid if you are going to post screenshots output for privacy.

@FsOver2 could you also confirm that the WiFi antennas are connected fully, with the silver bracket on top of the card to keep them in place? WiFi Replacement Guide - Framework Guides

@Kieran_Levin,@nrp: OK, one more twist in my WiFi saga. Yesterday, Ubuntu 20.04 on my old laptop, the one running the AX210 fast (I moved it over from my Framework machine. I know, it has the wrong kernel version, but it was working) offered to upgrade the kernel. I did, and now the AX210 stopped working on the old machine under Ubuntu 20.04. I then ran various live distros to get the AX210 to work, and now both machines are experiencing the exact same slow download speeds (the Intel AX210 on the old laptop and the Intel 3165 on the Framework laptop). So now it’s clear it’s machine independent. Not Framework’s fault. I wonder if the AX210 was using the 3165’s firmware on the 5.10 kernel, and that was the magic sauce. Just guessing at this point. :thinking:

I haven’t had access to the WiFi router, but that’s the next place I’ll start poking around.

1 Like

I mentioned this in another thread, but I’ll throw it here too:

I have the AX210 (non-vPro) running elementaryOS 6. I ran into the wifi issue and was able to work around it by installing the latest linux-firmware package from Ubuntu for hirsute without updating the kernel. Currently running on 5.11.0-27.