[SOLVED] Wifi problems 5GHz (not working)

kind of weird but I am noticing the display is varying a lot in brightness. I thought it might be an ambient sensor thing but now I am wondering with this wifi issue.

PopOS does have an automatic brightness feature. It should adjust the brightness based on the available light and from what I could tell from this other forum post it seems to work OOTB.

As for your wireless issue, you can get a utility called iwevent that will give you some better insight into what the wireless interface is doing when it disconnects. You could also try some of the basic troubleshooting steps mentioned in this System76 troubleshooting article, which also mentions iwevent. You would probably more interested in the Useful Commands section of the article.

This forum is awesome thanks for all the help. I am trying to get this tool but I am having something real trouble with my internet now and am using my phone for the forum.

So I switched to 2.4GHz and it has been pretty stable.

as an update 2.4 GHz seems to work totally fine with no drops. I will try the 5 GHz tomorrow more and see if I still have problems. But I can say the 2.4 GHz seems to have no or little problems.

If 2.4 has no problems then it could just be a range problem. The 5 GHz band has better speeds with wireless n/ac protocols but doesn’t have the same range that 2.4 does. If you are using the laptop a good distance away or with lots of walls/obstacles in the way that could be your problem. When you do try the 5 again you could try using the laptop closer to your router and see if it stabilizes.

@IPGentlemann I am sitting 3 feet from the router/AP. I cant imagine it is a range problem.

Might still be something to consider if the antenna cables aren’t seated properly on the network card. Range is definitely decreased for the card itself if the antenna isn’t connected properly.

If those are all good, then knowing that it is just one frequency that is going wrong helps narrow things down. It seems that it’s not the first time it’s happened for PopOS.

If the antenna are all set, then it is definitely something going on under the hood. PopOS says that this should be your driver with intel cards. You could try verifying its installed and updating/re-installing it.

“The name of the Linux driver for Intel Wifi cards is called iwlwifi and is included in the kernel by default. All information about the driver can be found here:”


@Jack_Thorne - I’m running Pop!_OS and not having the issues that you are experiencing. I will be happy to go over any settings etc to try to help you sort things out. I don’t recall that I have done anything to customize my wifi setup.

@lbkNhubert thanks! I have not changed any settings for wifi but I appreciate the help. What setting can I list for you?

@IPGentlemann I have been doing more wifi debugging today. I have not seen anything in the logs from iwevent but the wifi is still dropping out. here is an example from the logs when the wifi drops out.

16:59:43.253745   wlp170s0 Association Request IEs:00126361666665696E65206E6574776F726B203501080C1218243048606C21020016244A240128012C013001340138013C014001440148014C0150015401580
16:59:43.253785   wlp170s0 Association Response IEs:01088C129824B048606C350100410100460502000100002D1AEF0917FFFF0000000000000000000000000000000000000000003D16240D15000000000000000
16:59:43.253801   wlp170s0 New Access Point/Cell address:F0:99:BF:08:9A:E5
16:59:54.569706   wlp170s0 Scan request completed
17:00:07.468005   wlp170s0 Scan request completed
17:05:19.646777   wlp170s0 Scan request completed
17:10:31.769116   wlp170s0 Scan request completed
17:15:05.195667   wlp170s0 Scan request completed

@Jack_Thorne - is there anything interesting or notable in your router logs? As IPGentlemann noted above, you might check the antenna connections, but be careful, they are very fragile. I’m going to leave iwevent running on my machine to see if it captures anything interesting. I’ve seen other threads on here where people were having problems and disabling ax helped, but I haven’t run into that myself.

See these threads:

Looks like the ax setting was more related to slowness. Others mentioned potential router incompatibility. My routers are Asus and so far so good, fingers crossed.

As an update I have taken apart the laptop tonight and taken a look at the wifi connectors. They look fine. I did not use a magnifier or anything special. It makes me more and more nervous taking this apart after reading this forum. anyways put is back together and tested 2.4GHz and 5GHz network and have the same problem. I might back up everything and try out an arch distro this week. This is my daily driver now so it makes these changes harder to make on short notice.

I have upgraded Pop_OS and so far it seems like I do not have any more 5GHz problems.I have run it for less then a day but the immediate problem seems to be solved. I will probably run 2.5GHz for important tasks for a while but it seems like a driver update might have solved this.

$ uname -v
#202111250933~1638201579~21.10~09f1aa7 SMP Mon Nov 29 16:23:13 U

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Pop
Description:	Pop!_OS 21.10
Release:	21.10
Codename:	impish

So after having some time to test it just seems like the new PopOS switches to 2.4GHz more smoothly. When on 5GHz it is still unstable and basically broken.

I’m having the same issues.
It worked fine at the beginning but now I can only connect to 2.4G network.
When I delete the network and try to rejoin, It does detect it but refuse the pass.

I’m running :

uname -v
#36-Ubuntu SMP PREEMPT_DYNAMIC Fri Feb 3 18:36:56 UTC 2023
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.10
Release: 22.10
Codename: kinetic

Any ideas on how to troubleshoot this issue ?


Yes, please post your system log with related messages (dmesg and/or journalctl).

Echoing @Anachron’s suggestion, it’s also worth adding -f.

journalctl -f

Then try the connection again, see if you can capture an error in real time. Dual band has never been “amazing” on Linux, but there may be environmental factors as well. Worth trying the above command and seeing if a clear error is present.

I had some errors on the log. Rebooting the router and the laptop solved the issue. It did not happened again.

1 Like

Delighted to hear this!