[Solved] Why won't my laptop charge past %65

Why won’t my laptop charge past %65? I’ve had it plugged in for about an hour and it won’t charge past %65.

1 Like

Most obvious (but unlikely) first: Did you set a charge limit in the bios?
What color does your charging indicator have at this stage?

Which laptop do you have, what OS and what charger etc.

Can you still discharge it below, let’s say 50%, and then rechange it to it’s max which is recorded as 65%

Unless you have a BIOS setting as mentioned by @Simon_F maybe you could check by calibrating the monitor by discharging completely. Rub down till auto power down. Wait 20min power on until it powers off again.

Simon_F where do I find the charge limit? I tried looking around in the bios but I can’t find it. Is it possible that the bios I have doesn’t have that option?

Hi BIOS 3.07 to 3.10 all have it for sure as I have used them and set to 78%

Advanced > Battery charge limit.

Select > Type in value > Enter and click Yes etc.


1 Like

@amoun, my bios doesn’t have that. I must be running an older BIOS flash. Where do I get an updated BIOS? across from “insydeh20 version,” it says “GFW30.03.06”

These are for the 11Gen version only

@amoun where in the bios do I find my intel gen?

The above link for Win 10 :: Win 11 :: Linux
Download and then click on the file if you are using windows. It is automatic and will take a while.

found it

You may want to do the driver bundle first :slight_smile:

@amoun I did, thank you. Now it will fully charge as it should