Wifi card screwup!

@nrp, Thank you so very much for your response. I tried replying from phone, but not sure if that made it through. One of the great things about the framework is that, when we make a mistake like this, finding replacement parts is easy. I found some thin replacement laptop antennas with pressure-sensitive adhesive and wiring, and they should arrive today. This is exactly why getting one of these laptops changed my mind about laptops!

Thank you!


You may just need a new wifi module, not an antenna. Inspect the wifi card and verify if both of the grounding rings are still there on the wifi card. It’s possible that one of the grounding rings has broken off into the wifi socket. If so, removing it by carefully hooking it out with a very fine needle. Note that the broken ring is so fine that it’s almost invisible, even with magnification.

Attaching the antenna to the wifi module and keeping them connected while I slotted it into the M.2 slot was really difficult. I was a little worried about damaging the contacts myself.

1 Like

@FarmerJ and @Johnny_B, thank you so much, and I will take more care tomorrow. I really am excited by having a laptop where I can recover quickly after something like this!

I’ve actually been doing some testing and I’m getting very poor speeds on both Windows and Linux. Is it possible this is because of a poorly installed wifi module?

@RandomUser Well I think the problem is actually my AX router. If I disable AX my speeds are good.

A user on Reddit reports that disabling OFDMA on their router resolves the issue: https://www.reddit.com/r/framework/comments/pc6lee/very_slow_wifi_with_ax210_no_vpro/

802.11ax is still pretty early, so it is possible there are weird interactions on specific routers and cards.

@nrp, I tried responding the wrong way, and thank you so much for your message. Another community member suggested going to eBay for replacement laptop internal antennas, but there are plenty off of Amazon. A pair arrived yesterday, but family time was more important for the evening. Hoping to dive in tonight. Replacement network card should arrive this afternoon.

As for the connectors, these make sense. My favorite RF connectors (BNC, RCA, and SMA) wouldn’t make any sense in a laptop. (I’ve actually pumped almost 1 kW of RF through an RCA.) I’ll be less heavy-handed this time, and working under a magnifier will make more sense, too.

Again, thank you!

Unfortunately, these connectors are industry standard for WiFi modules laptops, mobiles, SBCs and so on. I had the same pain attaching antennas to WiFi M2 modules for my Nvidia Jetson Nanos in the past. And I had a nightmare replacing the module and antennas for my Dell XPS laptop( Dell even tracks serial number of the WiFi installed and blocks booting if they do not match). Although, somehow, I haven’t destroyed any single item yet. :joy:
P.S. Also, Frame.Work can potentially confirm( I hope :innocent:) – any modern existing M2-based laptop WiFi module should work. I mean you can install something 2-3 years old and reliable, 100% supported by Linux and any onther OS if you have the problem with the newest Intel WiFi chipset that Frame.Work is installing.

1 Like

@KOSTYANTYN_RUKHLIS, thank you! We will see tonight if I am better prepared. I’ve got one of the more modern Intels arriving tonight. Kubuntu 21.04 looks to have kernel 5.11, so fingers crossed.

I might’ve done the same thing. I had a lot of trouble getting the black wire on but eventually got it. I’ve noticed that in Fedora, my signal strength is not as good as my iPhone, even when less than 10ft away from my 802.11ax router. The iwconfig command says my signal is 63/70, and I’m down a bar. I get full bars on my iPhone.

Could something be wrong, or does it seem to be functioning properly?

This probably won’t fit or perform well, since the antenna module is custom to the system both for mechanical fit and to have the antennas placed clear of metal parts. It’s possible it will function though until we’re able to get replacement antenna modules into stock.

Could you share which router you’re using?

1 Like

Sure, it’s a Netgear Nighthawk RAX40.

Could you check if disabling OFDMA on it improves performance? This isn’t something we have tried, but another AX210 user found that it resolved the issue they had.

I basically did the same thing, and I also thought I was being very careful! So we have quorum for a support group. :handshake:

I was having a hard time fitting the black wire into its channel, and the connector kept popping off when I nudged the cable. Eventually I must have applied pressure at an angle. It was hard to tell without magnification, but I think I smooshed the inner part of the connector on the cable, just slightly.

After some meditation and a final careful click, it seems to be holding. I’m getting a good wifi signal, at least! I’d like to remove it to inspect it again with a magnifying glass, but I’m leaving it alone for now. Just in case that’s the proverbial straw.

1 Like

What worked well for me was to take the cables out of a couple of rungs, lay the card down on a hardcover book next to the machine, line up the connector to the chip, and use the spudger to apply force to the top of the cable connector. Don’t think I damaged anything since I’m getting pretty good wifi so far but didn’t check it with magnification or anything. Spudger seemed to do a good job distributing the force equally to get it to snap into place nicely without breaking it. From there, it was easy to put the chip into the receptacle and adjust the angle of the cables so they didn’t hit anything.


Connecting the wires on a hard surface with the spudger is a pretty great workaround! Will do that when mine arrives in the mail

THIS, just THIS… this is why we love the Framework! Okay, so a couple of days ago, I screwed up the wireless install. Oh, I did it well, so that I needed antennas and the card. NJP cautioned about antennas and the two that arrived yesterday were indeed a bit large for the nonmetal space. Two that arrived today (https://www.amazon.com/gp/product/B07DB6ZG3B/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1) are about the size of the original Framework antennas. I’d like to order the original for the more flexible wires when the marketplace opens.

Anyway, the replacement wireless card also arrived today. This time, I installed under a magnifier (thank you brother for the lit magnifier) and no problem with the connections.

Here’s where it pays to read the instructions. Saw no wifi when Windows was starting its install thing, so I figured I had gotten the wrong antennas or screwed up again. After a little break, I remembered something about a Windows driver bundle. BAM! Got wireless, and the system is going.

Now, it’s time to go into the BIOS to boot from USB. (K)ubuntu 21.04 is running off of the 5.11 kernel, and I’m just not a big fan of Windows outside of a few games.

I have to say, the support team at Framework really is top notch, and it made my day to actually get responses from NJP. Someone mentioned a support group, and we definitely have it!d


Yeah. This laptop is everything I wanted and more! Although I normally hate the mousepad, I really like the Framework better than others. Maybe I already said this. If so, I apologize, but maybe we can blame it on the bourbon.

Happy with the sound, and been watching music on Youtube. Yes, I know I should pursue dual-boot with Windows 10, but life is too short.

1 Like

Unfortunately, turning off OFDMA didn’t make a difference, @nrp.