[SOLVED] Windows 11 2H22 Won't Install -- Missing Media Library?

I’m trying to install Windows 11 2H22 from USB, but I get an error message basically telling me I need a media driver to find my hard drive. The driver pack does not appear to have a usable driver for me to use. The NVME is a Samsung 980 Pro.

Anyone have something I can refer to get this fixed? Probably need a driver from Intel, but not sure where to go. Thanks!

Yes, I had the same problem a few days ago, try different ports or rebuild your bootable device using different tools. I also have an issue with shutting down or restartin that I couldn’t resolve. Now im trying to install ubuntu.

1 Like

This happened to me when I created a Windows 11 installation USB from Linux…

It worked when I tried again creating the W11 installation USB from another Windows already installed somewhere else.

1 Like

Okay I recreated the USB using Microsoft’s media creation tool, and it worked fine. I had done this before, but it didn’t work… may have fumbled something. Anyway, Media creation tool worked for me, too. Thanks for the input!


Nice!! Very glad it worked!
I’m marking this “solved” in the title then.

1 Like