Stuck in a loop

Hey all,

So I opened my laptop this morning and instead of waking, it seems to have entered some kind of loop:

  • the keyboard backlight turns on
  • the power button lights up
  • the fans spin up
  • screen remains off

It sits like that for about 30 seconds before it seems to power off, but 5 seconds later it starts all over again. It’s stuck in some kind of a loop.

I’ve tried holding down the power button while it was lit up, but it had no effect. I was able to “break” the loop by waiting for it to power off, then hold down the power button.

With it “off”, I cracked open the case and removed the battery connector, thinking that it was just stuck trying to wake from sleep. Reconnected the battery, started it up, and it’s still in the same looping state.

I’ve emailed support, but hoping maybe someone has seen this behavior before and knows how to fix it?

It does this while plugged in?

Both on and off battery.


Popping out the CMOS battery seemed to do the trick. I’m back on the framework as I type. I’m not exactly sure why it happened, but at least I know what to do if it happens again.


So I thought this was a solved issue, but the next time I put the laptop to sleep it entered the loop again, and I had to reseat the CMOS battery.

Obviously this is less than ideal.

I’m still running the firmware version ( that the laptop shipped with. I tried to update via fwupdmgr last week but despite it seeming to have run, I’m still on the old version. I’m beginning to suspect that failed update has left the firmware in a somewhat broken state.

Unfortunately LVFS is still not ready but there’s a standalone updater for 3.07, the EFI Shell update:

I’ll give that a try. I was able to update to 3.06 using an Ubuntu Live CD, but now the battery isn’t charging. Whoops.

ETA: That’s going to be a problem. It seems like none of my expansion card ports are working. USB-C won’t charge. USB-A isn’t recognized, so I can’t boot to a drive with the EFI shell update.

Whoops, time to contact support.

Yanking the CMOS battery fixed the charging issue. I’m not sure if the sleep issue is fixed yet, but that’ll be the next thing to test.

Updated to 3.07 via EFI Shell/USB drive. Everything seemed to go smoothly, and everything is working afterwards. Suspend seems to work as well so it looks like things are back to normal.

Thanks for the help, @Fraoch!


Whew, glad that fixed it! :grin:

It’s so weird hearing these buggy things happening with framework…

I’m just now getting this issue. My laptop reset and has been in this loop. I tried everything with disconnecting the battery strap and the CMOS battery. There was at one point where it booted up with Windows saying that it couldn’t load properly. I clicked on “retry” and it just continue into the loop and I never got that screen again. I’m not entirely sure what to do next from here on…