Sudden shutdown during Memtest86 (AMD version)

I usually run memtest86 when I get new computer. I do this same test in my framework 13 AMD version, but I cannot finish this test. I did 4 times but always sudden shutdown during testing.

In the begining, I think it may temp cause the system protect to shutdown laptop. I add small fan to make system cooling. The memtest86 still shutdown.
Before the memtest86 shutdown, there’s no errors.
I checked the log. 3 times during Test 8 and 1 time during Test 6.

I’m not sure it’s hardware or software problem.
I use 32G*2 a-data DDR5-5600 RAM. Did anyone run memtest86 in framework 13 without problems?

I do always the same as you so I did with my Framework AMD. I have used Memtest86+ (opensource) from
It ran successfull 1 pass, that was enough for me. Try again with one stick at a time.

1 Like

what software is this precisely? other poster already mentioned the well established and modern memtest86plus (= )

Thanks. I’ll try memtest86+.

I use original Memtest86. (
Memtest86+ is using smae algorithm to test memory. The memtest86 was acquired by Passmark.
I use 86+ before, but I remember it does not support multiple core. It will take a long time to test large memory. I’m not sure that it supports multiple core now.

please do verify if things are still the same you consider them to be :wink: time moves on. memtestplus does have a lot of modern features in the mean time.

Multicore is available and enabled by default. It is available since a very long time, but wasn’t enabled by default.

1 Like

Why multiple passes? This is a laptop :frowning: a consumer laptop at that. don’t kill it!

I used to run furmark at high settings to test all the 820-2915 boards we fixed after replacing the GPUs on them. Some of them died less than 2 hours in.

At one point, for the hell of it, I tried testing normal repairs where I didn’t test the GPU… some of them died 30 minutes in.

It’s a thin laptop, 1 pass is enough to know it worked! Don’t torture it, IMO.

1 Like

No, I didn’t mention about multiple passes. It cannot pass 1 pass with full test in Memtest86. I just want to ensure the memory does not have any error.

BTW. I use Memtest86+ 6.20 to finish the memroy test.

I had exactly the same problem. I tested with Memtest86+ v7.00 and the Passmark version, all runs ended with unforeseen results: sudden reboots, freezings, once I saw a lot of red error messages. The test was able to pass only once with 1 core. I also thought on overheating, because I saw very high temperatures with all cores.

So my thought was: Test the laptop with another RAM. I changed it and voilà, the test was able to pass without any problems (changed GPU setting in BIOS too). The new RAM could pass 4 rounds with all 16 cores activated.

That’s why you can find [DDR5 ONLY] RAM Survey - Framework Laptop 13 (AMD Ryzen 7040 Series) and Framework Laptop 16 DIY - #134 by ajb

If something unusual happens, think on testing the RAM first. You can put the binary into the EFI partition and are able to start it through the UEFI firmware. But don’t forget to give the extension ‘.efi’.

One benefit to me: The new RAM is 7 3/4% faster :slight_smile:

Stable RAM is crucial for a stable system. One tilted bit can set your system on an ice surface …