Teething troubles

Hi, just received my Framework 16 and very pleased with it so far. I was prepared to send it back if the fan was too noisy or if the whole thing was too big and heavy or if it was too flaky to use but all those things are fine.

I did have some teething problems though that I thought I would share in case anyone else experiences them.

The first was a hardware problem - the screw that holds the main SSD in place wouldn’t come out - it just kept spinning. I thought it might be captive like the other screws but you can’t fit the SSD unless the screw is completely out. I had to prise it out with a screwdriver (complete with the female thread) and just sort of press it back in afterwards. So there’s a QC issue there.

I then installed windows, but couldn’t connect to the internet, either by wifi or cable. There were no lights on the ethernet socket. As suggested here I tried unplugging the cable and putting the laptop to sleep but no dice. Then some time later I suddenly realised it was working. Not sure exactly what made the difference - possibly resetting the BIOS.

I could then connect to the internet and got Wifi working after installing the driver package and upgrading everything (including the BIOS). At that point there were no errors visible in Device Manager.

Then I tried plugging in an external monitor and had the same sort of issue - initially it was as if the HDMI port didn’t even exist. I eventually tried swapping modules around and that got it working. It continued to work when I restored the modules to their original location (which I had checked for compatibility, I realise some modules only work in certain slots). So it’s possible it was a connection problem, or perhaps the reinstallation triggered a driver update.

I have two regrets about module choice. The first was getting the ethernet module, which sticks out too far and since I will rarely use it I’m going to put something else in that slot. I’ll keep it in my rucksack for the times I need it, but not keep it plugged into the laptop.

The second regret was getting the audio socket module, which I got because my wife still uses wired headphones - except that in the months between the pre-order and delivery she got some wireless earbuds so I don’t need it any more. I’ll probably replace it with a microSD reader or another USB socket. I probably should have ordered some spare modules, in other words.


Hi and welcome.

I have the 13" 11Gen Intel and one of my disappointments was that the µSD expansion card is not the spring type and the SD card sticks out a little, (all of 1.6mm) and isn’t that easy to get a grip of to pull out.

Temporarily I do carry it with the SD card in, inside a backpack, ensuring the SD card is up with little pressure on it. :thinking:

Temporarily: It is a backup for my personal files that were on a 256GB expansion card which wasn’t stable ~ has been replaced but not used yet ??


I had the same issue with my Primarty SSD screw being stripped and stuck in. Framework replaced the whole laptop and the new one arrived with the same issue but not as badly stripped. seems to be a very common problem, mainly stemming from the use of a chrome plated brass standoff for such a very fine thread. This can cause all sorts of issues.

2280 (long NVMe) screw? there’s been quite a few of those. IMO, the RMA should ship the offending screws in a bag so there’s no chance they come stripped from the factory.

Mine didn’t appear to have a stripped thread, the bushing it screws into had come loose enough to spin, I think. I guess they could ship me a new motherboard if they really wanted to “make it good” but honestly it’s not worth the bother, I’d rather glue it.

I occasionally repair laptops for a living, and it’s very rare that a laptop arrives with all its screws and mounting clips intact.

It’s a bit concerning that Framework appear to be knowingly shipping defective product though.

They pre assemble the laptops to test them in the factory so it most likely happens then.

The first one seemed to just be stripped and the second was a defective screw I believe that damaged the thread but didn’t completely strip it. Someone else said they has a screw with no thread at all.

I know of at least 5 other people that have had this issue now and its got to have happened a lot more than that if its happened this many times we know of.

Wish mine was spinning in the board but no luck there.

I’m a CNC and manual machinist by trade and using brass isn’t a good idea for such fine threads in the first place. It can easily be drilled oversized before tapping if swarf gets trapped, also as the threads are very fine it makes them weak, someone heavy handed on the assembly line can easily strip it.

1 Like

I wonder if they use small torque wrenches on the assembly line? I’ve never seen one that small but they must exist.

I must admit I was a bit concerned about getting it right when tightening those 16 screws manually during the DIY reassembly. Too tight and you can easily damage things, too loose and you end up with a small screw rattling around creating short circuits.

No sign of loctite either, which other manufacturers sometimes use. (I discovered just the other day that it doesn’t work the way people think, like glue - rather, it’s supposed to be put on one side only, then it bunches up as the screw tightens and puts pressure on the opposite side, creating tiny welds. Who knew?)

They should do, we have small tools with built in torque limiters for our assembly department at my work (mainly assembling delicate precision scientific equipment). You can buy torx keys with varying torque limiters in them for use on insert retaining screws on CNC machine tooling.

The cheap fix is to give the assembly line workers a screwdriver with just a thin shaft you can not physically turn too tightly. If you do, your fingers slip around the shaft instead of applying more torque to the little screw.

Just like you can not turn a screw with lots of resistance if you just use the shaft of the screwdriver instead of the handle. I do this a lot when assembling things then go back and torque the screws evenly after they have all been seated.

A better solution would be to do what some motherboard manufacturers do and make a pivotable cap like what ASUS puts on their motherboards. It just turns 180 degrees to lock the device in place. It is not like the drive needs to be held down with significant force. I can not imagine someone literally throwing around their laptop so much that it would pop free.

Here is a picture of what they look like:


A smaller solution might need to be developed for Framework or other laptop manufacturers. There might even be solutions already developed from other vendors; this is just one that I am aware of and have been impressed with.

1 Like

I found this https://uk.rs-online.com/web/p/torque-screwdrivers/7064821 (£200!) and this RT03346 26158 Wiha Torque Torx Blade T5 / 0.4Nm | eBay (£12).

Most of them don’t go that small.

The next question is obviously “what should the torque actually be?”.

Update: The cheap one looks like it just has an indication of the recommended torque.

Could I ask in what way the card was unstable please?

I think it was on one of these threads that someone posted a link to a little plastic device for this purpose. It uses a keyhole shaped hole in the PCB and is locked with a quarter turn. I think it was in a thread about fitting m.2 drives in the GPU expansion bay area.

Personally I would much rather deal with the stripped SSD screw in mine over these things. I despise these mounting brackets for m.2s since to me it seems like there’s no guarantee it’s latched properly, and it feels like given how thin the actual spinny part is it’ll snap with even a tiny bit of force, not to mention pushing that against the SSD feels like it’s going to dig into the board and break it. All of this is from experience with my desktop having these mounting brackets for all 4 SSD slots.

It’s most definitely a small minority of laptops in the affected batches, but I hope FW are investigating the issue.

I was referring to the 256 Expansion card unit not the &microSD.

The expansion card would just drop out and re-mount itself. Sometimes I wouldn’t noticed ~ until ~ I had an encrypted volume on the drive which of course I had to unencrypt each time.

It got worse and failed to be read at all. I contacted support and they replaced it, but it took the best part of two years to become a big issue and I think I lost some data on one of it’s dismounts.

1 Like

Not just that
a) everyone ships faulty products now and then and Framework are clearly no exception
b) The number of defects clearly does NOT do them much harm as they are growing and releasing new products
c) they are a new firm and I would expect an above average amount of recalls etc.
d) I’m sure they didn’t knowingly ship any defective product, in fact they do not do the shipping or build.
e) They design and finance and take responsibility for the customers and seems they do a pretty acceptable job.

Take care