Terrible Noise on the Internal Microphone

I’m having trouble with an extremely high noise floor (it’s clipping when I record it!). I didn’t notice it until I tried to make a video call and the person on the other end couldn’t hear me over the noise.

I ruled out fan noise, and using a USB microphone had no issues so it doesn’t appear to be a pulse/linux audio configuration issue.

Any suggestions on how to debug/fix? The internal microphone is unusable in this state.

2 Likes

I’ve seen this as well on my Linux-installed framework. I don’t think the OS does any filtering at all by default. I’m currently using PipeWire and EasyEffects to add a noise filter.

2 Likes

I ran into this problem as well. I resolved it by lowering the volume on the pulse source from 100 to like 30.

2 Likes

I just discovered an easy way to configure the mic base volume: alsamixer

Before:

After:

1 Like

For me the item “Internal” was also boosted. I could fix it with alsamixer. Thanks for sharing!

I had the same problem and was popping my colleague’s eardrums on video conferences. Solved by turning the mic down to 30% in Gnome Settings > Sound on Fedora 35. Default was 100%.