Thunderbolt stopped working reliably

I have a 2nd Batch, i7. When it arrived I was using my Razor Core X pretty reliably, but lately it’s all but. I also started having issues with a simple USB-C dock that ran Keyboard, Mouse, Microphone and LAN. Both started to reconnect/disconnect constantly. If I can coax them all into working, they don’t survive a reboot. Primarily I run them on the Left Side ports with USB-C Modules. Can replicate the issues on the right side as well.

I have upgraded to the 3.06 firmware and matching driver pack. I’m running Windows 10, but considering upgrading to 11 just to see. Then a clean reinstall of 10 as a last ditch effort.

I only have the one eGPU but I’ve also tried 3 different Hubs now. From a standard 4 port USB Hub, to a 12-in-1 USB-C hub, to a brand new yesterday Thunderbolt 3 Hub.

Anyone have any experience with something similar.

1 Like


I have found that over time what once worked, may not now, dur to wear in. So…

I would check the EMI shields and make sure that they are properly placed. It is something to check with batch 2 (I’m in that batch with the i7)

Also I find that the hub I am using is very picky about being plugged in only after windows is totally up to speed and all background applications are finished loading.

I suspect that it’s a timing issue for the handshakes that is not completed in the time frame the hub desires.

Yes I checked and fixed 3/4 ports with shielding installed wrong. It helped but didn’t fully resolve the issue.

At this point I’m requesting a RMA on the motherboard.

1 Like