Touchpad not scrolling and right-click not working

Setup my DIY edition, installed Windows 11, touchpad works but only with left-click. Two-finger scrolling and right-click does not work. The touchpad is being recognized as a PS2 mouse so it is not working as touchpad and settings cannot be controlled properly. Is this a Windows 11 issue or are other people running to issues like this?


Hey Dennis,

Have you already installed the Framework Driver Bundle?

I had same issue and was pointed to the driver bundle over in the Windows 11 thread because I couldn’t find any drivers or download links.

I’m not sure why they aren’t recognized by Windows Update yet but maybe in the future!

I have installed the Driver bundle and the BIOS update and everything is working now. It still shows as PS2 mouse but I guess that doesn’t matter so much.

I’ve also found another fix, If going into the device manager, there should be a warning sign next to an I2C HID device. Stop it, and restart it. I’m checking whether this persists throughout reboot after this post.

1 Like

From what it looks like, this does fix it. It might be it failing to start once, and continuing on reboot.

Yes, everything worked fine once installing drive pack.

1 Like

Same problem here, no results after installing drivers. Same issue.

1 Like

I don’t know if this is a permanent fix or not, but I was having the same issue of the right-click not working properly (not the scrolling though, as I don’t know how to use the 2-finger scrolling).

I went into Device Manager, looked at the Mouse section and uninstalled the PS/2 driver, then it asked to reboot, and it discovered the PS/2 driver by itself, but it also added a HID driver, and now my right-click is working again.

Will update if my issue comes back, right now its working though!


:point_up_2:t2: That worked for me, thanks. My scroll and right click weren’t working as well.

@Eric_Desnoyers how do you uninstall the PS/2 driver? The only uninstall option that I can see is for the device itself - I feel like that would be a mistake, I don’t want to mess things up even more!

@Ruaidhri_Lumsdem Sorry, that’s what I meant. Go into Device Manager, then search for the Mouse section and click on the arrow next to it. If you see a “PS/2” there, and uninstall that device.

Note; I’m having a weird bug though where I only have the HID present in the list, yet my right click isn’t working. I have to press with 2 finger in the lower right corner for it to work… has anyone else had that “bug”?

@Eric_Desnoyers No problem at all. Thanks for the quick response. I tried uninstalling however unfortunately it’s been unsuccessful.

The only HID device I’m getting seems to be the external mouse that I had to plug in when my touchpad stopped working completely - this was because I tried the solution that is on the Framework support page - I tried turning off PS/2 mouse emulation in the BIOS.

I haven’t had that bug, it seems like any press anywhere on the touchpad is registered as a primary click.

I’ve raised a support ticket so should hopefully get fixed soon - I’ll report back with any developments.

@Ruaidhri_Lumsdem I just noticed that my touchpad is behaving the same as you right now. However, if I tap the touchpad with 2 fingers in the lower right corner, it actually performs a right click. I haven’t changed a thing in my settings either, and it was working with a single finger beforehand… I’m a bit clueless, but the dual finger works

I contacted Framework directly too, because that behaviour is weird… hopefully they can answer fast and I’ll let you know if you haven’t had an answer before me.

@Eric_Desnoyers I haven’t been able to recreate the bug that you mentioned, however I did manage to fix my issue.

Apparently I had installed an out of date driver bundle. I’m not sure how I managed this, as I downloaded it from the Framework support page and it was listed as the latest version - perhaps I mistakenly downloaded one for an older model (I have the 12th gen version).

Once I ran the new bundle and restarted, everything is working just as expected.

It might be worth checking that you have the correct version for your model just in case you’ve made the same, admittedly pretty silly, mistake that I made!

I am also running into this problem. I reinstalled the touchpad drivers, among other things, and have had no luck.
Touchpad, gestures, and scrolling all work. But the left and right physical clicks don’t do anything.


@Adam_Bryant Did you try to update your drivers according to the following link:
Driver & Bios update for 11th Gen

1 Like

@Alec1 yes.

I’m currently experiencing this issue with a 12gen laptop. I installed the 11th gen drivers without realizing I was using 12 gen but the 12 gen drivers page has no options for Windows 10, which is what the laptop will be running. What drivers should I use?

Currently no right click or scrolling or gestures work

Windows 10 does not run on 12th gen, it’s unsupported, and there may be issues like this.

(Don’t blame Framework, Microsoft will not support 12th gen “Alder Lake” CPUs on Windows 10 so manufacturers are not producing or updating drivers for Windows 10 on this newer hardware.)