[TRACKING] Fedora Freezes and Flickering on newer Kernels

I decided to try out Silverblue two weeks ago, this may or may not help us narrow down whatever is causing these issues.

  • Fedora 36 or 37: 37 Silverblue
  • 12th gen or 11th gen: 1240P
  • Kernel version: 6.1.6-200.fc37.x86_64
  • Gnome version: 43.2
  • Using i915 fixes, if so, which ones: not tried yet
  • Has this been tried yet and if so, any difference: not tried yet
  • Applications running in foreground or background when freeze occurs: generally the Firefox rpm
  • What if anything is attached to your Framework; docks, (BT, IR, wired) mouse, keyboard: second monitor via hdmi, keyboard and mouse over usb, ethernet over usb: freezes occur whether or not anything is attached, nor does battery mode / cable seem to affect them.

Additonal notes

  • the freezing occurs a few times per day for a few seconds
  • the flickering of the upper few pixel rows gets markedly worse whenever nightmode is activated and tuning down the blue light during sundown, with nightmode turned off it happens occasionally during the day
  • all layered packages: btop, gnome-tweaks, intel-media-driver, langpacks-de, openssl, powertop, steam-devices, tlp
  • all tweaks:
sudo grubby --update-kernel=ALL --args="module_blacklist=hid_sensor_hub"
sudo grubby --update-kernel=ALL --remove-args="quiet"
sudo grubby --update-kernel=ALL --remove-args="rhgb"
sudo grubby --update-kernel=ALL --args="nvme.noacpi=1"
sudo rpm-ostree kargs --append='mem_sleep_default=deep'

All data same as my earlier post. 1st soft freeze since December 26th. No hard freezes in this time frame.

kernel: Asynchronous wait on fence 0000:00:02.0:gnome-shell[2562]:3dadc timed out (hint:intel_atomic_commit_ready [i915])
kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:0:00000000
kernel: i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
kernel: i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_70.bin version 70.5.1
kernel: i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc.bin version 7.9.3
kernel: i915 0000:00:02.0: [drm] HuC authenticated
kernel: i915 0000:00:02.0: [drm] GuC submission enabled
kernel: i915 0000:00:02.0: [drm] GuC SLPC enabledJan 21 13:07:32 Nuada 
firefox.desktop[3771]: Crash Annotation GraphicsCriticalError: |[0][GFX1-]: GFX: RenderThread detected a device reset in PostUpdate (t=10761.2)

More convinced than ever that a whole lot of this is on the gnome-shell and mutter.

1 Like

FYI: New Intel Media Driver dropped on Fedora 37 today. This one should have a bunch of fixes. SO if you are an infrequent updater, today might be a good day to do so :slight_smile:

1 Like

This is very helpful as the video visually demonstrates what is happening. I’m collecting data, so this is helpful.

Because you’re on Pop OS and may have a unique opportunity here, have you rebooted into “oldkern” to see if this behavior continued there?

Has doing a:

sudo kernelstub -o "quiet splash i915.enable_psr=0"

and reboot change anything for you?

Okay folks, this is where we see what happens! Please update and let me know after installing updates/rebooting, how it goes?

Thanks @Matt_Hartley for the heads up on the Media Driver in today’s update. I’ll update as soon as I finish this message. I usually updates daily.

I have been experiencing the freezing since receiving my 12th gen board. Here are the details to add to your spreadsheet:

Fedora 36 or 37: 37, and updating almost daily

12th gen or 11th gen: 12th gen

Kernel version: 6.1.7-200

Gnome version: 43.2-1 (at least for gnome-shell

Using i915 fixes, if so, which ones: None

Applications running in foreground or background when freeze occurs: I only experience it when I have an external monitor or external projector connected. I also get it when sharing a screen with zoom, but in every instance that I remember I also had an external monitor connected, so can’t confirm that zoom is contributing to the issue. I know I still get it without zoom, most notably when I have the screen in mirror mode and presenting in front of a class. I’ve only ever seen in on the laptop screen, and the mirrored projector does not show the 2-3 second freeze, nor does the Zoom screenshare show the freeze. I have also had a few hard freezes where a forced shutdown was required, which I’m not sure is related to this issue or not, but have no reason to suspect anything else

What if anything is attached to your Framework; docks, (BT, IR, wired) mouse, keyboard: I have had this occur with nothing but power connected on one USB port and a Framework HDMI or DVI port connected monitor. I have experienced it through both HDMI and DVI ports independently. I have also used presenter devices such as Logitech Spotlight, but also experience it without it.

@Matt_Hartley When you said multimedia updates, were you talking about the pipewire updates? If so, I updated them 24 hours ago, and was still experiencing the flickers today. I don’t see anything related to multimedia available at this moment.

Here is what I updated yesterday and the day before, none of which fixed the flicker issues:

Transaction ID : 171
Begin time     : Tue 24 Jan 2023 01:54:09 AM MST
Begin rpmdb    : 9d7a69bd65d6e7bb18c889f176151dfc1a25d99cc8ba6c03c3d64674e90eaa16
End time       : Tue 24 Jan 2023 01:55:25 AM MST (76 seconds)
End rpmdb      : fff81fe7faee4b039ea22c9e408d12ca92eb5db63516de12b09401ed4b675249
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Install  kernel-6.1.7-200.fc37.x86_64                                  @updates
    Install  kernel-core-6.1.7-200.fc37.x86_64                             @updates
    Install  kernel-devel-6.1.7-200.fc37.x86_64                            @updates
    Install  kernel-modules-6.1.7-200.fc37.x86_64                          @updates
    Install  kernel-modules-extra-6.1.7-200.fc37.x86_64                    @updates
    Upgrade  fd-find-8.2.1-10.fc37.x86_64                                  @updates
    Upgrade  kernel-devel-matched-6.1.7-200.fc37.x86_64                    @updates
    Upgrade  libnfsidmap-1:2.6.2-2.rc6.fc37.x86_64                         @updates
    Upgrade  nfs-utils-1:2.6.2-2.rc6.fc37.x86_64                           @updates
    Upgrade  pipewire-0.3.64-2.fc37.x86_64                                 @updates
    Upgrade  pipewire-alsa-0.3.64-2.fc37.x86_64                            @updates
    Upgrade  pipewire-gstreamer-0.3.64-2.fc37.x86_64                       @updates
    Upgrade  pipewire-jack-audio-connection-kit-0.3.64-2.fc37.x86_64       @updates
    Upgrade  pipewire-libs-0.3.64-2.fc37.x86_64                            @updates
    Upgrade  pipewire-pulseaudio-0.3.64-2.fc37.x86_64                      @updates
    Upgrade  pipewire-utils-0.3.64-2.fc37.x86_64                           @updates
    Upgraded kernel-6.0.18-300.fc37.x86_64                                 @@System
    Upgraded kernel-core-6.0.18-300.fc37.x86_64                            @@System
    Upgraded kernel-devel-6.0.18-300.fc37.x86_64                           @@System
    Upgraded kernel-modules-6.0.18-300.fc37.x86_64                         @@System
    Upgraded kernel-modules-extra-6.0.18-300.fc37.x86_64                   @@System
    Removed  kmod-v4l2loopback-6.0.18-300.fc37.x86_64-0.12.7-2.fc37.x86_64 @@System
    Upgraded fd-find-8.2.1-8.fc37.x86_64                                   @@System
    Upgraded kernel-devel-matched-6.1.6-200.fc37.x86_64                    @@System
    Upgraded libnfsidmap-1:2.6.2-2.rc5.fc37.x86_64                         @@System
    Upgraded nfs-utils-1:2.6.2-2.rc5.fc37.x86_64                           @@System
    Upgraded pipewire-0.3.64-1.fc37.x86_64                                 @@System
    Upgraded pipewire-alsa-0.3.64-1.fc37.x86_64                            @@System
    Upgraded pipewire-gstreamer-0.3.64-1.fc37.x86_64                       @@System
    Upgraded pipewire-jack-audio-connection-kit-0.3.64-1.fc37.x86_64       @@System
    Upgraded pipewire-libs-0.3.64-1.fc37.x86_64                            @@System
    Upgraded pipewire-pulseaudio-0.3.64-1.fc37.x86_64                      @@System
    Upgraded pipewire-utils-0.3.64-1.fc37.x86_64                           @@System
Transaction ID : 170
Begin time     : Mon 23 Jan 2023 02:00:20 AM MST
Begin rpmdb    : b55e179abce3bf3cb8c46ed79adddc6e7ac6a3917281542a522e9e1c9bcc6807
End time       : Mon 23 Jan 2023 02:00:42 AM MST (22 seconds)
End rpmdb      : 9d7a69bd65d6e7bb18c889f176151dfc1a25d99cc8ba6c03c3d64674e90eaa16
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Install  libplacebo-4.208.0-1.fc37.x86_64                                  @fedora
    Upgrade  ModemManager-1.18.12-1.fc37.x86_64                                @updates
    Upgrade  ModemManager-glib-1.18.12-1.fc37.x86_64                           @updates
    Upgrade  NetworkManager-1:1.40.10-1.fc37.x86_64                            @updates
    Upgrade  NetworkManager-adsl-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  NetworkManager-bluetooth-1:1.40.10-1.fc37.x86_64                  @updates
    Upgrade  NetworkManager-config-connectivity-fedora-1:1.40.10-1.fc37.noarch @updates
    Upgrade  NetworkManager-libnm-1:1.40.10-1.fc37.x86_64                      @updates
    Upgrade  NetworkManager-ppp-1:1.40.10-1.fc37.x86_64                        @updates
    Upgrade  NetworkManager-team-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  NetworkManager-wifi-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  NetworkManager-wwan-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  efivar-libs-38-6.fc37.x86_64                                      @updates
    Upgrade  firefox-109.0-1.fc37.x86_64                                       @updates
    Upgrade  firefox-langpacks-109.0-1.fc37.x86_64                             @updates
    Upgrade  git-2.39.1-1.fc37.x86_64                                          @updates
    Upgrade  git-core-2.39.1-1.fc37.x86_64                                     @updates
    Upgrade  git-core-doc-2.39.1-1.fc37.noarch                                 @updates
    Upgrade  gjs-1.74.1-5.fc37.x86_64                                          @updates
    Upgrade  ibus-1.5.27-5.fc37.x86_64                                         @updates
    Upgrade  ibus-gtk3-1.5.27-5.fc37.x86_64                                    @updates
    Upgrade  ibus-libs-1.5.27-5.fc37.x86_64                                    @updates
    Upgrade  ibus-setup-1.5.27-5.fc37.noarch                                   @updates
    Upgrade  iptables-libs-1.8.8-4.fc37.x86_64                                 @updates
    Upgrade  iptables-nft-1.8.8-4.fc37.x86_64                                  @updates
    Upgrade  koji-1.31.1-1.fc37.noarch                                         @updates
    Upgrade  libXpm-3.5.15-2.fc37.x86_64                                       @updates
    Upgrade  libinput-1.22.1-1.fc37.x86_64                                     @updates
    Upgrade  libnumbertext-1.0.11-1.fc37.x86_64                                @updates
    Upgrade  libqmi-1.30.8-1.fc37.x86_64                                       @updates
    Upgrade  libqmi-utils-1.30.8-1.fc37.x86_64                                 @updates
    Upgrade  libsoup3-3.2.2-2.fc37.x86_64                                      @updates
    Upgrade  libwebp-1.3.0-1.fc37.x86_64                                       @updates
    Upgrade  llvm-libs-15.0.7-1.fc37.x86_64                                    @updates
    Upgrade  mozjs102-102.7.0-1.fc37.x86_64                                    @updates
    Upgrade  mpg123-libs-1.31.2-1.fc37.x86_64                                  @updates
    Upgrade  perl-Git-2.39.1-1.fc37.noarch                                     @updates
    Upgrade  python-unversioned-command-3.11.1-3.fc37.noarch                   @updates
    Upgrade  python3-3.11.1-3.fc37.x86_64                                      @updates
    Upgrade  python3-devel-3.11.1-3.fc37.x86_64                                @updates
    Upgrade  python3-koji-1.31.1-1.fc37.noarch                                 @updates
    Upgrade  python3-libs-3.11.1-3.fc37.x86_64                                 @updates
    Upgrade  python3-pytz-2022.7.1-1.fc37.noarch                               @updates
    Upgrade  python3-tkinter-3.11.1-3.fc37.x86_64                              @updates
    Upgrade  python3-unbound-1.17.1-1.fc37.x86_64                              @updates
    Upgrade  rav1e-libs-0.5.1-6.fc37.x86_64                                    @updates
    Upgrade  selinux-policy-37.18-1.fc37.noarch                                @updates
    Upgrade  selinux-policy-targeted-37.18-1.fc37.noarch                       @updates
    Upgrade  sudo-1.9.12-1.p2.fc37.x86_64                                      @updates
    Upgrade  sudo-python-plugin-1.9.12-1.p2.fc37.x86_64                        @updates
    Upgrade  unbound-anchor-1.17.1-1.fc37.x86_64                               @updates
    Upgrade  unbound-libs-1.17.1-1.fc37.x86_64                                 @updates
    Upgrade  usbutils-015-1.fc37.x86_64                                        @updates
    Upgrade  vim-common-2:9.0.1221-1.fc37.x86_64                               @updates
    Upgrade  vim-data-2:9.0.1221-1.fc37.noarch                                 @updates
    Upgrade  vim-enhanced-2:9.0.1221-1.fc37.x86_64                             @updates
    Upgrade  vim-filesystem-2:9.0.1221-1.fc37.noarch                           @updates
    Upgrade  vim-minimal-2:9.0.1221-1.fc37.x86_64                              @updates
    Upgrade  ffmpeg-5.1.2-9.fc37.x86_64                                        @rpmfusion-free-updates
    Upgrade  ffmpeg-libs-5.1.2-9.fc37.x86_64                                   @rpmfusion-free-updates
    Upgrade  gstreamer1-plugins-bad-freeworld-1:1.20.5-1.fc37.x86_64           @rpmfusion-free-updates
    Upgrade  gstreamer1-plugins-ugly-1:1.20.5-1.fc37.x86_64                    @rpmfusion-free-updates
    Upgrade  libavdevice-5.1.2-9.fc37.x86_64                                   @rpmfusion-free-updates
    Upgraded ModemManager-1.18.8-2.fc37.x86_64                                 @@System
    Upgraded ModemManager-glib-1.18.8-2.fc37.x86_64                            @@System
    Upgraded NetworkManager-1:1.40.6-1.fc37.x86_64                             @@System
    Upgraded NetworkManager-adsl-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded NetworkManager-bluetooth-1:1.40.6-1.fc37.x86_64                   @@System
    Upgraded NetworkManager-config-connectivity-fedora-1:1.40.6-1.fc37.noarch  @@System
    Upgraded NetworkManager-libnm-1:1.40.6-1.fc37.x86_64                       @@System
    Upgraded NetworkManager-ppp-1:1.40.6-1.fc37.x86_64                         @@System
    Upgraded NetworkManager-team-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded NetworkManager-wifi-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded NetworkManager-wwan-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded efivar-libs-38-5.fc37.x86_64                                      @@System
    Upgraded firefox-108.0.1-3.fc37.x86_64                                     @@System
    Upgraded firefox-langpacks-108.0.1-3.fc37.x86_64                           @@System
    Upgraded git-2.39.0-1.fc37.x86_64                                          @@System
    Upgraded git-core-2.39.0-1.fc37.x86_64                                     @@System
    Upgraded git-core-doc-2.39.0-1.fc37.noarch                                 @@System
    Upgraded gjs-1.74.1-3.fc37.x86_64                                          @@System
    Upgraded ibus-1.5.27-4.fc37.x86_64                                         @@System
    Upgraded ibus-gtk3-1.5.27-4.fc37.x86_64                                    @@System
    Upgraded ibus-libs-1.5.27-4.fc37.x86_64                                    @@System
    Upgraded ibus-setup-1.5.27-4.fc37.noarch                                   @@System
    Upgraded iptables-libs-1.8.8-3.fc37.x86_64                                 @@System
    Upgraded iptables-nft-1.8.8-3.fc37.x86_64                                  @@System
    Upgraded koji-1.31.0-1.fc37.noarch                                         @@System
    Upgraded libXpm-3.5.13-8.fc37.x86_64                                       @@System
    Upgraded libinput-1.22.0-2.fc37.x86_64                                     @@System
    Upgraded libnumbertext-1.0.10-2.fc37.x86_64                                @@System
    Upgraded libqmi-1.30.6-2.fc37.x86_64                                       @@System
    Upgraded libqmi-utils-1.30.6-2.fc37.x86_64                                 @@System
    Upgraded libsoup3-3.2.2-1.fc37.x86_64                                      @@System
    Upgraded libwebp-1.2.4-2.fc37.x86_64                                       @@System
    Upgraded llvm-libs-15.0.6-1.fc37.x86_64                                    @@System
    Upgraded mozjs102-102.6.0-1.fc37.x86_64                                    @@System
    Upgraded mpg123-libs-1.31.1-1.fc37.x86_64                                  @@System
    Upgraded perl-Git-2.39.0-1.fc37.noarch                                     @@System
    Upgraded python-unversioned-command-3.11.1-1.fc37.noarch                   @@System
    Upgraded python3-3.11.1-1.fc37.x86_64                                      @@System
    Upgraded python3-devel-3.11.1-1.fc37.x86_64                                @@System
    Upgraded python3-koji-1.31.0-1.fc37.noarch                                 @@System
    Upgraded python3-libs-3.11.1-1.fc37.x86_64                                 @@System
    Upgraded python3-pytz-2022.7-1.fc37.noarch                                 @@System
    Upgraded python3-tkinter-3.11.1-1.fc37.x86_64                              @@System
    Upgraded python3-unbound-1.17.0-1.fc37.x86_64                              @@System
    Upgraded rav1e-libs-0.5.1-5.fc37.x86_64                                    @@System
    Upgraded selinux-policy-37.17-1.fc37.noarch                                @@System
    Upgraded selinux-policy-targeted-37.17-1.fc37.noarch                       @@System
    Upgraded sudo-1.9.11-4.p3.fc37.x86_64                                      @@System
    Upgraded sudo-python-plugin-1.9.11-4.p3.fc37.x86_64                        @@System
    Upgraded unbound-anchor-1.17.0-1.fc37.x86_64                               @@System
    Upgraded unbound-libs-1.17.0-1.fc37.x86_64                                 @@System
    Upgraded usbutils-014-3.fc37.x86_64                                        @@System
    Upgraded vim-common-2:9.0.1182-1.fc37.x86_64                               @@System
    Upgraded vim-data-2:9.0.1182-1.fc37.noarch                                 @@System
    Upgraded vim-enhanced-2:9.0.1182-1.fc37.x86_64                             @@System
    Upgraded vim-filesystem-2:9.0.1182-1.fc37.noarch                           @@System
    Upgraded vim-minimal-2:9.0.1182-1.fc37.x86_64                              @@System
    Upgraded ffmpeg-5.1.2-3.fc37.x86_64                                        @@System
    Upgraded ffmpeg-libs-5.1.2-3.fc37.x86_64                                   @@System
    Upgraded gstreamer1-plugins-bad-freeworld-1:1.20.4-1.fc37.x86_64           @@System
    Upgraded gstreamer1-plugins-ugly-1:1.20.4-1.fc37.x86_64                    @@System
    Upgraded libavdevice-5.1.2-3.fc37.x86_64                                   @@System

Updated yesterday (F37). Package to look out for should be the Intel(R) Media Driver for VAAPI in version

1 Like

@Simon_F @Matt_Hartley

Well, that is another bullet to add to Matt’s table. I didn’t have intel-media-driver installed on my machine. I had intel-mediasdk, but I’m not sure there was any value of having that without the driver, or how I missed the driver… I’m guessing that means there is a low likelihood that intel-media-driver played any affect in the flickering.

On a side note, I just taught another 8 hour session with an external monitor connected and sharing a screen with zoom, same as I did yesterday, but today I didn’t have any flicking issues. The only change I had made between sessions was doing the bios update. Since class ended an hours ago, I’ve added intel-media-driver and oneVPL so I’ll test for any flickering issues during tomorrow’s 8 hour class session. And for reference, I have never gone through an 8 hour class session since getting the 12th gen motherboard 6 months ago and not had flickering atleast 50% of the class session. I have also found that using the CTRL key to locate mouse pointer (used to emphasis bullets in slides while teaching) is a great way to case the flicker to occur on demand during that 50% of the time.

The new intel-gpu-firmware just dropped.

1 Like

I am typing this on Fedora right now - not able to replicate this on my end.

I have alerted my contact with the Fedora project and they indicated they too, had not seen any problems on their Framework either which make me wonder what possible common denominator might be at play.

Based on what you am seeing in your template.

Are you straight HDMI to HDMI or is there one of those DVI adapters involved by chance? I’ve seen them do weird things about 50% of the time in my own experience (other distros).

Zoom and WebRTC screen-sharing has been pretty wild with some browsers. I’ve seen oddness with Google Meet, Jitsi for example with Chrome, but better with Firefox. Whatever browser you use, I’d split test by disabling hardware acceleration in the browser.

1 Like

FYI: Another intel-gpu-firmware update dropped this morning.

I would like to point out that I have very similar issues:

  • Upper rows flickering just after wake up
  • Occasional full screen flickering observed, but rarely
  • Also 5 to 10 seconds freezes that appear maybe once every 1h

However, I’m not on Fedora, but Manjaro.

Some info about my system:

  • DIY 12th gen i5-1240P
  • Kernel 6.1.11-1
  • Manjaro stable
  • Gnome 43.2
  • X11
  • nothing attached to the laptop apart from the power cord

Toss in my latest experience into the ring.

On 12th gen right now, Fedora 37 Workstation, 6.1.11-200.fc37.x86_64, Wayland.

  • 2xUSB-C, one for power, the other for USB hub.
  • 1xHDMI expansion card direct connect to my 2k AOC display (#1)
  • 1xDP expansion card direct connect to my 2k AOC display (#2)
  • Cheap Lionwei USB-C hub. Ports connected are exclusively USB-A. Powering one Steelseries wireless direct headset dongle, G305 mouse, wired keyboard, Logitech BRIO Ultra webcam (1920x1080 @ 60FPS).
  • Bluetooth connection (using right now) JBL headphones, A2DP Sink, codec SBC-XQ.
  • Gnome is set to Performance mode, no TLP installed as I’m plugged into AC power. Flawless performance. Runs really well here.

If anything changes, I’ll updated.

i’m running cinnmon on fedora 37.

i had some issues with flickering after waking up displays, but nothing too bad - only a few seconds, and as soon as there was some redraw it stopped flickering.


this morning, i went from 6.1.9 to 6.1.11, and my display is no longer working - neither connected through thunderbolt → anker dock → hdmi nor through the hdmi dongle on the laptop itself.

dmesg says:

[   41.009244] ------------[ cut here ]------------
[   41.009245] i915 0000:00:02.0: AUX USBC2/DDI TC2/PHY TC2: not started (status 0xac2003ff)
[   41.009299] WARNING: CPU: 11 PID: 145 at drivers/gpu/drm/i915/display/intel_dp_aux.c:249 intel_dp_aux_xfer+0x6ec/0x780 [i915]
[   41.009384] Modules linked in: rfcomm snd_seq_dummy snd_hrtimer xt_conntrack xt_MASQUERADE nf_conntrack_netlink xt_addrtype nft_compat br_netfilter bridge rpcsec_gss_krb5 stp auth_rpcgss llc nfsv4 dns_resolver nfs lockd grace fscache netfs nft_fib_inet nft_fib_ipv4 nft_fib_ipv6 nft_fib nft_reject_inet nf_reject_ipv4 nf_reject_ipv6 nft_reject nft_ct nft_chain_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ip_set overlay nf_tables nfnetlink qrtr bnep sunrpc binfmt_misc vfat fat snd_sof_pci_intel_tgl snd_sof_intel_hda_common soundwire_intel soundwire_generic_allocation soundwire_cadence snd_sof_intel_hda snd_sof_pci snd_sof_xtensa_dsp snd_sof snd_hda_codec_hdmi snd_sof_utils iwlmvm snd_soc_hdac_hda snd_hda_ext_core snd_soc_acpi_intel_match snd_soc_acpi intel_tcc_cooling soundwire_bus snd_hda_codec_idt x86_pkg_temp_thermal intel_powerclamp mac80211 snd_hda_codec_generic snd_soc_core ledtrig_audio coretemp snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel snd_intel_dspcfg
[   41.009418]  kvm_intel snd_usb_audio snd_intel_sdw_acpi snd_hda_codec cros_usbpd_logger libarc4 kvm snd_usbmidi_lib snd_hda_core uvcvideo cros_usbpd_charger cros_ec_chardev cros_ec_sysfs btusb cros_usbpd_notify snd_hwdep snd_rawmidi irqbypass iTCO_wdt snd_seq videobuf2_vmalloc btrtl rapl videobuf2_memops iwlwifi mei_hdcp cros_ec_dev mei_wdt mei_pxp snd_seq_device intel_cstate btbcm intel_pmc_bxt ee1004 videobuf2_v4l2 hid_sensor_als iTCO_vendor_support snd_pcm processor_thermal_device_pci btintel intel_rapl_msr videobuf2_common hid_sensor_trigger processor_thermal_device pmt_telemetry cros_ec_lpcs hid_sensor_iio_common btmtk pmt_class processor_thermal_rfim industrialio_triggered_buffer cros_ec intel_uncore videodev wmi_bmof pcspkr snd_timer kfifo_buf processor_thermal_mbox bluetooth cfg80211 mc processor_thermal_rapl snd industrialio mei_me thunderbolt i2c_i801 intel_rapl_common joydev rfkill soundcore int3403_thermal mei i2c_smbus idma64 intel_vsec igen6_edac int3400_thermal
[   41.009452]  int340x_thermal_zone acpi_thermal_rel acpi_pad zram dm_crypt uas usb_storage hid_logitech_hidpp i915 r8152 mii drm_buddy nvme drm_display_helper nvme_core crct10dif_pclmul crc32_pclmul crc32c_intel cec polyval_clmulni ucsi_acpi polyval_generic hid_multitouch hid_sensor_hub ghash_clmulni_intel sha512_ssse3 typec_ucsi serio_raw ttm typec nvme_common i2c_hid_acpi video i2c_hid wmi pinctrl_tigerlake hid_logitech_dj fuse
[   41.009469] CPU: 11 PID: 145 Comm: kworker/11:1 Not tainted 6.1.9-200.fc37.x86_64 #1
[   41.009472] Hardware name: Framework Laptop (12th Gen Intel Core)/FRANMACP08, BIOS 03.05 08/23/2022
[   41.009474] Workqueue: events i915_hotplug_work_func [i915]
[   41.009539] RIP: 0010:intel_dp_aux_xfer+0x6ec/0x780 [i915]
[   41.009603] Code: 00 4c 8b 67 50 4d 85 e4 75 03 4c 8b 27 e8 6c 35 18 f4 41 89 d8 48 89 e9 4c 89 e2 48 89 c6 48 c7 c7 e0 08 85 c0 e8 8a a3 5c f4 <0f> 0b 48 8b 44 24 20 89 98 10 06 00 00 bb f0 ff ff ff e9 2b fe ff
[   41.009605] RSP: 0000:ffffb270806dfa78 EFLAGS: 00010282
[   41.009607] RAX: 000000000000004d RBX: 00000000ac2003ff RCX: 0000000000000000
[   41.009608] RDX: 0000000000000001 RSI: ffffffffb574c47b RDI: 00000000ffffffff
[   41.009609] RBP: ffff9d9090674860 R08: 0000000000000000 R09: ffffb270806df918
[   41.009609] R10: 0000000000000003 R11: ffffffffb61465a8 R12: ffff9d908322d6d0
[   41.009610] R13: 0000000000000004 R14: ffff9d908fac1c20 R15: ffff9d908fac0000
[   41.009611] FS:  0000000000000000(0000) GS:ffff9d9fef8c0000(0000) knlGS:0000000000000000
[   41.009612] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[   41.009613] CR2: 00007f229dbf01c0 CR3: 000000096f010005 CR4: 0000000000770ee0
[   41.009614] PKRU: 55555554
[   41.009615] Call Trace:
[   41.009617]  <TASK>
[   41.009619]  ? schedule_hrtimeout_range_clock+0xbd/0x100
[   41.009623]  intel_dp_aux_transfer+0x121/0x320 [i915]
[   41.009685]  drm_dp_dpcd_access+0x96/0x110 [drm_display_helper]
[   41.009696]  drm_dp_dpcd_read+0xb5/0x1d0 [drm_display_helper]
[   41.009704]  drm_dp_cec_unset_edid+0x8d/0xd0 [drm_display_helper]
[   41.009712]  intel_dp_detect+0x50a/0x6c0 [i915]
[   41.009774]  ? ww_mutex_lock+0x14/0x80
[   41.009779]  drm_helper_probe_detect_ctx+0x44/0xe0
[   41.009783]  intel_encoder_hotplug+0x43/0xf0 [i915]
[   41.009851]  intel_ddi_hotplug+0x83/0x420 [i915]
[   41.009910]  ? psi_group_change+0x15f/0x380
[   41.009913]  i915_hotplug_work_func+0x182/0x2f0 [i915]
[   41.009971]  process_one_work+0x1c4/0x380
[   41.009974]  worker_thread+0x4d/0x380
[   41.009975]  ? _raw_spin_lock_irqsave+0x23/0x50
[   41.009977]  ? rescuer_thread+0x380/0x380
[   41.009978]  kthread+0xe6/0x110
[   41.009980]  ? kthread_complete_and_exit+0x20/0x20
[   41.009982]  ret_from_fork+0x1f/0x30
[   41.009986]  </TASK>
[   41.009987] ---[ end trace 0000000000000000 ]---

I had similar issues until I updated to the 3.06 beta bios. If you choose to do so, read and follow the instructions precisely.

Also did you shutdown and perform a cold boot?

Since the log mentions kernel 6.1.9 I would assume that that is the kernel actually running.
I have no issues using 6.1.11 on Fedora 37 and BIOS 3.05 with a Microsoft surface USB C to HDMI dongle.

Something that may be helpful when docks are involved is trying this after determining the naming scheme of the display(s), trying the following:


In my case, I had a DP (#1) that wasn’t activating at boot at all. By adding the video=DP-1:1920x1080M@60 grub, I was able to force the display to wake up and perform the desired resolution and framerate. Use xrandr or similar to determine the display name and the desired resolution/framerate.

I also experience the GPU hangs and flickering display on Fedora 37. This happened a few times to me (not always, not every day):

  1. Connected to a Lenovo Dock (AC) while in a video conference (Zoom) (hard freeze of laptop)
  2. When waking from s2idle (top few display lines flicker, screen updates pause for a few seconds, hard freeze of laptop)

It also occurs when the HDMI expansion card isn’t connected - so it’s not related to it.

Journalctl shows (searching for “GPU HANG”):

Feb 20 15:16:19 framework kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:1:4c0452c8, in gnome-control-c [112845]
Feb 20 15:16:19 framework kernel: i915 0000:00:02.0: [drm] gnome-control-c[112845] context reset due to GPU hang
Feb 20 15:16:19 framework kernel: i915 0000:00:02.0: [drm] CanvasRenderer[14346] context reset due to GPU hang
Feb 21 20:20:51 framework kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:0:00000000
Feb 21 20:39:15 framework kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:0:00000000

It seems to happen much more often when on battery than when on AC, but not always. Will try i915.enable_psr=0 as a kernel arg with my next boot.

I’m happy to help, try things, write emails/chat, etc.

Fedora 36 or 37: 37, updating almost daily
12th gen or 11th gen: 12th gen
Kernel version: 6.1.11
Gnome version: 43.3 (at least for gnome-shell)
Using additional Kernel args: module_blacklist=hid_sensor_hub nvme.noacpi=1
Changes from default config: TLP, intel-media-driver
Bios: 3.05

Adding i915.psr_safest_params=1 (no psr=0 yet) to the kernel args (now on 6.1.12) got no effect. There are still some flickering top lines after wake from s2idle and rendering hickups.
What I observe in journalctl is:

Feb 23 07:52:13 framework systemd[2441]: Started dbus-:1.2-com.intel.dleyna\x2drenderer@18.service.
Feb 23 07:52:13 framework dleyna-renderer-service[27009]: dLeyna core version 0.6.0
Feb 23 07:52:13 framework dleyna-renderer-service[27009]: dleyna-renderer-service version 0.6.0
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Type[0] Level[0x13] Mask[0x4C] Flags[0x4F]
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Load file [/home/.../.config/dleyna-renderer-service.conf]
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: [General settings]
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Never Quit: F
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Connector Name: dbus
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Port: 0
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Push host port: 0
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: [Logging settings]
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Log Type : 0
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Log Level: 0x13
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: [Network filtering settings]
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Enabled : F
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Entries: (null)
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Calling GetRenderers method
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: Client :1.573 lost
Feb 23 07:52:14 framework dleyna-renderer-service[27009]: dLeyna: Exit

I’m not quite sure why dleyna might be related, but it was discontinued by Intel. The same few lines occur quite often in my logs and sometimes (not always) align with display issues from a timing perspective. As you can see in the logs, the Client is lost after some time. I’m not sure whether this is the expected behaviour.

Has been tested without the dock? I have been dock testing and they absolutely can in some cases do creative things in my own testing.