[TRACKING] Graphical corruption in Fedora 39 (AMD 3.03 BIOS)

I was going to open a new topic but this one seems closest to what I am seeing.

For me to reproduce, a resolution change has to occur (as per @F_Behrens). It most often reproduces when I wake the laptop from suspend as the lock screen is not using the same DM (I think?!) as the desktop session.

However this only seems to occur when I have an external monitor connected. So I am not sure whether that is a contributing factor.

I have two 1440p displays connected. One goes in via USB-C, the other monitor is connected to the first via daisy-chain.

1 Like

I see exactly the same on my external monitor (internal monitor sadly does not work). Fully updated Fedora 39 Beta. So far it only happened when starting games through Steam but otherwise I did not do a lot yet on that machine.

I think the problem will go away after moving to Fedora 39 stable. Think we can rely on that :slight_smile: However, the error also occurs without an external monitor.

Something similar is happening to my Ryzen Framework on Fedora 39 Silverblue.

What’s odd is that it doesn’t happen in xOrg, Wayland only.

While on Wayland, it only happens if I run my internal display at the native resolution. If I lower the resolution of the display, there are no graphical glitches.

This happens even after I added the kernel parameters mentioned by @F_Behrens

1 Like

I was experiencing this pretty consistently by launching a fullscreen 3d game from steam (elden ring, surprisingly runs quite well) at a lower resolution. Things seem to run fine, but after tabbing out, the white flickering appears. kernel log shows:

amdgpu 0000:c1:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0005 address=(inconsistent) flags=0x0000]

I am running on bios 3.03 (hoped this wold have been fixed, but nope) and using Manjaro KDE, kernel 6.5.5-1 when this happens.

The good news is that using the LTS kernel (6.1.55-1) seems to fix it. I hope this helps somebody :slight_smile:

All, new BIOS update beta today - please update: AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Beta

Just updated to bios 3.03. I’m seeing a different but still flickering effect on full screen games. I’m on kernel ver 6.5.6.

I do notice that this doesn’t happen on an external display though.

I am on F39 with 6.5.8-300 kernel and I go the white blocking artifacts once so far today. I ran sudo grubby --args="amdgpu.sg_display=0" --update-kernel=ALL and rebooted. I’ll see how it behaves.

2 Likes

Pure anecdata, but this seems to have improved the situation on my system. Bios 3.03, Kernal 6.5.7. I’m running an external 4k display through a thunderbolt 3 dock.

The BIOS update 3.03 solved the problem for me. There are no more graphical artifacts. Chrome does not crash anymore either. However, it still happens that all programs are terminated and the system logs me out during higher loads, e.g. games. I can imagine that this will be solved over time by an update of the operating system.

2 Likes

Would need a bit more information; distro, etc. Looks like something went sideways on the OS side of things.

  • Check the cable (even if untouched).
  • Test a live ISO of an tested distro (Ubuntu 22.04 or Fedora 39)

Interesting, I have not run into this.

  • Have you filed a bug with Fedora as I have not experienced this here?
  • Internal displays only or external displays?

Yeah, we’ve heard from folks across distros and even Windows about improvements.

  • I have not. I think that’s probably going to be an upstream amdgpu bug.
  • I’ve seen it only when using mulitple monitors, it affects multiple monitors. It MAY be with one using fractional scaling…I don’t remember the circumstances. It’s also harder to replicate with 3.03 seeming to have drastically reduced the occurences for me (only once since I updated).

Gotcha, this may indeed be an issue with multiple displays and perhaps even with how the displays are connected. If it reoccurs, worth a bug report as I have not experienced it.

@Matt_Hartley hate to be the bearer of bad news but after upgrading to the 3.03 BIOS, the problem is worse and now happens on the regular monitor with no external monitors connected at all.

2 Likes

This sounds like a hardware issue as I am not seeing this here on two separate units. What is your update status (last time updated) and which kernel is in use again?

Edit: I’m doing a clean install now and retesting to see if a bug cropped up.

This AM opened lid and was unable to wake. Rebooted and updated (dnf update), later laptop suspended after inactivity, and when woken, display was flickering.

Linux devnull 6.5.7-300.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Wed Oct 11 04:19:02 UTC 2023 x86_64 GNU/Linux

Just did a clean install, running current kernel 6.5.9-300.fc39.x86_64 - suspended and resumed multiple times without issue. Logs reflect successful resuming as well.

Are you like Tim, attached to external displays as well? If so, how are the displays connected (expansion cards, HDMI or DP)?

It used to only happen when external displays were connected. Now it occurs even without them.

But when I had them connected, it was via USB-C expansion card for one monitor, with the other monitor daisy chained via DP.

Do you know what log files I should look at shouldwhen this happens again?