[TRACKING] Graphical corruption in Fedora 39 (AMD 3.03 BIOS)

Sometimes when resuming from sleep, or when playing a fullscreen video, my screen will fill with white video blocks. If I switch to a virtual terminal and back to my GNOME session, the corruption goes away. Similarly, rebooting will fix the problem (until it appears again).

I passed a memtest86+ last night after thinking this might be caused by memory problems.

In my kernel ring buffer:

[45698.229842] amd_iommu_report_page_fault: 40953 callbacks suppressed
[45698.229938] amdgpu 0000:c1:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0005 address=0xffffe914000 flags=0x0000]

A few technical details:

$ sudo dmidecode -s bios-version
$ uname -r

Interesting, has this been occurring since day of the installation or after a recent update? Also is this occurring with external displays attached to a dock (or expansion cards as this would be ideal) or just with the internal display? Looking to try and duplicate.

What size memory do you have?

Also, does the corruption look similar to the following post?

1 Like

It’s been occuring since I received the board (running 3.02) as well. I thought this would be fixed in the 3.03 BIOS update, but no such luck.

This is occurring with no other displays attached. Two USB-As and two USB-Cs in the slots.

My memory is 32GB of Framework-supplied DDR5 5600. Part number AD5S560016G-B.

I can’t attach a video, but I can host it elsewhere and link it here! Here is an example of the corruption.

After looking at the other thread, this does look like similar corruption (although no translucent blocks like in the first image). Interestingly this isn’t happening with >= 64GB RAM or with external monitors attached. I can try the sg_display=0 kernel cmdline option to see if it helps.

I get the same white video blocks on BIOS versions 3.02 and 3.03. (My machine has 16GB RAM.)

For both versions, adding theamdgpu.sg_display=0 kernel param fixed it for me.

I enabled fedora-updates-testing with includepkgs=kernel* kernel-modules* linux-firmware* *-firmware to test 6.5.9. So far I haven’t gotten the artifacts to reproduce yet, although sometimes it takes a while. If it does I’ll try the sg_display=0 option.

For the sake of keeping these together, moving a couple of related posts here.

1 Like

Great question.

Been trying to replicate this myself to see if we need to file a bug. This is Fedora with external displays, correct? I have not had any issues (single display, internal) with distortion on resume. If this is in another thread (and I remember seeing this today), I can answer it there as well once I get the requested details.

This is Fedora 39 (Beta), no external display.
Default bios and OS configuration of Gnome (wayland) with no out of repo packages and a couple flatpaks installed.

To summarize, a series of i2c errors are reported, as well as a page fault in amdgpu.
It appears to happen on resume and not suspend.

I can put the log in chat, or email it to support depending on the preference.

Hi there!

I have graphical artifacts on my display from time to time. These occur when I open videos, start a game via Steam or sporadically from time to time. Has anyone else experienced anything like this? Other than that, the system is stable.

I suppose it could be either the beta version of Fedora or the still very new drivers. At this point, I hope it can’t be a hardware defect.

Attached some pics from my issue.


1 Like

If you have a lot of ram (64GB+), could it possibly be related to this issue?

Linux support for 64GB (Inclusive) and higher RAM capacities may cause white/blank screen issues with displays on some distributions with kernels below 6.5. Ubuntu OEM kernel oem-6.1-1021 and later has a backported workaround. For other distributions, please verify you are using 6.5 or utilize the following patch if you experience this issue:


I just have 32GB of RAM installed, but thanks for the hint!

Same artifacts here. It seems almost whenever display space changes (resolution change or display added/removed) they appear. Good thing KDE has such a robust session management, I have restarted it more in one day than in weeks before.

I also have 32Gigs of RAM, btw.

Using dmesg, I am seeing a lot of these messages:

amd_iommu_report_page_fault: 15159 callbacks suppressed


amdgpu 0000:c1:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0005 address=0xfffc32f0000 flags=0x0000]

with changing addresses.

Quickfix: add “amdgpu.sg_display=0” to your kernel command line (Source)

That introduces some other oddities but resolves this one (for me) :slight_smile:

Hi @F_Behrens thanks for the tip! It works for me as well :slight_smile: What oddities do you mean?

If you can capture logs I would recommend reporting this as an official bug / compatibility issue. No reason for a workaround when things should “just work” on a supported distro. It could signal a broader issue that may need to be fixed.

I had a similar issue but have not been able to reproduce. Happened to me waking from sleep.

Sitting here on mine, same BIOS, same release (Fedora 39 Workstation GNOME, fully updated today). Even on a fresh install I have not seen this. Feels like a hardware/connection issue.

Start with the following:

  • Open up your laptop and try re-seating your display cable. Inspect it for damage as well.
  • If this does not help. Grab a new copy of Fedora 39 and boot from the Live USB, is it happening there?