[TRACKING] Hard freezing on Fedora 36 with the new 12th gen system

“options i915 enable_psr=0” is still looking good here. I just got done cranking away on a game with no issues. Not even a burp. My lap is super sweaty because the laptop is cooking! LOL!

I went back through journalctl to see if I could find any oddball graphics messages, but I haven’t seen any since changing this option.

1 Like

@James_Adams Pretty sure the DisplayPort adapter is the culprit. Removing it from my wife’s computer and putting one in mine switched around who’s computer was freezing. Then adding it back to her computer caused hers to also freeze again. I just took them out of both and we’ll see what happens.

@Paul_Sorensen – I tested that. It happens with DisplayPort, HDMI, or USB-C with dock

Still no more crashes. F36, KDE Plasma, Wayland.

1 Like

@Aggraxis could you explain how and where exactly you need to put that kernel command or addition? I have a i5 12th gen and I didn’t have that file in /etc/ that others have referenced and I’m not sure how to make that change to the kernel parameters.

I’m having hard freezing, screen stuttering, and mouse movements stuttering too.

1 Like

@Brendan Sure!
Type the following command in a terminal window:

sudo nano /etc/modprobe.d/i915.conf

The file may not exist, and so nano might be presenting you with a blank file. This is ok. Put in the following line:

options i915 enable_psr=0

I also have two other lines in mine because I was following several different guides. It is my understanding that these two values are already at their defaults for 12th gen based on the Arch wiki and other random Google results:

options i915 enable_guc=3
options i915 enable_fbc=1

Save the file (ctrl+x, follow the prompts).
Now that you’re back to the shell prompt we need to call dracut to incorporate your changes:

sudo dracut --force

It may take a few seconds. When it finishes (usually without output), reboot your system. At that point the changes should have taken effect. You can check for any i915-related messages since the current boot with journalctl:

sudo journalctl -b | grep i915

I hope that helps. Good luck!

–Edit: added sudo to dracut line.


Got more freez (mister). It happen to me very rarely mostely when I am on google meet video call, pushing the machine a little with many heavy apps and sharing windows.
I had it with Ubuntu mate 22.04 LTS kernel 5.18.x yesterday and this time it freezed two times, the mouse moves but the window manager is unresponsive. The video conferencing was somhow still there, at least the sound, the mouse was moving… It came back once…and then I had to hold the power button down to reboot and come back in the conference (I was organising!).
Other than video call;
I had another freeze just before opening a simple PDF wih no video call (but I was on the phone, it s asif it detect I really need it to not freeze !). I mention it because with my thinkpad E590 I never had such blocking of the wall desktop.

@Aggraxis Thank you! Awesome. I got it working quickly. I also have an open ticket with Framework Support. Hopefully, this helps.

1 Like

This seems to be a good workaround on NixOS for me.

I’ve followed the steps described by @Aggraxis - hopefully this’ll resolve the freezing issues. After setting the option, and then afterwards reading what it does (lol), I understand that it’s a power saving feature. Additional context from my situation is that I’ve followed the linux power-saving guide stickied somewhere else here… could this be the culprit?

1 Like

Hello @Aggraxis. As I am experiencing this hard freezing issue I followed the process you described here and all seemed to be going fine until I called dracut. This is what I see at that stage.

Perhaps I did something wrong?

Edit: I added sudo to the dracut command but the issue with ‘"options’ remains and it definitely hasn’t worked.

1 Like

@ggg I didn’t follow the power saving guide. It seems to do this 'out of the box '.

@Greg_Stedman you seem to have a stray quotation character in your i915.conf at the beginning of the line. That’s what the error is telling you.


Thanks @Aggraxis. I have no idea where that stray quotation character is coming from. I can’t see it in Terminal and when I look at the i915.conf file itself in /etc/modprobe.d/ there is no visible quotation character either. Weird. I’ll keep trying but I’m a bit stumped.

1 Like

@Greg_Stedman It appears the syntax error is in /etc/modprobe.d/blacklistUAS.conf file, not /etc/modprobe.d/i915.conf.


@Jason_H_Young thanks for catching that! I was still waking up when I saw the message the first time this morning. LOL!

1 Like

@Aggraxis Anytime! If I had a nickel for every time things like that have caused me wasted hours at home & work, I would’ve been able to retire 10 years ago.


Ugh. Thanks @Jason_H_Young and @Aggraxis. I was fully awake and didn’t notice, so I have only myself to blame.


@Greg_Stedman no worries, friend! Let us know how things go!

1 Like

Yup, I think it works. I’ve tried the things that tended to cause hard freezes, and since doing the enable_psr=0 thing it has been rock solid reliable. Very nice.


I got today multiple hard freezes. I found out that by pressing alt+ctrl+f6 and the alt+ctrl+f2 solved it