[TRACKING] Hard freezing on Fedora 36 with the new 12th gen system

Got the DIY edition with everything except the SSD (WD SN850 bought separately) and am running into hard freezes even after doing a clean reinstall of Fedora 36. Seems to happen when I am on the settings page, and the only thing I’ve done in this latest install is update my packages. I was enabling tap to click and some basic power settings when it suddenly froze. No mouse/keyboard input works, no ctrl+alt+f2, etc. Fans also get really loud and stay this way until I power it off.

The laptop just came out, but just wondering if anyone out there has been able to successfully run their system for more than a couple of hours on Fedora with 12th gen.


Have you updated the firmware of the SN850 as the firmware on most of them have issues with framework.


Haven’t updated the firmware but I’m on 614900WD.

Either way for reference I think I fixed it for now by disabling “automatic screen brightness” in the power settings. I guess it might be because I’ve had my camera switched off as far as I can remember and this setting might rely on it? idk

I would still recommend updating the firmware, also add solved to the title for reference.

1 Like

On a thinkpad e590 Inhad hard freez after update to ubuntu 22. Never had this before with linux.
Updated the bios and it seemed to stop freezing. Then updated the samsung 980 ssd.
Have no freez dor 48h woth heavy vidéoconférencing
Update: no freeze for 20 days on e590.
Updated kernel 5.15 to 5.18 works great too

Still getting hard freezes after my last post, but the issue now seems to be with Wayland. Using xorg has not given me any crashes, but it’s not ideal (no touchpad gestures). Hopefully there’s an update down the line that fixes the issue.

Freezing still only happens in the settings application so currently I just switch to xorg if I ever need to change anything.

1 Like

I’m having the same issue - fresh 12th gen system with basically completely vanilla Fedora installation randomly freezes after a few hours of use. No further indication that anything’s wrong, it just suddenly locks up and ramps the fans to max speed. Only holding the power button does anything at that point.
I’m using a Samsung 980 for my SSD so it probably isn’t the SN850’s firmware.

Exact same issue for me. 12th gen system, Fedora 36, except a SK Hynix P41 Platinum SSD.

1 Like

Did you hold it down for 12 seconds or more?

I had 3 crashes with my new 12th Gen today as well. Each time I was in gnome settings, and I was in a Wayland session. Trying xorg for a while to see if it’s any better.


Regarding the thread’s [SOLVED] status…is it really solved, or using xorg as a workaround?


Maybe there are some incompatibilities with your kernel or other libraries? What versions are you guys using?

I’m on Arch, running Linux 5.18.16 w/ Wayland 1.21.0 (and sway as my wm) for the past couple days and haven’t run into anything weird so far.

1 Like

(sorry for the late responses)

I held it down until the screen went black after which the power light turned off, I don’t remember how long it was exactly.

I do seem to remember that both of my freezes happened while I was in Fedora settings, and arredoluis also reports the same thing. It seems like that’s causing the issue.

The second option. @arredoluis, could you remove the [SOLVED] from the title? This way it might get more attention to be solved for Wayland.

Fedora 36, about as stock as it comes. I’m not knowledged enough with Linux to make any major modifications.
Versions: Linux 5.18.15, GNOME 42.3, Wayland ??? (how do I find this version)

The crash hasn’t happened to me since my initial reply, I do remember turning automatic brightness off around that time. I’ll keep experimenting a bit.


Got my 12th gen just today and installed Fedora 36 with all upgrades and some additional packages. No issues in the beginning. But now Gnome Settings app freezes the system on a regular basis. First I thought it was bluetooth, but no change after deactivation.

The machine seems to be not absolutely dead. With some key combinations I was able to get some sound output, like it is not allowed to that. But only once. Then only holding the power button helped.

After couple of seconds of freeze the fan starts running and gets soon to the max. I believe there is something completely overloading the CPUs.

I have uninstalled some of the additional packages I suspected, like firmware-upgrade tool or Gnome extensions. Then I didn’t see the issue anymore. Then I installed one after the other again to find out the bad guy. But now I believe I got them all back, and still no issue. No clue!
Forget this last thing. System froze again when I tried to change some sound settings. :exploding_head:

I think this is related, I’ve been trying fedora in virtualbox, and going to settings and opening up any menu or change any display settings cause the screen to freeze, flicker and then the whole thing crashes.

Note: I’m on 11th gen

1 Like

As far as I remember it happened only when I was using the settings app, but not only in connection with the display. Yesterday, I was in the sound settings and the freeze occurred exactly when I pushed one of the buttons to test the sound output. But it was not reproducible.

1 Like

I’m on a Gentoo linux system, kernel 5.18.18, and I have seen this issue. I got some logs from when it occurred: gist:a4bd52e2e065367b411d2da23feed376 · GitHub

Interestingly, the entire system didn’t crash – just video. I was in a video conference at the time and sound and outgoing video was working even though my GPU driver (and wayland session) were out to lunch. I did have to hard reset the laptop to recover the situation.

1 Like

Same on my 12th gen, using the SK Hynix P31 as my storage. I’ve had freezes in both the settings program as well as the software center.

1 Like

@arredoluis The issues with Automatic Brightness are going to be there for a few more months. I suggest looking at the fedora install guide. This might be part of thee reason it freezes.

Has anyone with the issue tried out Fedora 37 to see if it helps? 37 is still a month away from official beta (schedule) but might be stable enough to try. Should come with 5.19 kernel which might help. :man_shrugging:

(obligatory disclaimer, I don’t recommend running a pre-beta OS on your primary machine)