[TRACKING] Hard freezing on Fedora 36 with the new 12th gen system

  • With absolutely nothing attached to create a vanilla environment (no sense in adding complexity for testing), try the suggestion found here.

  • Make sure you’re fully up to date on Fedora 37.

  • Test the workflow in Chrome or Brave. If it’s like the rest of these, this is related to Firefox.

Summary: Make sure all your packages are up to date - if you did it yesterday, do it again please. I’d rather be triple sure on that.

Reboot after packages are update. Still happening, test the workflow with Discord, etc, using another browser (Brave, Chrome, etc). If the issue isn’t happening there, this is related to the Firefox telemetry issue.

Fedora 36 or 37: 37. Has been happening since 36

12th gen or 11th gen: 12th gen

Kernel version: 6.1.8-200.fc37.x86_64 and previous

Gnome version: N/A. Using latest KDE Spin.

Using i915 fixes, if so, which ones:

Has this been tried yet and if so, any difference: Yes. No difference.

Applications running in foreground or background when freeze occurs: Various, happens more often with GPU-accelerated applications such as Discord, Firefox, wezterm

What if anything is attached to your Framework; docks, (BT, IR, wired) mouse, keyboard: Replicatable with all module slots empty and hardware webcam/microphone switches off.

I’ve tried to keep this fairly similar in terms of test config.

I’ve had hard freezes when running on battery & no peripherals too. 6.1.7 kernel has shown freezing with ecode errors.

Here’s a second report from me, differences are bolded. Most obvious change is PSR=0:

Fedora 37 KDE spin

12th gen or 11th gen: i5-1240p, 2x 16gb ram

Kernel version: 6.1.7-200.fc37.x86_64

Gnome version: NA. KDE 5.26.5 Plasma / 5.102.0 framework

Using i915 fixes, if so, which ones: psr=0 only.

Has this been tried yet and if so, any difference: yes. appears to be stable.

What if anything is attached to your Framework: running on battery, only Bluetooth mouse.

additional notes: from past freezing issues, i’ve no issues with firefox, youtube, freecad or vscode.

Good to hear that’s still working. I mean there is definitely a driver issue there, but at least the module option seems to keep most folks going.

yeah, it’s weird. been fine for weeks with psr (default/1). Things seems stable and i figured it was fixed with the various kernel updates. Then it started misbehaving where i need to re-apply psr=0 to get things stable.
i havent trawled the kernel changelogs to see if theres a regression possibility, but there is a possibility there.

plus side, TLP is enabled again and i seem to have gained noticable battery life with it, so if psr=0 remains as a longer term fix then i’m happy to live with it. While i’m sure PSR has benefits, it doesnt appear to have result in a substantial must-have power reduction.

Because this is a mega thread, what are we looking to fix with psr=0? It’s known to affect stability. So what happens as it stands now if you leave this off? :slight_smile:

I’m still on Fedora 37, still no grub parameters expect for the brightness fix.

Also spoke to my Fedora contact, they echo my experiences exactly. Currently sitting on kernel 6.1.8-200

1 Like

I am very interested in zeroing in on what the cause is. I have no mitigations in place, use many of the apps that might contribute to issues and yet I have problems only once every three + weeks or so.

The fact that it affects some users and not others indicates something is “different” somewhere along the line for sure.

1 Like

Absolutely. Definitely think some of it is a Xorg vs Wayland thing.

1 Like

default (psr=1): has been freezing recently. Both soft and hard freezes with ecode 12:0:00000000 across different apps (actively using freecad & vscode, but messages around dmesg ecode sugested ‘kwin_wayland’ iirc).

psr=0: so far rock solid reliability. no issues anywhere. This is my current setting, as of right now.

Thing is, my experiences are similar to @nadb - can be fine for weeks then I’ll start seeing issues. I’ve been running default/psr=1 without issue since F37 kernel 6.1.2.
6.1.7 seems to have required psr=0 being set again, but that could just be coincidence.
Maybe it is a kernel/mesa regression, maybe something else. But that was the most obvious change at the time.

I’m experiencing these issues as well on a fedora 37 12th gen cpu running Gnome (Wayland).
I’ve applied the fixes and I’m still experiencing the crashes. Log reports are identical to what has been submitted earlier. (igpu hanging)

Seriously wondering if this is a Wayland issue atm. A friend of mine using a 12th gen cpu on Fedora (xorg) has not experienced crashing. So I will for the next few days try xorg and report back with my results.

ALSO PLEASE NOTE. My crashing hasn’t been limited to screen freezes although those happen as well. I’ve also experienced issues where my screen will freeze and then ALL applications will shut down all at once as if someone just pressed alt f4 on my whole system. The last time this happened, I noticed there was one app still open even though all other apps were shut down.

That one app was the gnome software store. In addition, like many others here, I’m also experiencing screen freezing when I go into my settings app. I believe that the gnome software store and gnome settings app all have something to do with this and they are the only pattern that I see whenever I face screen freezing or screen crashing.

To conclude, I will let you guys know my results after I switch to xorg. I suspect that I will still experience these issues but who knows. Anybody else who still lurks this forum, if you’ve experienced better results with x11/xorg or better results with a non gnome fedora spin or distro, let me know as well.

From my undestanding everyone has issues on wayland, right?

I have issues on xorg, but I run a more complex system: Qubes OS(fedora 32 in dom0 which has GPU) + kernel 6.1.7-1 + custom xorg config for removing tear issues with it(can be found on the Qubes wiki).

It happens once everyday and basically the screen hangs and then resiezes and it won’t stop until I do a reboot.

I have one of the 12th gen Intel Frameworks running Fedora 37 currently, and the last month or so I’ve been running into various issues around lockups and most recently graphical glitches.

Initially I was running into hard lockups that required me to hold the power button down to restart. That didn’t seem to really be correlated to high CPU usage either. It comes in waves sometimes where it’ll just randomly lock up a ton for a day and then be fine for a few days after. That seems to have stopped for the past week, and now this weekend I’ve noticed graphical glitches (using internal display) and smaller lockups of a second or so.

Anyone else running into similar issues? This has been super frustrating, and for now I’ve switched back to an older laptop that’s been more reliable until I can figure this out.

Yes, a lot of people have similar issues.

1 Like

I experience this with both Wayland and Xorg and setting psr=0 has fixed my issue

1 Like

The easiest, most foolproof way would be to swap in another drive (maybe something cheap or secondhand, just to test).

You can install a utility like this:https://linuxconfig.org/obtain-hard-drive-firmware-information-using-linux-and-smartctl

Compare the results you get with whatever the manufacturer says is the latest firmware for that hard drive model to see if you are missing an update.

Hi @BluishHumility

Great news! It is a hard drive issue. Specifically, my hard drive was bent/bowed out towards the keyboard!

All of the symptoms were as others on here had described. Notably, freezes occurred when

  1. I used the laptop off the desk
  2. Alternatively, when I typed hard, especially around the v/c/d/f/x keys (directly over the hard drive).

I purchased a replacement based on the description of others, and was really surprised to see the bowing of the hard drive.

I don’t think it was anything in the Frame.Work design that could have prevented this. I wonder now how many of the other threads where people talk about freezing WD SN850s are related to bowed SSDs.

In case there is a batch issue with WD, this is the relevant information:

  • Model: WDS200T1XOE-OOAFYO
  • Date of Manufacture: January 7, 2022
  • Purchased through: NewEgg

Unfortunately the new hard drive did not stop the freezing issue.

I have tested with all new ram, so at this point am not sure what the issue is. Symptoms suggest a GPU issue (freezes w/ blinking squares, will provide a picture the next time it happens).

Data point: MS Teams in Chrome browser is almost certain to cause a freeze.

Thinking out loud, the issue that was causing the freeze with the mispositioned/bent SSD might have been a short. Repeated shorts may have caused damage to the mainboard.