[TRACKING] High temperatures and no fan response despite default fan curve

I’m running Manjaro KDE, the same install that I’ve been using for years.

I’ve been struggling with temperatures on my laptop for quite awhile now whenever I do something remotely intensive, especially anything 3D. It’s been getting to the point of thermal throttling and just freezing up whenever I’m under a reasonably high load. Most recently I had trouble driving a single 4k display at 30fps, with the lid closed.

It took until yesterday for me to notice that there’s no noticeable fan activity. I installed fw-ectool-git from the repos and ran ectool --interface=lpc fanduty 100, which kicked on the fans at full blast and very quickly cooled the device down to 40-50C.

However, when restarting, the fan never comes back on again, even at 100C.

I checked the fan curve and it appears to be set reasonably, but crossing those temperature thresholds has no effect. It appears that it’s set at the default value, according to this post

ectool thermalget                                                                                                                                                                                                                                 
sensor  warn  high  halt   fan_off fan_max   name
  0        0   361    371    313     335     F75303_Local
  1        0   361    371    313     342     F75303_CPU
  2        0   360    370    313     335     F75303_DDR
  3        0   323    333    313     323     Battery
  4      368   376    378    377     378     PECI
EC returned error result code 3
(all temps in degrees Kelvin)

I’m not really sure what’s going wrong here. This started because I’m looking to start using my laptop as my primary computer, so I’d like to figure out the root cause for this lack of fan response.

I’m pinging @DHowett as Framework has no official support for Manjaro KDE using ectool.

That said, if you are not able to resolve this with ectool, I’d first verify there isn’t a thermal issue. Boot to a live ISO of Fedora. Play some YouTube videos full screen, see if things go nuts or if it’s a local config issue.

I’m starting to wonder if this is some sort of weird edge case being hit in the EC firmware. I recently got my AMD mainboard and it’s suffering from a similar issue. Happens regardless of what OS is running. Pretty sure that ectool doesn’t support the AMD one yet, so I can’t test setting the fan speed manually. I do know that the fan works though, it seems to spin during POST. Already submitted a support ticket about it, we’ll see if anything comes of it.

1 Like

+1 I noticed this on my new ryzen board, also in manjaro kde. I tried the supported Fedora 39 beta live and noticed the exact same behavior: the fan dosen’t run until ~100c! Once that happens, it kicks in and takes everything back down. Web browsing and video playing only brings up the temps to 50c, but a stress test or 3d game will hit that ceiling quickly. I had just chalked it up to an aggressively silent fan curve; now I’m not so sure… Hoping bios 3.03 is better.
Also, I did repaste to see if it was just a bad factory job; even with ptm7950, the behavior is the same. At least with that TIM, it cools off much faster once the fan does start moving.


It’s certainly an odd fix, but what cleared it up for me was booting up the live environment of Ubuntu 22.04.

Now that everything works on my end, I think I can confirm that it’s just a really weird fan curve. It seems to prioritize noise over everything else, leaving load temps a little hotter than the 11th gen. Probably a direct response to the complaints about fan noise, but it may be a bit overboard. The fan does actually spin before you actually hear it. Try opening the laptop and observing the fan when temps are in the 70s and 80s.

1 Like

Actually, that’s where my concerns started; I noticed how hot the bottom was getting so I ran a few tests with the top off and noticed no movement from the fan under normal browser use, getting up to uncomfortable temps (~50). I guess I was just expecting it to behave like the 11th gen board. You’re right, though: if it gets toasty enough (~60 in my case) the fan will gently bring it back down to around 50 before cutting out again. I guess it really is just a silent curve.

I’m hitting this too. AMD 7640U, Arch Linux. Kernel 6.7.2.
My exact symptoms are:

  • Fan will not spin until prolonged extreme temperatures (30+ seconds at 100°C)
  • When the fan does finally spin, it barely spins at all, not enough to provide any meaningful amount of cooling

I tested and confirmed the same symptoms on a Fedora live boot.

I went through Framework support, and they sent me a thermal assembly, but that did not change anything. I’m kind of at a loss with what to do going forward. I wish Framework was able to provide some kind of built-in diagnostic test like some other companies do, because it would immediately be able to rule out if it’s an OS-level issue or some other hardware issue.
Specifically, I would really like to see commanded fan RPM vs actual fan RPM - though after replacing the assembly I guess I can be sure it’s not the fan.

ectool is not an option yet (not without a custom kernel, anyway) because the patches needed to make it work for 7040 series haven’t been mainlined.

I’m going to try booting Ubuntu 22 on a live drive, then failing that a custom kernel, and then failing that just giving up. I just wanted to document in case any other 7040 owners are having the same issue. Will report back with my findings.

I want to quickly add that this did NOT happen when my FW13 was new - it was working exactly as intended, and, if anything, ramping up the fan early (which I’m perfectly fine with.)

Something changed at some point in time that I can’t quite pin which causes the current behavior.

Ubuntu 22.04 live media results are inconclusive. Using stress -c 12, the CPU frequency locked to 544Mhz on all cores, even after manually setting the performance governor. I believe the 22.04 live installer is using the wrong pstate driver.

I double-checked on a freshly downloaded Fedora 39 Live and can still reproduce the same results I see under Arch.

Will move on with trying to compile a custom kernel including the patches needed to use ectool on 7040 series.

At this point I’m close to folding and trying Windows too, just for any extra data points.

Appreciate everyone’s feedback.

We want to make sure you are all on the current PPD version tested (PPA and COPR). This is from our Ubuntu and Fedora guides (Allow both CPU and platform drivers to be simultaneously active).

Additionally, please make sure to test against installed and fully updated (Fedora in this example). Set PPD in the power menu to performance, test the stress sequence again and report back.

I’ve got the same problem, the laptop will sit at more than 100C and only after 15 seconds the fan will gently kick in (I think the fan runs at a quarter of it’s capacity) and eventually it will start blasting air as it should.

Running ubuntu 22.04 LTS, I did follow the Framework’s instructions.

Had the same problem on Windows 11 before switching.

I’m not sure when this behavior started, I know that I had no problems before.

Would love to have a simple temp/fanspeed curve that I could enable the fan to follow and edit in it the bios, that would solve this problem and allow me to disable the economical use of the fan in general.