[TRACKING] Linux Fedora 39 Internal Microphone not found

Just installed fedora 39 and did upgrades and the internal microphone is not registered in KDE. Did all the troubleshooting steps in Fedora Audio Troubleshooting Guide.
Kernel 6.6.6-200.fc39.x86_64 x86_64

We’re seeing other issues with 6.6.6 as well, we’re curating a list. Adding this to it for debugging.

Can you test this against older kernels, make sure all is well there for comparison? You can do a button hold power off, then boot up, select an older kernel for testing.

Still having issues on 6.5.12-300.fc39.x86_64.
This is a fresh install of fedora 39. I can get it to work with pulseaudio sudo dnf swap --allowerasing pipewire-pulseaudio pulseaudio but not with pipewire

Disregard broke everything

Finally got it work
sudo cp -a /usr/share/wireplumber/main.lua.d/50-alsa-config.lua /etc/wireplumber/main.lua.d/50-alsa-config.lua
Copy the system config to /etc then edit that file and add

...
alsa_monitor.rules = {
    {
        ...
        apply_properties = {
            -- Use ALSA-Card-Profile devices. They use UCM or the profile
            -- configuration to configure the device and mixer settings.

            --- comment out below line
            -- ["api.alsa.use-acp"] = true,
 
            -- Use UCM instead of profile when available. Can be
            -- disabled to skip trying to use the UCM profile.

            -- un-comment
            ["api.alsa.use-ucm"] = true,
...

Then restart pipewire wireplumber

systemctl --user restart wireplumber pipewire pipewire-pulse

EDIT this breaks the 3.5mm jack

I wanted to jump on this to say I am experiencing the same thing. Mic isn’t registered in Fedora 39 KDE. Interestingly, if I rip out pipewire and install pulseaudio, the mic starts working (but I lose the ability to control volume through the OS and audio options are also removed. Volume control works via alsa mixer though.


You see there is a recording device section, but there’s no dropdown or mention as to what device it is.

I am currently on the following kernel:
Linux fedora 6.6.8-200.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Thu Dec 21 04:01:49 UTC 2023 x86_64 GNU/Linux

Update my issue turned out to be the Profile. Switched from Analog Stereo Output to Analog Stereo Duplex and the mic works now and also shows it’s own set of options.

2 Likes

Delighted to hear switching audio profiles solved this for you.

Others affected on Fedora:

  • Updates, please run and reboot.
  • Check your audio profile. Install and use PulseAudio Volume Control (pavucontrol).

Okay, this morning it has stopped working again today. I have double checked my sources. But now no sound is registered, but if I use software to listen to the input (EasyEffects) I just hear static and the occasional pop…

Edit: Internal Microphone in sound settings is showing as β€œInternal Microphone (unplugged)”.

Literally no physical changes to the laptop since my last update. I’ve had to salvage a broken headset with a mic to continue working at this point, by may end up switching back to Pop tonight because it’s more stable.

Appreciate the update. This may be worth getting into a ticket so we can look at the logs. If you decide to open a ticket, we will need to see logs from one of our tested/supported distros as Pop is not among them.

That said, if you are able to get success with Pop, feel free to update us here.

I have not reverted yet. And seems to be behaving again. Is it expected behaviour for the internal mic to be marked β€œunplugged” when connecting an external mic via the onboard dual-type 3.5mm input?

Previously, without it connected internal showed as unplugged again but hasn’t since unless headset/mic is plugged in.

I’m on Fedora 39 KDE Plasma Desktop Edition on Intel 12th gen and I’m also running into an issue with the mic. Ran through the Fedora Audio Troubleshooting Guide to no avail. No matter what I have tried, zero sound picked up by the webcam mics. I even swapped out the webcam module with a new unit, nada.
(above edited for clarity, spelling)

Is there more information that I can provide below for somebody to help me troubleshoot?

Linux framework 6.7.3-200.fc39.x86_64
arecord -iL
null
    Discard all samples (playback) or generate zero samples (capture)
pipewire
    PipeWire Sound Server
default
    Default ALSA Output (currently PipeWire Media Server)
sysdefault:CARD=PCH
    HDA Intel PCH, 92HD95 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, 92HD95 Analog
    Front output / input
systemctl status --user pipewire*
● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; preset: enabled)
     Active: active (running) since Thu 2024-02-08 17:22:25 PST; 11min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket

Feb 08 17:22:25 framework systemd[5126]: Listening on pipewire-pulse.socket - PipeWire PulseAudio.

● pipewire.socket - PipeWire Multimedia System Sockets
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; preset: enabled)
     Active: active (running) since Thu 2024-02-08 17:22:25 PST; 11min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
             /run/user/1000/pipewire-0-manager (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket

Feb 08 17:22:25 framework systemd[5126]: Listening on pipewire.socket - PipeWire Multimedia System Sockets.

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
             /usr/lib/systemd/user/service.d
             └─10-timeout-abort.conf
     Active: active (running) since Thu 2024-02-08 17:22:26 PST; 11min ago
TriggeredBy: ● pipewire.socket
   Main PID: 5416 (pipewire)
      Tasks: 3 (limit: 76750)
     Memory: 8.8M
        CPU: 1.573s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─5416 /usr/bin/pipewire

Feb 08 17:22:26 framework systemd[5126]: Started pipewire.service - PipeWire Multimedia Service.
Feb 08 17:32:34 framework pipewire[5416]: mod.client-node: 0x5577efa0d9b0: unknown peer 0x5577efdd72e0 fd:56
Feb 08 17:32:34 framework pipewire[5416]: mod.client-node: 0x5577efd7a5a0: unknown peer 0x5577efa7bac0 fd:112

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/service.d
             └─10-timeout-abort.conf
     Active: active (running) since Thu 2024-02-08 17:22:29 PST; 11min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 6069 (pipewire-pulse)
      Tasks: 3 (limit: 76750)
     Memory: 13.3M
        CPU: 998ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─6069 /usr/bin/pipewire-pulse

Feb 08 17:22:29 framework systemd[5126]: Started pipewire-pulse.service - PipeWire PulseAudio.

wpctl status
PipeWire 'pipewire-0' [1.0.3, niro@framework, cookie:914470579]
 └─ Clients:
        31. uresourced                          [1.0.3, niro@framework, pid:5404]
        32. WirePlumber                         [1.0.3, niro@framework, pid:5419]
        33. WirePlumber [export]                [1.0.3, niro@framework, pid:5419]
        53. xdg-desktop-portal                  [1.0.3, niro@framework, pid:5434]
        54. pipewire                            [1.0.3, niro@framework, pid:6069]
        55. Plasma PA                           [1.0.3, niro@framework, pid:5568]
        56. Brave input                         [1.0.3, niro@framework, pid:6857]
        61. wpctl                               [1.0.3, niro@framework, pid:7937]
        70. libcanberra                         [1.0.3, niro@framework, pid:5568]

Audio
 β”œβ”€ Devices:
 β”‚      42. Built-in Audio                      [alsa]
 β”‚  
 β”œβ”€ Sinks:
 β”‚  *   45. Built-in Audio Analog Stereo        [vol: 1.00]
 β”‚  
 β”œβ”€ Sink endpoints:
 β”‚  
 β”œβ”€ Sources:
 β”‚  *   46. Built-in Audio Analog Stereo        [vol: 1.00]
 β”‚  
 β”œβ”€ Source endpoints:
 β”‚  
 └─ Streams:

Video
 β”œβ”€ Devices:
 β”‚      40. Laptop Camera                       [v4l2]
 β”‚      41. Laptop Camera                       [v4l2]
 β”‚  
 β”œβ”€ Sinks:
 β”‚  
 β”œβ”€ Sink endpoints:
 β”‚  
 β”œβ”€ Sources:
 β”‚  *   43. Laptop Camera (V4L2)               
 β”‚  
 β”œβ”€ Source endpoints:
 β”‚  
 └─ Streams:

Settings
 └─ Default Configured Node Names:
         0. Audio/Sink    alsa_output.usb-Schiit_Audio_Schiit_Hel_2e-00.pro-output-0
         1. Audio/Source  alsa_input.pci-0000_00_1f.3.analog-stereo.2
wpctl inspect 42
id 42, type PipeWire:Interface:Device
    alsa.card = "0"
    alsa.card_name = "HDA Intel PCH"
    alsa.driver_name = "snd_hda_intel"
    alsa.long_card_name = "HDA Intel PCH at 0x605d1b8000 irq 187"
    api.acp.auto-port = "false"
    api.acp.auto-profile = "false"
    api.alsa.card = "0"
    api.alsa.card.longname = "HDA Intel PCH at 0x605d1b8000 irq 187"
    api.alsa.card.name = "HDA Intel PCH"
    api.alsa.path = "hw:0"
    api.alsa.use-acp = "true"
    api.dbus.ReserveDevice1 = "Audio0"
  * client.id = "33"
  * device.api = "alsa"
    device.bus = "pci"
    device.bus-path = "pci-0000:00:1f.3"
  * device.description = "Built-in Audio"
    device.enum.api = "udev"
    device.form-factor = "internal"
    device.icon-name = "audio-card-analog-pci"
  * device.name = "alsa_card.pci-0000_00_1f.3"
  * device.nick = "HDA Intel PCH"
    device.plugged.usec = "28917245"
    device.product.id = "0x51c8"
    device.product.name = "Alder Lake PCH-P High Definition Audio Controller"
    device.string = "0"
    device.subsystem = "sound"
    device.sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
    device.vendor.id = "0x8086"
    device.vendor.name = "Intel Corporation"
  * factory.id = "14"
  * media.class = "Audio/Device"
    object.path = "alsa:pcm:0"
  * object.serial = "42"
cat /etc/default/grub 
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-9a6bf74e-50b0-45cc-b31e-6cd7c825b3c5 rhgb quiet hid_sensor_hub.blacklist=1 rd.driver.blacklist=hid_sensor_hub"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true


This helpful. Was this happening with previous kernels?

Easy way to tell in Fedora is to force power off long press power button, power on again, select previous kernel.