[TRACKING] Lots of stuttering and lagging on AMD + Ubuntu 22.04

BIOS 3.03
Kernel 6.1.0-1024-oem

3.02 is not something we’re going to be supporting after we’ve taken 3.03 out of beta, so no. If something goes wrong and we need to revert you back for a second attempt with 3.03, that would be a support ticket.

Sounds like other oddness is afoot with your setup. At the airport, been using suspend all day on 22.04.3 without issue. This may become a ticket at this point as I have not been able to replicate any of it.

Try Wayland as is default with Ubuntu 22.04.3 for best results. That is what we’re testing against. We can take a look at X11 suspending when I return home, should still suspend unless something attached is preventing sleep.

@FlowWork seems to also be having similar issues.

My years of experience working on consumer devices has taught me that “it’s not happening to me” doesn’t mean there isn’t an issue. The latest firmware messed with power settings, so it stands to reason that some power-related stuff may also have been inadvertently broken. Have you had a chance to use your laptop in a quiet setting?

Changing the iGPU Configuration UMA mode setting to UMA_GAME_OPTIMIZED in BIOS under Advanced settings seems to have fixed the problem for me.

I had the same issue using Ubuntu 22.04 on a 7840 AMD setup.

I’ve done this now under two full clean installs of 22.04 (the fingerprint reader fwupd doesn’t work at all if you install with Secure Boot enabled, so I had to start fresh with it disabled.) and it had the same effect/improvement both times. Also noted the same problem and solution when running the Unity desktop and with or without the OEM kernel version. I’m thinking there’s some driver issue/conflict with whatever that UMA setting is switching when it’s in AUTO mode.

If we cannot replicate it, we can file a ticket for triage. If we cannot replicate it on our own machines, there is clearly a difference somewhere and we’d need to take a deeper look at what that difference is.

Both of my laptops are set to UMA_AUTO. Odd.

I agree there must be conflict somewhere beyond what we would find on a vanilla installation with the OEM C kernel (6.1.x).

There is either a difficult to replicate issue (which we have seen in the past and make it very difficult to catch) or there is a difference in config somewhere.

Another data point, FWIW: I was using the 3.02 BIOS that came with my batch 2 machine when I did the testing that I mentioned and saw the lag linked to UMA_AUTO. I have since updated to the 3.03 BIOS.

Out of curiosity, I just flipped back to UMA_AUTO and with 3.03 I’m no longer seeing the stutters, screen blanking, and lag that I saw before.

I’ve been testing it for about 20 minutes. Some things like Google Maps seem to be a little more clunky than I’d expect on a machine with a mature graphics driver, (Edit: I forgot I had also been testing a different Kernel. Switching back to the OEM kernel made things fully normal.) but there’s no difference between UMA_AUTO and UMA_GAME_OPTIMIZED that’s obvious enough for me to discern any longer. This is a definite change from when I first got the machine.

The external monitor display is still extremely glitchy, but that’s a separate issue.

Are the differences between UMA_AUTO and UMA_GAME_OPTIMIZED documented anywhere? I couldn’t wind anything and the only difference I figured out myself, was that UMA_GAME_OPTIMIZED changes the VRAM from 512MB to 2048MB.

No, not at this time as we are tossing out BIOS releases pretty rapidly. We are continuing to track and narrow down stuff like this.

On both of my units, switching between the two modes had no difference whatsoever. I experienced none of this behavior. To dig into this deeper and in a meaningful way to identify what is different, I’d need to see your logs in a ticket.

I’m sure everyone has done this, but for others coming by want to really re-iterate the importance of this step.

I want to re-confirm with all involved, when you run uname -r, you are seeing, correct? As you must use the steps in the guide and not merely just install the OEM C kernel - it must be set in GRUB. And all updates have been installed as well.

I can see similar, on NixOS and 64GB RAM when I change this setting my VRAM goes from 512MB to 4096MB. (I don’t think this is unexpected/wrong behavior? Mayhaps in the wrong thread in that case)

Spoke to the engineering team. The benefit of UMA_GAME_OPTIMIZED is for those looking to allocate more system RAM to graphics. I will be creating a KB article in coming days to make this available to those looking for documentation.


@Matt_Hartley what is difference between UMA_AUTO and UMA_GAME_OPTIMIZED ?

Since another user answered this very same question in another thread, linking it here:



Automatic allocation vs manual. We are recommending manual.