[TRACKING] USB port stopped working: over current condition

Please create and boot to a Live Ubuntu USB. We need to know if this is a bad installation or a hardware issue. This means we need to work with a brand new, vanilla Live USB to see if this issue happens there as well.

Regarding your other thread, I echo the steps there as well. Thanks :slight_smile:

encountered this issue as well, the usb devices on the left side just stopped working until a eject and replugged in, and became unavailable after next reboot, however the ports on the right side is normal, i also have usb overcurrent in my dmesg outputs

1 Like

Definitely something to keep an eye on. Noting:

  • What was connected to said port; expansion card with USB or direct connect to USB-C.
  • TLP installed and active, split testing with it temporarily disabled to see if the issue repeats. Should have nothing to do with overcurrent obviously, but good to keep thing vanilla for tracking.

If it’s an expansion card, could be a bad card.

1 Like

The problem happens even without TLP active, on Windows, I recieve warnings about port power surge, I didn’t tested connecting USB-C directly since I didn’t have dual-USB-C cables at my hand that time, AC-in worked fine though.
but I’ve just resolved this by resetting CMOS, strange thing is, after a reset, ports(with expansion cards) weren’t available until AC plugged in on that side, now all ports worked fine.

I think I spoke too soon, the ports went overcurrent again overnight, not sure what happened, dmesg didn’t output anything about overcurrent thing, but when I reboot, the message in boot sequence showed usb overcurrent condition just as before.

Few things we can try.

  • When the over-current is happening, running journalctl -f to see things unfold in real time.

  • If we can spot what is happening, great, please post it back here. If nothing and considering this is happening in Windows, the issue is likely the expansion card itself and needs to be brought up with support.

The issue continues present, and makes this framework laptop feel crippled–because it is.

I was one happy customer when I bought it, this issue didn’t exist then, even though this laptop has only ever run Ubuntu 22.04. If it is happening across Fedora and Ubuntu, it could either be the kernel, or somehow the mere process of aging a bit is behind this. Either way, it shows poorly on Framework, the company, that all I got so far is “try this, try that”, and when returning all info asked for, I got silence for a while, then more questions, never ending, stretching for months. In the US, I would have simply returned it for a refund. Here in Europe one feels screwed over, as the only apparent solution is to buy a new motherboard + CPU for about £1000, which is out of question.

So here we are, using a crippled laptop that can’t have any ports open without one CPU being pegged. Works well even, with that CPU pegged, but it isn’t good for noise (the fan shoots up) or battery life, obviously.

Do you want to spend under £1000 in good PR? Send me a replacement motherboard. At this point it’s likely much cheaper than that, as I have an old version 11, with an 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz.

I’m not exactly sure what you mean here. If you purchased the laptop in Europe you should have a 2 year warranty (1 year better than the US). Unless you purchased it before it was available in your country (accepting all the risk of doing so) you should hopefully be able to reach out to support to ask for a replacement.

1 Like

Thank you, I have reached for support many times and so far I got nothing.

Have you ever gotten around to start a Live-ISO and see if that condition also occurs there as requested by Matt here?

If live-ISOs work, then something is clearly wrong with your installation. If they don’t that’s a sign of bad hardware and you should be able to request a new one, especially if it dragged out for months like you said and nothing rules out an hardware issue.

Hi Anachron, yes, I have live-booted the machine, to the same effect. First all fine, after a while the issue pops up.

Okay, do you use the Framework charger? Does this also happen when you are on battery?

Yes, I use the framework charger exclusively, even though I have other USB-C chargers sitting around, from Apple, that in principle I should be able to use. It is not even compulsory to buy the Framework charger, is it.

And yes this happens while on battery and while plugged to the charger.

This works on any combination of expansion port + usb c expansion card, right?

(Shuffling the power and mouse ports to see if it makes any change)

Yes, so far no difference which port gets power – plus the issue occurs in battery too. It might as well be a kernel issue, as posted here: [TRACKING] Kworker stuck at near 100% CPU usage with Ubuntu 22.04 - #28 by Albert_Cardona

I am also running Linux (Ubuntu 22.04) and have both the Kworker XHCI issue and just today noticed my left front USB port is no longer working on some devices. I normally keep the Type A adapter card in there. It’s delivering power ok, but some devices don’t respond at all. Both the framework SD card reader and a small USB one I have work ok still, but a USB device that enumerates as an ACM plays dead (it still gets power). Rebooting I see the following in my kernel buffer:

[  +0.132415] input: FRMW0001:00 32AC:0006 Wireless Radio Control as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-FRMW0001:00/0018:32AC:0006.0001/input/input5
[  +0.000166] input: FRMW0001:00 32AC:0006 Consumer Control as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-FRMW0001:00/0018:32AC:0006.0001/input/input6
[  +0.000101] hid-generic 0018:32AC:0006.0001: input,hidraw0: I2C HID v1.00 Device [FRMW0001:00 32AC:0006] on i2c-FRMW0001:00
[  +0.035330] input: PIXA3854:00 093A:0274 Mouse as /devices/pci0000:00/0000:00:15.3/i2c_designware.2/i2c-3/i2c-PIXA3854:00/0018:093A:0274.0002/input/input7
[  +0.000234] input: PIXA3854:00 093A:0274 Touchpad as /devices/pci0000:00/0000:00:15.3/i2c_designware.2/i2c-3/i2c-PIXA3854:00/0018:093A:0274.0002/input/input8
[  +0.000357] hid-generic 0018:093A:0274.0002: input,hidraw1: I2C HID v1.00 Mouse [PIXA3854:00 093A:0274] on i2c-PIXA3854:00
[  +0.035055] usb usb3-port4: over-current condition
[  +0.136107] usb usb3-port6: over-current condition
[  +0.127959] usb 3-9: new full-speed USB device number 2 using xhci_hcd
[  +0.114765] ish-hid {33AECD58-B679-4E54-9BD9-A04D34F0C226}: [hid-ish]: enum_devices_done OK, num_hid_devices=1
[  +0.002439] hid-generic 001F:8087:0AC2.0003: hidraw2: SENSOR HUB HID v2.00 Device [hid-ishtp 8087:0AC2] on 
[  +0.036426] usb 3-9: New USB device found, idVendor=27c6, idProduct=609c, bcdDevice= 1.00
[  +0.000006] usb 3-9: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  +0.000003] usb 3-9: Product: Goodix USB2.0 MISC
[  +0.000002] usb 3-9: Manufacturer: Goodix Technology Co., Ltd.
[  +0.000002] usb 3-9: SerialNumber: UID9E46B8F4_XXXX_MOC_B0

I am currently removing the xhci_pci driver on bootup to have any semblance of battery life. It does not affect any USB devices I normally use.

Any suggestions? Did I somehow lose a port on my mainboard? How can it be complaining of a over-current condition while still delivering power? (The OC error also exists even if the bay is empty)

As previously indicated and I realize it takes time because we have to gather information, issues like these need to be in a ticket.

  • Those with existing tickets, please continue through the process.
  • Those without tickets posting here, please create one.

I have just run into this issue myself. No software changes were made recently, and I was using the same cards I normally use, and suddenly both ports on the right side stopped working for anything besides storage devices.

Please see above so we can track it.

Ran into the same issue now (on my dad’s 11th gen) and opened a support ticket. Weird thing is that it seemingly happened overnight. Even disconnecting all cards the condition is still present and older kernels also don’t fix it. So either it is a hardware issue or some firmware update broke it? Anybody found a solution yet?