Trackpad stop working due to USB adapter

I am using different distributions of Linux on my Framework laptop and across all of them the audio from the built-in jack port is too noisy. In addition to that, there is also the pop every times the audio codec goes in power save mode.
All the distributions being used are either Debian or based on Debian, so no Arch or Fedora

This is a deal breaker for me, to the point of returning the device.
Though, before returning the laptop I wanted to try using a USB to jack adapter. Far from ideal, but I want to keep my money where my mouth is.

So when ever I have this USB to jack adapter plugged in the USB C port, my touchpad no longer function properly.
If I do a keyboard shortcut like ALT+SPACE, ALT+TAB, CTRL+T, CTRL+Q, etc. Basically any key combination that involves ctrl or alt, the touchpad will freeze. I can no longer move the cursor or tap, the only thing that works is the physical click from the touchpad (pressing the touchpad instead of tapping it).
To “unlock” this bug I need to press again ctrl or alt.

  • If I remove the USB adapter, the problem goes away.
  • The problem start when the laptop recognize the device as a soundcard, which does not happen right after I plug it (a few minutes after).
  • The problem start right away if I boot with the device already plugged.
  • The keyboard has no interruption what so ever, it works as intended from A to Z.

Here is what I have used, which might help to reproduce this problem / help you to figure out what is going on.



I have tried to fiddle around the different options of the touchpad driver (synaptics) too see if something in particular was making this bug. And here is what I found:

  • If Disable touchpad when typing is disabled this bug does not occur anymore.
  • Changing the related setting timeout when the above setting (Disable touchpad when typing) is enabled does not solve the problem.

As much as I like the trackpad, I’d rather disable it entirely than typing on the keyboard using chopsticks.

I am going to return this adapter and try another one. I have no way to know for sure if the problem is from a faulty device / laptop as I have a single Framework laptop to test the trackpad.
With that said the adapter worked fine on 2 different phones and 2 other computers. It also worked fine regarding audio on the Framework laptop.

I have to say that I am unsure if this is relevant as I feel this bug is niche and obscure, but regardless of that: thank you for reading me.

Have a good day

I did notice there is a thread going for this issue. Did you check that out? There are a bunch of troubleshooting ideas in there; here’s a Debian one you can try:

Just a note, I had the same problem with the trackpad not working when I plugged in the dongle for the Obsbot camera’s optional remote control.

I don’t consider this a Framework issue but one of a poorly written driver by Obsbot who admits their remote causes keys to stop working.

My solution, returned the Obsbot remote. I have no issues (so far) with all the other dongles I have (and I have a ton I use)

Some dongles have have poorly written hooks… Or act as something they should not be. So my 1st reaction is to suspect that, not the computer.

1 Like